AVS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1
Once upon a time, I made a spdif plug for my motherboard. My sound worked. The end. Not really. Basically from the get-go it just seemed to work. I could, for example, mplayer * and music would happen. I could adjust the volume using the mplayer keyboard shortcuts. Life was grand.


Now, sometimes it doesn't work. BUT, if I force it with mplayer -ao alsa:device=spdif, then it works. Or, restarting the xserver sometimes makes it work 'normally'. All the Test buttons in the ubuntu play out of the speakers. Yet it seems like the spdif doesn't just work 'normally' unless I force it somehow which means I don't have software volume control. When it is being weird like this, I can play a dvd if I use -ac hwac to tell it to use the dolby stream, but if not, it doesn't make any sound, because it's decoding to 2channel and it's not working, just like music isn't working unless I force spdif with mplayer.


I only ever want spdif, it's the only thing I have hooked up. During these phases, the spdif thing in alsamixer is never muted. I have turned off 'enable software sonud mixing'. It must be that something is stealing the spdif for itself or else I need to fiddle with some gui parameter somewhere, which annoys me. Unless it's a bug clearly there's some aspect of the sound architecture that I'm missing. Alsamixer says it's not muted; to me that means it should work.


Since switching to linux I seem to have this problem: I assume that since a command line utility like alsamixer exists, that it's all I need. But, what I fear is that there is some GUI widget that is messing me up. I had this happen with nm-applet...I was trying to use ifconfig to just go 'eth0 up' but it didn't work, because my nm-applet was set to 'disable networking'. In my mind, the gui should always bow to the command line.
 
1 - 2 of 2 Posts
Top