AVS Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
I'm sure there is probably a thread for this somewhere but i cant seem to find it.


I hooked up my 5450 and tried to play Avatar, but the only audio i could get to my receive is LCM or standard DTS, Master DTS (DTS-HD) would not show up. My receive is capable of playing DTS-HD and Dolby TrueHD as it works with a standard Blu-ray player.


I downloaded the latest driver from ATI, is there something else i need? I went through all the settings but nothing worked.


I am currently using Cyberlink PowerDVD to play the Blu-ray, but I think i am going to go to Arcsoft TotalMedia Theatre 5.


Any help would be appreciated, thanks.
 

·
Registered
Joined
·
81 Posts

Quote:
Originally Posted by Jeratt /forum/post/19513972


What OS are you running? If your running XP it's time to upgrade.

LOL no i am not running XP, that would be awful. I am running Win7 Home Premium 64 bit
 

·
Registered
Joined
·
81 Posts

·
Registered
Joined
·
461 Posts

Quote:
Originally Posted by krodami /forum/post/19514019


LOL no i am not running XP, that would be awful. I am running Win7 Home Premium 64 bit

Yeah I kind of realised that afterwards since you do seem to get DTS lol
 

·
Registered
Joined
·
1,650 Posts

Quote:
Originally Posted by imadork8317 /forum/post/19513698


I hooked up my 5450 and tried to play Avatar, but the only audio i could get to my receive is LCM or standard DTS, Master DTS (DTS-HD) would not show up. My receive is capable of playing DTS-HD and Dolby TrueHD as it works with a standard Blu-ray player.


I downloaded the latest driver from ATI, is there something else i need? I went through all the settings but nothing worked.


I am currently using Cyberlink PowerDVD to play the Blu-ray, but I think i am going to go to Arcsoft TotalMedia Theatre 5.


Any help would be appreciated, thanks.

What version of PDVD do you have?

Which AVR do you have?


Here's what you need to do:


[1] Uninstall all drivers, ATI & Realtek and reboot.

[2] Download the latest ATI CCC package

[3] Choose Custom Install and make sure that all components are selected for the installation, there is a free demo trial of a LOTR game which you can disable. Make sure the HDMI audio driver is selected.

Do not, I repeat, do not use the Realtek driver!

[4] Reboot even if it doesn't ask you to do so.

[5] Go to 'Playback Devices' in Win 7 and set 'ATI HDMI' output as the 'Default' audio device.

[6] Select 'ATI HDMI' and click on configure. Set the number of channels to 5.1.

[7] Click 'Next' to test each channel. Click 'Finish' when done.

[8] Then click on 'Properties' and check whether the HD audio codecs show up under decoders.

[9] Open TMT and go to Audio Settings.

[10] Select 'Use Original Primary Audio' as default.

[11] In PDVD select 'Non-Decoded High-Definition Audio to External Device'.

In PDVD, I believe you may have to play a movie first and then set the audio settings.


Good Luck!
 

·
Registered
Joined
·
164 Posts
I have an XFX 512MB Radeon HD 5450 video card, and I can DTS-HD and TrueHD all day with PowerDVD 10 and TotalMedia 5. It has to be your audio driver. I would remove all your ATI drivers, and install 10.10 driver. don't use the realtek audio driver unless you have a specific reason to.
 

·
Registered
Joined
·
81 Posts

Quote:
Originally Posted by hirent /forum/post/19514454


What version of PDVD do you have?

Which AVR do you have?


Here's what you need to do:


[1] Uninstall all drivers, ATI & Realtek and reboot.

[2] Download the latest ATI CCC package

[3] Choose Custom Install and make sure that all components are selected for the installation, there is a free demo trial of a LOTR game which you can disable. Make sure the HDMI audio driver is selected.

Do not, I repeat, do not use the Realtek driver!

[4] Reboot even if it doesn't ask you to do so.

[5] Go to 'Playback Devices' in Win 7 and set 'ATI HDMI' output as the 'Default' audio device.

[6] Select 'ATI HDMI' and click on configure. Set the number of channels to 5.1.

[7] Click 'Next' to test each channel. Click 'Finish' when done.

[8] Then click on 'Properties' and check whether the HD audio codecs show up under decoders.

[9] Open TMT and go to Audio Settings.

[10] Select 'Use Original Primary Audio' as default.

[11] In PDVD select 'Non-Decoded High-Definition Audio to External Device'.

In PDVD, I believe you may have to play a movie first and then set the audio settings.


Good Luck!

So i followed these instructions, and even disabled the onboard audio in the bios, but i am still only getting DTS audio out of my Pioneer VSX-1019AH


Also for some reason on TMT3 the blu ray playback is chopping and there is no audio at all


On powerdvd 10 it does play but only with DTS not DTS-HD


Do I need Shark007?


I thought ATI fixed everything so it should work without any 3rd party software
 

·
Registered
Joined
·
81 Posts

Quote:
Originally Posted by mike 01hawk /forum/post/19513775


I think you'll need "ATI HDMI Audio Device" version R2.49 @ Realtek's download site:


Try this link: http://218.210.127.131/downloads/dow...&GetDown=false


Or http://www.realtek.com.tw/DOWNLOADS/...&GetDown=false


And then update your drivers within Device Manager - > Sound device


Read thru this monster thread: http://www.avsforum.com/avs-vb/showthread.php?t=1179134

Thanks for the input Mike, but this didn't work for me.
 

·
Registered
Joined
·
81 Posts

Quote:
Originally Posted by jlachowin /forum/post/19514639


I have an XFX 512MB Radeon HD 5450 video card, and I can DTS-HD and TrueHD all day with PowerDVD 10 and TotalMedia 5. It has to be your audio driver. I would remove all your ATI drivers, and install 10.10 driver. don't use the realtek audio driver unless you have a specific reason to.

I have the 10.11 Catalyst Package installed but it still isn't working properly
 

·
Registered
Joined
·
202 Posts
This thread interests me. I've been trying to get Band of Brothers blu-ray to play DTS-HD, but only the DTS light comes on (no HD light) on my Denon 1611. I also have a 5450, and this is my only blu-ray so I can't test anything else. It doesn't even appear that the disk has a regular DTS audio track, just the DTS-HD and 2.0 options, so I'm not sure what is going on or what is happening. I'm using TMT 3, Windows 7 64bit.
 

·
Registered
Joined
·
81 Posts

Quote:
Originally Posted by andrew c /forum/post/19520885


This thread interests me. I've been trying to get Band of Brothers blu-ray to play DTS-HD, but only the DTS light comes on (no HD light) on my Denon 1611. I also have a 5450, and this is my only blu-ray so I can't test anything else. It doesn't even appear that the disk has a regular DTS audio track, just the DTS-HD and 2.0 options, so I'm not sure what is going on or what is happening. I'm using TMT 3, Windows 7 64bit.

Upgrade to TMT 5 this fixed my problem
 

·
Registered
Joined
·
202 Posts
Upgrade prices are ridiculous. I'm not paying that just to get a silly light on my receiver to light up. There has to be another way, because I'm pretty sure others have gotten it to work with TMT 3. Not that big of a deal to me, since sound is coming out of all speakers. But I guess it is the principal that I bought a receiver with all the new codecs, I bought a blu-ray drive, and player software, for all the latest and greatest, yet it still doesn't seem to work (and to add insult to injury, the above post is telling me, just pay a little more and it will work). That's baloney.
 
1 - 14 of 14 Posts
Top