AVS Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,009 Posts
Discussion Starter #1
So I've been playing around with a new HTPC I've recently built and experimenting with XBMC and DVDFab but I've hit a snag I can't figure out... The (AMD/ATI) Sapphire GPU- 7970's HDMI output to the Pioneer Elite VSX-52 doesn't work for audio.


I thought maybe it's the AVR but it's the card more specifically I think it's the driver. The HDMI appears under the sound in the control panel but it's shows as grayed out (not hooked up etc..) I did download a realtek driver (V.270 I think ) that would allow me to get stereo (2 channel and Analog sound only) sound to work but I can't figure out how to get digital 7 channel??


I was up to 3 am last night messing with it and installed about 10 different ATI drivers but nothing seems to work... anyone have any ideas?


Do I have to use the optical sound from the MOBO and just stick with the Video from the Graphics card HDMI in order to get full 7.1 channel digital sound?


Cheers

Calvin
 

·
Registered
Joined
·
1,650 Posts
Is pass-through turned OFF in the AVR? Pass-through is used to send the signal from the source to the TV even if the AVR is OFF.

If pass-through is ON, then the HTPC will see the two TV speakers and will not allow you to set more than two speakers.


Make sure you have the AMD HDMI driver selected during installation.

After installation, configure AMD HDMI Audio Device and see if you can set 7.1 speakers.
 

·
Premium Member
Joined
·
2,009 Posts
Discussion Starter #3
hirent


Thanks for the response. My main issue i can't seem to get the AMD HDMI audio drivers to install and show the sound devices properly so they can be selected as the default...it's very confusing and from a google search I'm not alone there are a lot of folks wrestling with this one...I'll try the pass through suggestion though thanks that can't hurt!


Cheers

Calvin
 

·
Premium Member
Joined
·
2,009 Posts
Discussion Starter #4
Problem solved for some reason the 5th time I reinstalled the driver the HDMI allowed selection and everything works now:confused: Oh well alls well that ends well I guess. Thanks for posts


Cheers

Calvin
 
1 - 4 of 4 Posts
Top