AVS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 20 inch samsung tv and have had it for about 8 months and just a few days ago I was watching a movie with my Philips DVD player that is about the same age and notice a white pixel right in the middle of the screen. Its only there when I use the dvd player but when I hooked the dvd player to my other tv its not there. So is this being caused by the tv or dvd player and is there anything I can do about it.

Thanks
 

·
Registered
Joined
·
1,541 Posts
There is no such thing as stuck pixel in CRT TV. If you have a LCD TV go to the LCD TV

section in this forum.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Well I guess its not a pixel but there is a white spot right in the middle of the tv only when I use the dvd player.
 

·
Registered
Joined
·
6 Posts
I know this is an old thread but I have the same issue.


Philips progressive scan DVD player through component produces a white dot in the middle of the screen. (Not visible with other sources - TV is a Sony Wega 30" KV30HS420)


I know CRTs shouldn't get stuck pixels but any ideas what is doing this or how to fix it? Thanks
 

·
Registered
Joined
·
21,398 Posts
In both cases... it must be the Philips DVD player. Get a different DVD player (or borrow one?) and see if the problem is resolved.
 

·
Registered
Joined
·
6 Posts
Thanks! I'll try that tonight. I was kind of thinking (and hoping) it was the DVD player after I posted and thought about it more since all the other sources seem ok. (But, none of them are using the component inputs) I kinda thought it might be component input specific but that would be strange. We'll see what happens tonight with it.


Thanks again
 

·
Registered
Joined
·
21,398 Posts
Yeah... seems kind of strange that you and the OP both have the same symptoms and the only thing in commom is a Philips DVD player.


Good luck. Hope it works out.
 

·
Registered
Joined
·
6 Posts
Well just before returning the player I decided to switch the component video inputs to the other set of component inputs on the TV... It's fixed. I didn't try switching back to see if just those inputs were bad. Maybe tomorrow I will.
 
1 - 8 of 8 Posts
Top