AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
Well as you know, I was one of the members that picked up a new 50 inch LCOS from Shop at Home last April. The first one had a burn in on screen and they sent me a new set after just 1 week of use.


Well this one is now having a problem after only 8 months. I turned it on today and the picture has a dark and very red hue to everything. I first thought it my DishHD receiver but even hooked a stand alone DVD player to both Component and composite inputs on tv without going thru my Onkyo rec. No help. I reset on remote the settings and still a dark granny red picture.


I took off side plate and see big bulb is still lit up. So I am preplexed as to what may be wrong?


TV is still under warrenty but what a pain it was last time to have to put 1500 buck on my CC until my old TV got returned to them. Plus had to wait weeks.


Is this something I can fix>?


HELP!
 

·
Registered
Joined
·
7,233 Posts
Just a thought to check the seating of your component cables. If one of the RGB colors isn't fully connected the range will have a dominance of one of the colors and lack of one.


I had a similar event when I hooked up Xbox and the game awhile back and had a green tint - the red was not fully connected even though it felt like it was and green became dominant and it wasn't even an SXRD
. As it was a shooter game and new I thought it was part of the game theme until I popped in a very colorful game - Serious Sam II and there was no RED and Green was dominant. Fully reseated the components and the event was fixed for the Xbox component hookup. Can't say this is your issue but through the process of elimination you may save a service call and expedite a resolution - if not you've taken away one source the Service Tech doesn't need to check.


Hopefully, it's something simple like this and easily correctable and not other issues that require serious internal parts replacement. Good Luck!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top