AVS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
So I have a Toshiba 43hx71 that is about 7 years old. With the boards help I had the convergence fixed about 2-3 years ago for $350 +


I now get the blinking red power button and no picture. Owners manual say's nothing . During a search I have read lamp failures are common. Which lamp are we talking about? Other threads talk about the power supply circuit board being bad.

I need to keep this tv because it fits the cabinet perfect ( see pic) and the new TVs I have looked at in 42" are not a good fit. I am going to try to diagnose the problem myself .. would you suggest the power or the lam[ is the problem.

TV turns on for a minute - blinks and goes off with no pic and the red power light blinks. Letting it sit overnight used to fix it but now we bet nuthin.


all opinions apreciated
 

·
Registered
Joined
·
189 Posts

Quote:
Originally Posted by Bennett3 /forum/post/19598955


So I have a Toshiba 43hx71 that is about 7 years old. With the boards help I had the convergence fixed about 2-3 years ago for $350 +


I now get the blinking red power button and no picture. Owners manual say's nothing . During a search I have read lamp failures are common. Which lamp are we talking about? Other threads talk about the power supply circuit board being bad.

I need to keep this tv because it fits the cabinet perfect ( see pic) and the new TVs I have looked at in 42" are not a good fit. I am going to try to diagnose the problem myself .. would you suggest the power or the lam[ is the problem.

TV turns on for a minute - blinks and goes off with no pic and the red power light blinks. Letting it sit overnight used to fix it but now we bet nuthin.


all opinions apreciated

You may not get a lot of sympathy from the forum since you knew something was wrong with it and continued to use it (letting it sit overnight). That may have caused either significantly more expensive damage or made the problem more complicated. How long did you do that?


If letting it sit overnight fixed the problem, it was probably originally a simple power supply issue. Now, it is probably much worse.


Without any info...probably now both a power supply problem and a convergence board problem or other.


Good luck.


Joe
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·

Quote:
Originally Posted by jgruessing68 /forum/post/19600020


You may not get a lot of sympathy from the forum since you knew something was wrong with it and continued to use it (letting it sit overnight). That may have caused either significantly more expensive damage or made the problem more complicated. How long did you do that?

If letting it sit overnight fixed the problem, it was probably originally a simple power supply issue. Now, it is probably much worse.


Joe

It will power up for a few minutes and go off.. the picture is fine for those few minutes.

why would turning it on with a failing power supply mess up the convergence?

just don't see a domino effect...I only powered it up 3 times after the problem. 2 weeks now it sits unused. Time for another TV I guess.
 

·
Registered
Joined
·
189 Posts

Quote:
Originally Posted by Bennett3 /forum/post/19600107


It will power up for a few minutes and go off.. the picture is fine for those few minutes.

why would turning it on with a failing power supply mess up the convergence?

just don't see a domino effect...I only powered it up 3 times after the problem. 2 weeks now it sits unused. Time for another TV I guess.

Quite simple. It doesn't mess up the convergence directly...it damages the convergence or deflection boards. If the power supply is going bad, how do you know what voltages it is sending to the other boards? You don't.


If the set is still powering up and is ok for a few minutes, you may be lucky. It's probably just the PS board. It takes a few minutes for the parts on the board to warm up enough to invoke the problem. It may be as simple as a cold-solder joint. Stop using it and have a tech look at it.


Joe
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
thanks for the reply... what is the "PS" board?


Power supply?...... I got nothing to lose checking it out myself. I put it up for sale for $20 and never got a call so before it goes to the dump I want to give it a shot...

any links or info where I can get a schematic?
 

·
Registered
Joined
·
1 Posts
I have a Toshiba 43HX71 for 8 years.

No power on only with a red blinking LED light.

Not always the STK392-110 convergent IC problem.

Open the lower-back cover, goto the far-left corner.
Attachment 207114


On the big-floor PCB, try to locate the black SOC Fuses.

Total 4 (5Ax2, 2A, 1.25A) around a group of purple Capacitors.
Attachment 207113


These bad FUSES are all with infinite (1) resistance unit.
Attachment 207112

Should be easily picked up with a Volt-Ohm-Milliammeter.


Replaced and done. Good Luck to all.


Allen 2011/3/27


 
1 - 6 of 6 Posts
Top