AVS Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently connected my desktop to a Samsung LT-P-2227W HDTV, and cannot get Half-life 2 to run anymore.


When I start HL2, program quits because settings are incorrect, and states that HL2 is reverting to default settings. Default settings then do not work so it goes to safe mode. That fails, and it then tells me I need a graphics card which supports direct X 7.


For graphics card, I'm using NVidia GeForce FX 5200. Connection is via DVI cable.


Would greatly appreciate anyone's assistance.
 

·
Registered
Joined
·
2,010 Posts
Try temporarily hooking the PC up to a regular monitor and running the game. That may reset it and fix the problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the tips. Unfortunately, HL2 is still "failing to set video mode."


Any other thoughts? I'd think about shelling out for a better card, but don't want to find out I've got some larger problems.
 

·
Registered
Joined
·
8,729 Posts
Unfortunately you need a new card for DirectX 9, or can run in DirectX 8 or 8.1. Even though your card should default to 8, it is possible that the game is trying to run in DirectX 9. Since you can't run the game, type mat_dxlevel 80 in the command line in the Half-Life 2 Steam launch options.
 

·
Registered
Joined
·
2,010 Posts
Unistall and reinstall Steam.
 

·
Registered
Joined
·
8,729 Posts
Quote:
Originally Posted by elliottblanchard
Hmm. mat_dxlevel 80 didn't work. Also bit confused since I thought I had been up and running with directX 9.0c.
Hot Hardware did an article where although the menu said DirectX 9.0C, the game was actually running their FX 5200 in DirectX 8.0. Try what chris5977 suggested.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top