AVS Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter · #1 ·
1. Disable MPD100 capture device in the Device manager.


2. Install Hauppage Card with MCE drivers, Reboot. ( Will probably uninstall MPD100 driver so when PNP detects the TWO multimedia devices, only install the Hauppage card.


3. Look for the device with the question mark ( should be the MDP100 device.) Disable it.


4.Once its disabled right click on it, Update Drivers by pointing to the current MyHD driver.


At this point you should have the Hauppage WinTV PVR device installed and working and the MDP100 device with a red X. Open MCE and confirm MyTV is working.


In order to have them work together I automated the disabling of the MyHD driver with Girder.


1. Download Devcon from the link listed. Unzip to wherever.

DEVCON


2. Setup two commands in Girder to enable and disable the MDP 100 driver.

use the "execute" option and browse to where you put the devcon.exe file.


3. in the Step Size box place this


disable pci\\ven_544*


and of course to enable use


enable pci\\ven_544*


This should be the hardware id of the MyHD card. You can do a search with the DevCon.exe file using Devcon find pci\\* line to get the specifics of your card.


Now assign buttons in Girder for your remote and you are good to go.


Enjoy. Its a hack but its the best I could do in an hour or two. Open to alternatives if anyone has a better idea.


Dave
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #3 ·
The fix works more reliably in the Device Manager if you disable both cards then enable the card you want to use.


I created a bat file that executes in Girder that does this. Works great.


Now to figure out how to use both cards at the same time.


Hmmm


Dave
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top