AVS Forum banner
  • Our native mobile app has a new name: Fora Communities. Learn more.

How to use keyframing in Sony Vegas?

3413 Views 6 Replies 2 Participants Last post by  Don Landis
Due to my blurring issue with 3d footage from my TD10 I want to try and render a disc differently in Vegas, I think I need a more accurate encode than default and its been mentioned that using a keyframe every 1 second gives a more accurate result, I want to try it but cant for the life of me find out how to adjust this in Vegas, any ideas?
1 - 7 of 7 Posts
Depending on your rendering format you may be able to adjust the keyframing for rendering. This is not the same keyframing as you do for a change in video or audio effects along the timeline. The setting is located in the "render as" section and under video custom settings. RTFM
Type a value in the box to specify the interval between video keyframes. A keyframe is a frame that contains all data required to draw a frame. When encoding low-motion video, you can use a setting near 20 seconds. When encoding high-motion video, you should insert keyframes more frequently.

Decreasing the Seconds per keyframe value will increase the file size and bandwidth required to play your file.

This may or may not help your blurring problem. Depends on what is causing the blurring.

Note to all, I really wish people would read the manual and help files for Vegas. AVS is not a classroom on how to edit video. So many of these questions are answered in the help files. Learn to do a search by key word. Do YOU know how to use the "?" in Vegas?
See less See more
Thanks for the reply.

As stated I did search through stuff inc the help files within Vegas but couldnt come up with anything.

Obviously my issue needs investigating further but its definately something to do with Vegas and how its encoding it. Ive never used the 'render as' option, I need to look into it, is it possible to create a disc image this way? I suppose if it is then I can just use that option to create a custom template and use that from creating the discs. It is an odd problem though, I cant get my head round why it caused blurring on those scenes when I created the whole 2 hr disc but just creating a disc from one scene which was blurred and it came out perfect, all using the same basic settings that you kindly gave me in another thread.
There seems to be some huge holes in your understanding of how Vegas work flow works. You asked about Keyframing, in reference to reducing the blur on rendered images but mention that the blur results are from your disk burning process. The "seconds per keyframe" setting only pertains to certain renderings such as wmv video files and is one of the parameters that is used to control the bandwidth / file size of the wmv file vs. quality. You can set it high ( more blurry) for smaller files and low to 1 second per keyframe for larger file size ( less blurry ) In the case of rendering to a file for disk burning, there is no "seconds per keyframe" setting because that data is represented in each video frame anyway. In otherwords, it's fixed at the highest setting anyway.

Now that I think I know where your head is at, I believe you may have pulled a piece of information out of a different context and tried to apply it where it didn't belong. Not uncommon around these parts.
But its typical of many who jump in and use Vegas without understanding how this stuff works. We're all guilty of it to a degree.

Of course this doesn't solve your problem but then it does get you off the wrong track for what you want to accomplish.
See less See more
You could well be right, maybe i've misunderstood all about keyframing, from something you mentioned about using a keyframe every 1 second making the encode more accurate.

I just cant really work it out, maybe its down to the fact the cam is playing the source file at 50i and the Vegas encode is at 50p? I just dont know, all I do know is that some scenes have this slight blur yet when watching the same scene directly from the cam (and thus the source file) its perfect with no blurring. The odd thing is that its only on some scenes though.
So as i'm understanding it, as the disk burning method uses the highest settings anyway then there is pretty much nothing else to do and just live with it.

I think i'm going to run the disk burn proccess again and see what happens.
There is nothing to do with respect to seconds per keyframe when it comes to the MVC rendering process used for disk burning. Your blurr problem is caused by something else.

I recall another AVS poster from PAL country complained in the past about a similar issue with the 50p frame rate. You two could be talking about the same problem.

Personally, I use this rule of thumb- For videos using very little motion in the video scenes, I render using 1024 24p x 1920. For videos that have consistent motion in the scenes such as pans, and object motion like cars moving down the road etc. I use 720 60p 1280. Rendering. In my thinking 50p would not be as blur free as 60p.
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.