AVS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I recently got a new motherboard with integrated Intel g35 and I am using its HDMI to connect to my 720p Samsung DLP. There seems to be a issue with the driver or could be there is some setting I am unaware of: whenever I changed sources on the TV from say from HDMI_1 to HDMI_2 (g35 is hooked up to HDMI_1), the g35 would change its resolution from 720p to 800x600, and when I switched back to HDMI_1, g35 resolution would stay at 800x600. The same occurs if I would to turn the TV OFF and ON again. It is quite annoying, any ideas?
 

·
Registered
Joined
·
123 Posts

·
Registered
Joined
·
1,769 Posts

Quote:
Originally Posted by crappy_htpc /forum/post/14340997


I recently got a new motherboard with integrated Intel g35 and I am using its HDMI to connect to my 720p Samsung DLP. There seems to be a issue with the driver or could be there is some setting I am unaware of: whenever I changed sources on the TV from say from HDMI_1 to HDMI_2 (g35 is hooked up to HDMI_1), the g35 would change its resolution from 720p to 800x600, and when I switched back to HDMI_1, g35 resolution would stay at 800x600. The same occurs if I would to turn the TV OFF and ON again. It is quite annoying, any ideas?

Yes. This is a known issue with G35 systems.


there's two fixes.


1. Update Graphics Drivers to the latest. This was fixed in 15.8 but 15.9 will work better.


2. Disable the IGFXPERS process. This is where the bug was. DPlettner found this work around. You can permanently disable it by deleting the entry from the registry. The key can be found in HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\Windows\\CurrentVer sion \\Run

look for the "Persistence=C:\\Windows\\system32\\igfxpers.exe" entry and delete it.


Wo0zy
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
thanks, guys!

i am using XP and already got the latest driver, and the issue hasn't been fixed yet, but removing the IGFXPERS process fixed the issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
i didn't test it thoroughly last time, it only fixed the issue from changing sources. if i start the pc from cold boot the issue still exists, it won't default to 720p resolution consistently.. ideas?
 

·
Registered
Joined
·
1,769 Posts
Can you confirm the driver version you are running?


Did you delete the igfxpers entry from the registry or just end the process?


Like I said, this issue was flagged as fixed a while ago and afaik it was. Check out the G35 thread. There's lots of references to it.


I have heard that a few people still experience random behaviour when vmc is running fullscreen but i don't know of anyone else having problems with desktop resolution changes any more. Sorry.


Wo0zy
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
i am using the latest XP driver from intel website, version 14.34.


i did remove igfxpers from the registry, and it does fixed the source changing issue i have mentioned above, but during cold boot, g35 won't lock to 720p after windoze has loaded.
 
1 - 7 of 7 Posts
Top