AVS Forum banner

41 - 60 of 63 Posts

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #41 · (Edited)
New Release: v1.2.1

Notes

v1.2.1
  • Command and remote editor usability improvements
  • Documentation link now opens in web browser (easier to keep open for reference)
Download Release Here (v1.2.1)
 

·
Registered
Joined
·
26 Posts
Hello! Awesome work ! Congrat ! One question. Any chance for Digital Projection projectors (Barco) remote ? Thanks a lot

Br, Zoltán
 

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #44 · (Edited)
Hello! Awesome work ! Congrat ! One question. Any chance for Digital Projection projectors (Barco) remote ? Thanks a lot

Br, Zoltán
Good question heh.

I’ll look up the spec and see how difficult it is.

If I try adding it I’m assuming you can test it then?

Do you have a specific Barco projector in mind? It looks like they may have a few communication protocols. I could try supporting at least the model(s) you plan on using.
 

·
Registered
Joined
·
26 Posts
Good question heh.

I’ll look up the spec and see how difficult it is.

If I try adding it I’m assuming you can test it then?

Do you have a specific Barco projector in mind? It looks like they may have a few communication protocols. I could try supporting at least the model(s) you plan on using.
Hello! I attached the pdf about the communication protocol I tried to use. The switching on/off part is working from Home Assistant, but, meanwhile the other buttons work as well, just only once, after the first button press the projector freezes, I have to restart it. I think it has to do with the minimum timing between button presses. Here, in Hungary, there are a couple of guys who own this kind of projector, thus this support would be very useful. Here is the rest http call I do from HA, without timing.
This works: http://192.168.130.35:1025/:pOWR1’CR’
And yes I can test it and I have this projector: Digital Projection dVision 35 WQXGA

Thanks a lot for your support ! :)

Zoltan
 

Attachments

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #46 · (Edited)
Hello! I attached the pdf about the communication protocol I tried to use. The switching on/off part is working from Home Assistant, but, meanwhile the other buttons work as well, just only once, after the first button press the projector freezes, I have to restart it. I think it has to do with the minimum timing between button presses. Here, in Hungary, there are a couple of guys who own this kind of projector, thus this support would be very useful. Here is the rest http call I do from HA, without timing.
This works: http://192.168.130.35:1025/:pOWR1’CR’
And yes I can test it and I have this projector: Digital Projection dVision 35 WQXGA

Thanks a lot for your support ! :)

Zoltan
Thanks for the PDF.

At first look this seems like a really simple communication protocol.

I should be able to try this tonight.
 

·
Registered
Joined
·
26 Posts
Thanks for the PDF.

At first look this seems like a really simple communication protocol.

I should be able to try this tonight.
Hello,

Thanks for your effort ! By the way, the denon part is not working for me for some reason. Any experience with it? I did set up the dm device, i created the buttons, but did not work. I place here the xml for the commands, maybe You can see something I did wrong.
{
"RemoteID": 2,
"RemoteName": "Denon",
"RemoteItems": [
{
"ItemType": 1,
"Label": "Denon"
},
{
"ItemType": 2,
"Label": "PowerOn",
"RelativeSize": 1,
"Color": "Green",
"Commands": [
{
"DeviceName": "dm",
"Cmd": "PWON"
}
]
},
{
"ItemType": 2,
"Label": "PowerOff",
"RelativeSize": 1,
"Color": "Red",
"Commands": [
{
"DeviceName": "dm",
"Cmd": "ZMOFF"
}
]
}
]
}
 

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #48 ·
Hello,

Thanks for your effort ! By the way, the denon part is not working for me for some reason. Any experience with it? I did set up the dm device, i created the buttons, but did not work. I place here the xml for the commands, maybe You can see something I did wrong.
{
"RemoteID": 2,
"RemoteName": "Denon",
"RemoteItems": [
{
"ItemType": 1,
"Label": "Denon"
},
{
"ItemType": 2,
"Label": "PowerOn",
"RelativeSize": 1,
"Color": "Green",
"Commands": [
{
"DeviceName": "dm",
"Cmd": "PWON"
}
]
},
{
"ItemType": 2,
"Label": "PowerOff",
"RelativeSize": 1,
"Color": "Red",
"Commands": [
{
"DeviceName": "dm",
"Cmd": "ZMOFF"
}
]
}
]
}
Hmm, it looks OK to me.

Many people are using the Denon control as well as I use it on my own system all the time and I have never heard of any problems with it.

I am not entirely sure how you have everything set up, but what does your HTPCRemoteDevices.txt look like?

Try opening this URL to turn on your Denon just to see that things are working.


Replace computerIP and DenonIP

Also try enabling the show errors option in HTPCRemote.
 

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #49 ·
Hello! Awesome work ! Congrat ! One question. Any chance for Digital Projection projectors (Barco) remote ? Thanks a lot

Br, Zoltán
Try this:

Commands are like:
POWR1 (power on)
POWR0 (power off)
BRIG 60 (brightness 60)

Commands as defined in the PDF doc.

No ":" before the command (I built it in) and no separate param. Just put all the command text into cmd box.
 

·
Registered
Joined
·
26 Posts
Try this:

Commands are like:
POWR1 (power on)
POWR0 (power off)
BRIG 60 (brightness 60)

Commands as defined in the PDF doc.

No ":" before the command (I built it in) and no separate param. Just put all the command text into cmd box.
Hi,

Thanks for the fast response and beta. Unfortunately the exe file is blocked by my antivirus, meanwhile the original from the github is ok. :(
 

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #51 ·
Hi,

Thanks for the fast response and beta. Unfortunately the exe file is blocked by my antivirus, meanwhile the original from the github is ok. :(
Try now.
 

·
Registered
Joined
·
26 Posts

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #53 ·

·
Registered
Joined
·
26 Posts

·
Registered
Joined
·
26 Posts

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #56 · (Edited)
FYI
The version 1.3 is ok, it has not got this problem
There’s nothing more I can do. All I added was a few lines of code similar to the others.

Why can’t you tell AV to ignore it?

I just tried downloading this on my PC at work which has AV and it did not have a problem with it.
 

·
Registered
Joined
·
26 Posts
There’s nothing more I can do. All I added was a few lines of code similar to the others.

Why can’t you tell AV to ignore it?

I just tried downloading this on my PC at work which has AV and it did not have a problem with it.
I just received a message from avast center and it said it is ok. :) I will start tesing after I finished my work !
Thanks a bunch
 

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #58 ·
Thanks, yeah I wish it was simpler, but Antivirus is just too overly sensitive these days IMO and in cases like this where it detects something it doesn't like there is nothing someone like me can do about it.

Unless maybe go through a ton of work to get it added to the white list of every AV company haha. Maybe makes sense for a big commercial app, but not for the little guys or test app versions.
 

·
Registered
Joined
·
26 Posts
Thanks, yeah I wish it was simpler, but Antivirus is just too overly sensitive these days IMO and in cases like this where it detects something it doesn't like there is nothing someone like me can do about it.

Unless maybe go through a ton of work to get it added to the white list of every AV company haha. Maybe makes sense for a big commercial app, but not for the little guys or test app versions.
Thanks, yeah I wish it was simpler, but Antivirus is just too overly sensitive these days IMO and in cases like this where it detects something it doesn't like there is nothing someone like me can do about it.

Unless maybe go through a ton of work to get it added to the white list of every AV company haha. Maybe makes sense for a big commercial app, but not for the little guys or test app versions.
Hi

It does not work. I used the following settings
{
"RemoteID": 3,
"RemoteName": "PROJI",
"RemoteItems": [
{
"ItemType": 1,
"Label": "Proji"
},
{
"ItemType": 2,
"Label": "PowerOn",
"RelativeSize": 1,
"Color": "Green",
"Commands": [
{
"DeviceName": "dpbarco",
"Cmd": "POWR1"
}
]
},
{
"ItemType": 2,
"Label": "PowerOff",
"RelativeSize": 1,
"Color": "Red",
"Commands": [
{
"DeviceName": "dpbarco",
"Cmd": "POWR0"
}
]
}
]
}
 

·
Registered
JVC NX5 at 140", Denon X4200W (5.1.2) with Axiom Audio speakers + Bass Shakers
Joined
·
2,684 Posts
Discussion Starter · #60 ·
Hi

It does not work. I used the following settings
{
"RemoteID": 3,
"RemoteName": "PROJI",
"RemoteItems": [
{
"ItemType": 1,
"Label": "Proji"
},
{
"ItemType": 2,
"Label": "PowerOn",
"RelativeSize": 1,
"Color": "Green",
"Commands": [
{
"DeviceName": "dpbarco",
"Cmd": "POWR1"
}
]
},
{
"ItemType": 2,
"Label": "PowerOff",
"RelativeSize": 1,
"Color": "Red",
"Commands": [
{
"DeviceName": "dpbarco",
"Cmd": "POWR0"
}
]
}
]
}
I would suggest that you get the Denon remote working first since I know that one works.

If the Denon remote does not work for you, then you have larger problems with your setup and no other remotes will work for the same reason.

You are the first person I have heard who has run into a problem of a remote not working so I am not quite sure what to suggest to you yet.

Did you try showing errors?
 
41 - 60 of 63 Posts
Top