AVS Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
315 Posts
Discussion Starter · #1 ·
I just noticed a strange problem that appears to be affecting my ide drives. I copied some recorded shows from my htpc so I could cut out the commericals. I went to edit the first one and it showed a lot of blocks and tiles. I checked the mpg file with WM9 and it would stutter, stop, and fail to play.


I didn't think much of it until I noticed that several other files had this problem. Thinking it was a problem with my pc I copied the files back over to the htpc. Some of them were now playing fine - even when I played them from my pc (they play over the network).


I'm thinking WM9 is fine since the mpg can play over the network. The files are fine since I can play them from the htpc. I don't think it has anything to do with a specific drive because I tried copying from one local drive to another and the mpg still didn't play. Also, some of the other mpg files that I have on the drive appear to play fine.


I replaced the ide cable on the drive I use to edit files. I also switched to a different ide connection. Nothing else appears to be giving me a problem since the pc boots fine and applications run. I did a quick disk check on the drive an no errors were reported. I've copied several files to and from the drives and haven't seen any errors so I think the disk is physically fine.


At this point I don't know what to look at. The only thing to change recently is the new WD200 and it's actually been there for about a month. It's like there is something wrong with my ide controller or something. The strangest thing is that I can copy an mpg file to my pc and it's appears corrupted, I copy the same file to the htpc and play it over the network and it plays just fine.


Can anyone suggest some more debugging ideas?
 

·
Registered
Joined
·
779 Posts
This could be several things....


1) make sure your IDE drive isn't in PIO mode vs. DMA.


You can check this in control panel ->system ->hardware -> device manager -> IDE ATA/ATAPI controllers


Check all of the channels for their "transfer mode". You want them to be in DMA mode.


2) Bad codec


Have you installed any strange codec's on your desktop pc? Could be a decocding error.


3) Horsepower.


You didn't mention the specs of these machines.


4) try another viewer.


If you have powerdvd winddvd or ndvd, try playing the mpg's using these programs. They have their own graphedit codec's and will ignore whatever your computer has as default.


5) burn to cdrom


If it plays from the cdrom, there is an issue with your drive, althogh I would be very surprised by this.


6) check WM9 settings


Do you have "video smoothing on?" this and other options will effect mpeg playback.


in WM9, go to tools -> options -> performance -> advanced


If you can choose "hardware" decoder, do it. uncheck "use video smoothing" You can also play ith the video mixing options
 

·
Registered
Joined
·
315 Posts
Discussion Starter · #5 ·
Thanks for all the tips!! I can't want to go home and try them.


I'm not very optimistic though because everything was working fine (even as early as yesterday) and I haven't installed anything in the last few weeks.


I forgot my specs aren't in my sig. Here they are just for fun:


abit kr7a (it's raid but I'm not using raid)

amd tbred 2000+

1 gb micron 2700 ram

2 wd 80 hd

1 wd 200 hd

gf4 ti200
 

·
Registered
Joined
·
315 Posts
Discussion Starter · #6 ·
I ran HDTach and I need some help figuring out what it says. Here's the results


drive 0 (wd 80gb no problems)

max=50

min=16.9

avg=41

cpu=25.3%


drive 1 (wd 80gb no problems)

max=50

min=20.2

avg=39

cpu=24.2%


drive 2 (wd 200gb problems??)

max=59

min=1.9

avg=37

cpu=6.1%


The wd 200gb drive just fell off the chart after about 130gb and flatlined all the way to the end. What does that mean?
 

·
Registered
Joined
·
315 Posts
Discussion Starter · #7 ·
I moved the 200 gb hard drive off my IDE3 channel (one that can be used for raid) and put it on ide2 with my dvd burner. I don't see the huge drop in HDTach now. The numbers end up similar to the other drives.


I should also mention that I did a full chkdsk and it ended up taking a few hours to chug through the final two steps.


Maybe I need to split the drive into separate partitions?
 

·
Registered
Joined
·
779 Posts
I still can't believe this was a HD problem. a mpeg, even at a huge bitrate would take about 1/100th the bandwidth of a typical ATA drive connection


I would look at your controller to see if you are in PIO mode.
 

·
Registered
Joined
·
315 Posts
Discussion Starter · #9 ·
I forgot to mention, the IDE 1 and 2 were using DMA mode. The Raid controller didn't show the mode using the device manager - it just wasn't an option. I did check it out in the bios and it said ata100 but that's about it.


I'm finding more files on the 200gb drive to be corrupted. Now they crash Explorer and WM9 when I try to play them. It could be the chkdsk I did on the drive though.
 

·
Registered
Joined
·
315 Posts
Discussion Starter · #10 ·
1 - 10 of 10 Posts
Status
Not open for further replies.
Top