AVS Forum banner

Status
Not open for further replies.
1 - 20 of 34 Posts

·
Registered
Joined
·
453 Posts
Discussion Starter · #1 ·
I need some help resolving a network problem. My HTPC is running Win98SE and is on a home network with another Win98SE machine and a Win2K machine. At the end of last year, I was able to get all machines to see the drives on all the other machines. With the addition of a D-Link 704 router between my cable modem and my network, I have lost the ability of my Win2K machine to see my Win98SE disks ("network error" is what I get when I use windows explorer to try to look at them). My Win98SE machines can still see each other, as well as the Win2K disk. I heard that this is due to the Win2K machine broadcasting its system identity, whereas the Win98SE machines do not, but I don't know how to resolve this problem. I don't have a DNS or WINS server, and the router has DHCP enabled to hand out internal TCP/IP addresses. I have TCP/IP and NetBEUI protocols on all machines, File and Printer sharing, and matching guest ids. All machines can access the internet. Thanks!


Al
 

·
Registered
Joined
·
186 Posts
Try this, it will eliminate all name resolution issues as being the problem.

Start->Run->

Type in the UNC of a Win98 machine, but use its IP address instead of the name.


IE, if your win98 machine is named "Computer1" and its IP address is 192.168.0.3, then You would type>

\\\\192.168.0.3


From a DOS prompt you could also do a "net view". From the above IP>

net view 192.168.0.3


This will let You see all shares on the machine. Let me know how it goes.
 

·
Registered
Joined
·
1,390 Posts
I assume that before you got the router, you were using the w2k box with internet connection sharing to connect the cable modem to the hub. This required 2 network cards in the w2k box.


If this is the case, then what has likely happened is that Windows File Sharing was only enabled on one of the 2 adapters in your w2k box. Once you connected the w2k box to the hub, it is likely that you used the adapter that used to connect to the cable modem, hence Windows File Sharing is not activated.


Go to the properties for the adapter that is in use on the w2k box. Make sure that Windows File Sharing is enabled.
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #4 ·
deepcover,


Since I'm using DHCP, my IP will vary from session to session, so this sounds like it might be kludgy, if I have to do it everytime.


EricN,


No, I only had one NIC in each box. At the time, I was trying a software solution to internet sharing, but decided that a router gave me what I wanted and a firewall as well.


Al
 

·
Registered
Joined
·
1,390 Posts
You'll need to give a little more detail on your setup before you bought the router, since settings that were necessary at the time may be causing issues now.
 

·
Registered
Joined
·
38 Posts
1.) Goto Start>Settings>Control Panel>Users and Password


2.) Click the Advanced Tab


3.) Click Advanced Button


4.) Click the Users Folder


5.) Click the Action Menu>New User


6.) Type in the info about the computer that will be accessing it, so the user name and login password (if applicable) of the win98 computer


*You must add a user for each person trying to access this computer.


Hope this works, think that is what I did before, now I'm using XP so it just asks me for the username and password.
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #7 ·
EricN,


I don't remember all the things I did to get it to work in the previous setup - otherwise, I would probably have solved it by now. I'm hoping that someone who knows how things ought to be set up would be able to point me in the right direction. If you know of things I should be checking, I'll be glad to look.


cardguy1000,


I just added a new user and password to both machines, but I still can't access the Win98SE machine from the Win2K machine. I get a prompt for a network password, and the one I just created doesn't let me thru.


Al
 

·
Registered
Joined
·
1,564 Posts
If you turn everything off, go out for a beer, return and when powered on, it still won't work, something is not configured correctly on at least one of the machines.


Not 30 minutes ago, I said, on our forum, "windows networking is, at best, fragile."


I'm not sure of MS's terminology, but their machines compete for who is the authority-of-the-moment.


In your case, everything should be configured to use dhcp, the default gateway should be the same, and under [something Microsoft], everthing should be in the same workgroup. The terminology keeps changing from one Windows OS to the next and they usurp terminology like "domain" that has been used for years in TCP/IP networking.
 

·
Registered
Joined
·
182 Posts
Al,


The suggestion that deepcover gave is a good troubleshooting step to help narrow down what the problem is. Run winipcfg on your 98 box to find out what its IP address is and then try pinging it from your 2000 box and then try what deepcover suggested. I would highly recommend that you remove the NetBEUI protocol from all your machines. If IP is configured correctly there is no need for NetBEUI, and can only make troubleshooting more difficult. There was another member on the forum that had a very similar problem as yours that I had several posts with. You may want to search for that thread and read thru it. Though I believe ended up doing a fresh install of 2000 on his 98 machine.


Rob
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #10 ·
Ok, I did an ipconfig on both machines:


Win2K

IP 192.168.0.2

Subnet mask 255.255.255.0

Default Gateway 192.168.0.1


Win98SE

IP 192.168.0.10

Subnet mask 255.255.255.0

Default Gateway 192.168.0.1


On the Win2K machine (SOUTHERN_SEA), I do a net view \\\\192.168.0.10 and I get

Shared resources at \\\\192.168.0.10


AMD 1.2Ghz RAID


Share name Type Used as Comment

--------------------------------------------------

C Disk

D Disk

E Disk

F Disk

G Disk

H Disk

The command completed successfully.


I can ping 192.168.0.10 w/o a problem.


If I do a net view \\\\192.168.0.10\\C

I get


System error 5 has occurred.

Access is denied.



On the Win98SE machine, I do a net view \\\\SOUTHERN_SEA and I get

Shared resources at \\\\SOUTHERN_SEA


Sharename Type Comment

-----------------------------------

C Disk

D Disk

E Disk

F Disk

G Disk

H Disk


However, I am unable to ping 192.168.0.2 or SOUTHERN_SEA.


Does this help?


Al
 

·
Registered
Joined
·
1,979 Posts
Lets just stick with IP numbers for now, we can try to make the names work later. Since you are getting your DHCP leases from your router/firewall they are unlikely to change unless you power off the machine longer than the lease duration.


I find it very strange that 192.168.0.2 can ping 192.168.0.10 but 192.168.0.10 can't ping 192.168.0.2... As the machines have to be able to ping one another for TCP/IP connectivity to work (except in RARE cases where ICMP messages are disabled), I suspect this is a more serious / different problem than Windows network connectivity.


What's even stranger is the fact that the Win98SE machine can access the Internet, therefore TCP/IP is bound to and working on the ethernet interface. Could there be some remnant of your Internet connection sharing software on the Win2K machine causing an IP address conflict or some kind of firewall / blocking of the Win98SE machine?


The fact that explorer on the Win98SE machine CAN see resources on the Win2K box is probably due to NetBEUI. I would suggest removing NetBEUI as has been mentioned earlier.
 

·
Registered
Joined
·
1,979 Posts
On the Win98SE machine, from a command prompt, type arp -a, is 192.168.0.2 listed? If so, record the physical (MAC) address. Now on the Win2K machine also from a command prompt type ipconfig /all. Is the same MAC address listed?


Actually, it would be helpful to have the arp cache and MAC addresses of both machines. If you don't mind, post the results of arp -a from both machines, and the results of ipconfig /all on the Win2K box and winipcfg on the Win98SE machine. It's been a while since I've used winipcfg, so there may be an option for more results, like a more or details button, that reveals the MAC address of the Win98SE machine.


I also find it somewhat unusual that your DHCP server gave .2 and .10 addresses, usually DHCP servers dole out leases in sequential order.
 

·
Registered
Joined
·
182 Posts
Well first "net view" only works for \\\\servername (or IP) not \\\\servername\\share. If you want to try to connect to the share you can use "net use z: \\\\192.168.0.10\\C". But the fact that "net view \\\\192.168.0.10" works shows that connectivity should be fine. The appears that your 2000 box can not resolve your 98 box's name to its IP address. And since there is no WINS server the name resolution is performed with broadcasts. This is the same problem the other guy had. Having that NetBUEI in there only complicates it, because depending on the binding order of NetBEUI and IP it determines which to try first. And sometimes file and print sharing may only get bound to one or the other. I recommend removing NetBEUI and maybe browse this other thread for some more clues:
http://www.avsforum.com/avs-vb/showt...hreadid=127387


Rob
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #14 ·
Hmm. Removing NetBEUI from both machines now leaves my Win98SE machine unable to access the Win2K machine at all, and my Win2K machine can't find any workgroups in Network Neighborhood.


I am able to do


net use z: \\\\192.168.0.10\\c


from the Win2K machine and connect to the Win98SE machine that way.

I can copy files, which is really what I want. I guess I can live with this, if no one else has a more elegant solution. But I think I need the NetBEUI protocol back, since my Win98SE machine doesn't seem to have IP connectivity to my Win2K machine.


Al
 

·
Registered
Joined
·
1,979 Posts
It doesn't surprise me that the Win98SE machine no longer has connectivity to the Win2K machine now that NetBEUI has been removed, since TCP/IP isn't working in that direction as evidenced by ping.


I strongly suspect you have some sort of firewall like ZoneAlarm enabled on the Win2K machine, that is allowing TCP/IP connectivity to the Win98SE machine, but preventing TCP/IP connectivity from it. Until that issue is resolved and ping can work both ways, we're fighting a losing battle.


You could re-enable NetBEUI, but I strongly discourage that solution... Win2K was really meant to use TCP/IP, and down the road if you want to do more than file/print sharing, you'll have to resolve this problem anyhow.


Try this... On the Win2K machine, close all running programs, tool tray applications, etc. Right-click on an empty section of the task bar and choose task manager, click the Processes tab, and check the "Show processes from all users" check box. Post the results here and I will look for any unusual daemons you may be running that could be blocking TCP/IP connectivity.


You may also want to look at the network properties on the Win2K machine, under the advanced tab make sure "Internet Connection Firewall" is disabled.
 

·
Banned
Joined
·
9,999 Posts
AlMark,


Your 704 D-Link router is based on the SMC Barricade series of routers, which I happen to own. I also have three PCs on my network and plugged into my router, which acts as a gateway/firewall to the Internet. Two of my PCs run Windows 98, and the last PC runs Windows 2000 Server. Ain't that convenient!?!


On each PC, I have:


Client for Microsoft Networks

TCI/IP

Network Card Driver

Windows File & Printer Sharing


Note: The 704 has a firewall built-in, but any PC in the 'DMZ' is outside of this firewall. Thus, if you use 'file/print sharing' on a PC listed in the DMZ it is wide open to Internet. Please take care!!!


Anyhow, configure the TCP/IP Properties on each PC to automatically acquire the IP address, DNS information, etc., but manually configure the router's 'gateway' LAN-side IP address (192.168.0.1 in your case).


Next, make sure the DHCP server on the router is enabled, as this server will hand-out the IP addresses to your PCs on your local network. Then, make sure File Sharing is enabled on each PC as this allows ARP (address resolution protocol) to build a table in the router and allow each PC aware of the other.


Also, make sure that Client for Microsoft Networks and TCP/IP are bound to the network adapter card in the Network Properties window. BTW, once the router has assigned an IP to each PC, the router associates an assigned LAN-IP to that PC's MAC address. From each PC (and at a Dos/Command prompt), you should try to 'ping' the Ip addresses of the other PCs.


Finally, make sure that the 'Workgroup' you gave in each of the computers is identical, less one or more of the PCs thinks the other PC(s) is/are on a different network.


If you continue to have problems, please send me an email. I should be home around 12:45AM EDT, but if you would like to wait until morning that's fine, too. I'll have the next couple of days off, and I could provide screen captures.


Cheers! :)
 

·
Registered
Joined
·
254 Posts
As a continuation of WanMan's fine instructions and the fact that you can connect with 'net use' and IP address let me add this.

Check that you have DNS enabled for Windows Resolution, and not LMHost.

Release all IP address from all machines connected to the router. Power the router off for several minutes. Power the router on and wait for it to establish an IP address, then renew each PC's IP address checking for sequential order.

Ping each IP address from Win2k with the command 'ping -a xxx.xxx.xxx.xxx' (the 'x' being the IP address) and it should return the name of the machine and your replys.

If this is successful ping each machine by name. If this is successful you are ready to go.

If not and you can only see IP addresses I would suggest creating seperate entries in your host file and rebooting your Win2k machine.

In any case let us know how you make out and good luck.
 

·
Registered
Joined
·
453 Posts
Discussion Starter · #18 ·
Thanks for all the suggestions, guys! I'll have to wait until I get home to try out a solution, though. I think helzerr is on to something, because he just jogged my memory about something I had installed - ZoneAlarm on the Win98SE machine, before I had the router. I noticed that VNC will not work on it, no matter what I do. It will work, however, on the Win2K machine and my HTPC running Win98SE (which is the other Win98SE machine in the network). I had uninstalled ZoneAlarm, but VNC still doesn't work, and perhaps this is the cause. VNC is Lucent's lightweight client for virtual private networking, which I use to connect to work. I will also try to ping my HTPC from the Win2K machine. I'll let you know what comes of it. Thanks very much!


Al
 

·
Registered
Joined
·
31 Posts
I would like to add on to what some others have hinted at. Win2K has a heavy preference for DNS, and will even resolve NetBIOS names through it. 98SE still has a tendency to prefer WINS, and the NetBIOS broadcasts that the NetBEUI protocol is throwing on the wire actually "strengthen" that, in a way (Windows TCP/IP does NetBIOS broadcasts as a last-ditch effort for name resolution--since NetBEUI is nothing but NetBIOS broadcasts, it can cause TCP/IP sessions to fail when using computer names). I've lost track of the number of users who have run into this issue on home networks, and it always occurs when people mix Win9X machines with Win2Ks.


The solution for the cases I've dealt with is to eliminate the NetBEUI protocol, disable LMHOSTS and WINS usage for TCP/IP, and remove firewall programs from all network interfaces that aren't directly connected to the Internet (a LOT of consumer firewall apps block NetBIOS, which is one cause for IP addresses that work, but NetBIOS names that won't).


Something else that's worth mentioning because of an earlier post. The presence of NetBEUI can cause Win2K machines to call for a browser election (what a previous poster described as Windows machines fighting it out). Since the Win2K machine will always win the browser election over Win9X boxes, it's a big waste of time and resources. It's probably not the cause of your problem, but it does throw a lot of unnecessary packets on the wire every time a computer uses NetBEUI.
 

·
Banned
Joined
·
9,999 Posts
I also run ZoneAlarm on all PCs, and you MUST affirm when prompted to allow the local network awareness to each PC. This is something easily overlooked (I did it once).
 
1 - 20 of 34 Posts
Status
Not open for further replies.
Top