AVS Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
10,444 Posts
Discussion Starter · #1 ·
Ok...a few of you know I've had problems with the graphics in Battlefield 2.

Mainly shadows give me this weird glitchy polygonal thing. I shrug, I live with it.

Its basically a flashing polygon....like for a split second..."flash"...then its gone.

I really ought to AVI it sometime.....


Anyhow: it happens in BF2.....mostly its shadows.....objects dont glitch, etc...just the shadow being cast glitches a bit.


Unreal Tournament 2004....not a glitch in sight, with max detail and max settings and 1600x1200...no glitches.


3D demos and benchmarks...NO glitches....Futuremark, etc...no glitches.


FEAR Demo....not a glitch in sight, no glitching at all.


Today I installed Return to Castle Wolfenstein, just for the heck of it.

GLITCH CITY.


I mean there are polygons flashing here and there....its horrible!!!


RTCW is like 4 or more years old, no WAY its taxing this card at all. ITS INSANE :)


I tore apart the card, removed the HSF, removed all the grease and pads, replaced with Arctic Silver 5, reattached HSF....card is running a bit cooler (idles at like 50c).......AND YET WOLF FREAKIN GLITCHES ON ME....!?!?!


I read online that last year LEADTEK had some bad boards go out, but their glitching problem was more severe.......I dunno what I'm going to do, I mean RTCW kinda blows anyhow so I'm not that upset.....but so far Battlefield 2 does it (and turning off or down the shadows and detail does NOT make the problem go away)......I emailed LEADTEK tech support to see if they could help.


Its not a ram utilization problem, its not a power supply problem, since software that stresses the card much more doesn't exhibit the problem...but a simple game like Wolf3D will glitch out.....I'm wondering if something inside the chip itself is bad, some weird thing that only certain games use.....I dunno.


Anyone else ever have this problem?


I should try the card in another system I think, just for laughs. And see what happens.
 

·
Registered
Joined
·
2,378 Posts
Poly glitching is something that happens to me when I overclock my card (usually the ram) too high.


You can try using Powerstrip or Coolbits to underclock your speeds and see if that helps. It may have been a bad batch of ram but they tested it as fine.
 

·
Registered
Joined
·
10,444 Posts
Discussion Starter · #3 ·
UPDATE: Underclocking has no apparrant effect.


RETURN TO CASTLE WOLFENSTEIN: turning off "use GL Extensions" eliminated 100% of the graphical glitches....its now working perfectly. UT2004...no glitches. FARCRY...no glitches.

Both of those use D3D. Doom3 uses OpenGL doesnt' it?? I might have to reinstall and whats what. Half Life 2 uses D3D doesn't it? Hmmmmm


In fact in that game when you click on "show GL extensions" or DRiver Info, the instead of a list of driver files I get a bunch of garbled characters, then the list underneath the garbled characters.


Does Battlefield 2 use OpenGL at all? If so, I might be on to something...


Downloaded a program called OpenGL Extension Viewer, and it said everything was installed 100%.


Last time I did a windows registry hack and removed all instances of NVIDIA....I wonder if I need to do the same for OpenGL.......
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top