AVS Forum banner
  • Get an exclusive sneak peek into our new project. >>> Click Here
  • Our native mobile app has a new name: Fora Communities. Learn more.

Inside the insignia ns-BRHTIB , fixing a no disc problem and more

2941 Views 1 Reply 2 Participants Last post by  tgl3
Posting this to provide info for anyone who might want it.

I bought one of these as is for about $35 . It was just the receiver , no speakers, no remote. Plugged up all it did was display no disc. I have worked with embedded processors and the ones inside devices like this is the main reason I wanted it, something to play with.

Got it home, opened it up and tried to play a disc. Disc spins about 2 seconds then stops and the display reads no disc. The focus assembly did its usual up/down movements , so that part was working. I removed the drive assembly. the blu ray drive was labeled as asatech for the manufacturer so I looked at their website for any technical info. Nothing really there but I did learn that asatech only makes the sled, the part that loads the disc , they have nothing to do with manufacturing the pickup assembly or the control system for that. The pickup in this model was actually made by sony.

I pulled out my laser power meter to make sure the lasers were working. I know most people don't have a laser power meter and I wouldn't either except I found an ad for a repair shop going out of business and the guy sold it really cheap $20 and it has sat in my closet since then.

Turns out the lasers were fine, peak output around 4-5mw.

Last thing to check was the spindle height. Every dvd player has screws that adjust the distance between the spindle motor and the rails that the pickup assembly slides back and forth on. They have to be perfectly in line or when the pickup assembly moves back and forth on the rails it will not be able to maintain focus. This model has two screws for each rail , one on each end and uses two rails. I adjusted these so that the pickup lens tracked as close to the disc as possible without touching and slid it back and forth to make sure it was level across the entire range. Replaced the whole drive assembly back into the unit and inserted a disc. It played ! no problems at all.

I guess that over time with all the inserting of disc it became misaligned.

The unit itself is well designed inside. The power supply is a switching design with good layout and more than capable of supplying the needs of the unit.

Cooling is via a fan on one side of the unit that pulls in air through a vent on the opposite side of the unit. So the airflow is through the entire unit.

The audio amp is 6 channels provided by a texas instrument class D system. The coils and capacitors for the output are all solid design and good quality. No worries there.

The decoder used is a cirrus logic DSP with integrated EQ and handles all the audio dealys, etc.

The chipset is broadcom 76xxx variety and the board has a serial connection that I was able to use to look around inside the units files.

Pressing CTRL+C brought up the shell prompt.

The box is running embedded linux, a redhat variety of uclibc.

Linux version ([email protected]) (gcc version 4.2.0 20070124 (prerelease) - BRCM 10ts-20080721) #3 Fri Feb 19 00:43:27 EST 2010

It tries to retrieve the newest firmware at every boot
GET Number=118app 74016:00:15.332 +0.127 QA_OUTPUT(8): About to download - http://insigniaproducts.com/cms/soft...B_NSBRHTIB.xml

app 74016:00:15.736 +0.154 PslExternalUBNGetManifestFileInfo() Could not find firmware node newer than the current firmware for player INSIGNIA NS-BRHTIB BD Player

Most of the typical linux commands are present and a few more. Typing telnetd at a prompt enables telnet access and tftp support is intact so I could dump the files pretty easily.

I noticed a few curious things I didn't expect.

The box has support for USB serial devices, specifically the pl203 ones.

I'm guessing it is to make it easier on the service people since you could plug a usb to serial converter in the usb port then connect that to any pc with an existing serial port. Maybe for backwards compatibility.

The SATA port on the inside also supports HDD devices. All the options to mount one and support the files systems ext2,ext3 are present. Not sure how you would access them through the normal interface though.

The bluray drive it ships with is listed as Desay .
Attached devices:

Host: scsi0 Channel: 00 Id: 00 Lun: 00

Vendor: DESAY Model: Desay_7620_01 Rev: 1.40

Type: CD-ROM ANSI SCSI revision: 05

I know people want a region free bluray and its possible. I was able to dump the box keys complete with region coding without any problems. I also dumped the security keys and certificates for this box. Dumping them is one thing but altering them is another.

There is lots that can be done with the firmware on these boxes. There is support for NFS but not samba for networking these . I was really hoping to find a way to enable some form of DLNA support but there is a lot that would have to be done to do that as it lacks some important libraries and modules.

I did notice a few interesting libraries. One of them is for divx, even though the player says it doesn't support divx or mp4 file types there is hints in the startup logs and other places that someone is working on adding it in future firmware. It appears to exist in the firmware but is not enabled unless you run it in debug mode, which I wasn't able to do.

Overall a decent box. It has some good hardware inside and lots of potential.

Here is the memory layout.
dev: size erasesize name

mtd0: 00180000 00020000 "ucfe"

mtd1: 00080000 00020000 "drmregion"

mtd2: 00080000 00020000 "drmregion.1"

mtd3: 00080000 00020000 "rawnvr"

mtd4: 00000090 00020000 "macadr"

mtd5: 00000770 00020000 "nvram"

mtd6: 000ff800 00020000 "virtual"

mtd7: 00200000 00020000 "cfe.0"

mtd8: 00200000 00020000 "cfe.1"

mtd9: 00080000 00020000 "vault-a"

mtd10: 05800000 00020000 "rootfs.0"

mtd11: 00080000 00020000 "vault-b"

mtd12: 05800000 00020000 "rootfs.1"

mtd13: 00400000 00020000 "vmlinux.0"

mtd14: 00080000 00020000 "vault-c"

mtd15: 00400000 00020000 "vmlinux.1"

mtd16: 00080000 00020000 "paniclog"

mtd17: 00080000 00020000 "cfelog"

mtd18: 00600000 00020000 "splash"

mtd19: 00400000 00020000 "syslog"

mtd20: 00400000 00020000 "psnv"

mtd21: 12d80000 00020000 "pstor"

mtd22: 00100000 00020000 "config"

mtd23: 20000000 00020000 "all"
See less See more
1 - 2 of 2 Posts
I have this unit and I cannot get the setting menu to come up. TAC suggested it was a firmware issue. I have the new firmware but it will not load like it should. Do you know how I could poke it in, via serial or usb?

Any help would be appreciated.

1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.