AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
Hi guys,


This is my first build so forgive me if my question is rather stupid,


I'd like to know exactly what drivers need to be updated for optimal HTPC performance?


The first pic is the one taken off AMD website and the second pic is the one taken off Gigabyte. I have a 78GM-US2H motherboard with an onboard ATI 3200HD VGA card.


I'm going to download & install everything from Gigabyte website - they are Audio, LAN, AMD Chipset Driver (includes chipset, VGA driver, SATA RAID driver). As for the ones available from the AMD website, I'm going to install Catalyst control centre.


However, Could you please tell me if the "Display driver" from the AMD website is exactly the same as the "AMD chipset driver" from the Gigabyte website so I don't need to install that? Also, what is "South Bridge Driver" from the AMD website? Do I have to install that as well?


 

·
Registered
Joined
·
3,525 Posts
you are best getting the audio and LAN driver from Gigabyte, although you could also go to Realtek's site for the most recent (their site is not consumer-oriented, though).


The graphics, catalyst control center, and chipset driver (southbridge) are best coming from the AMD web site as they will definitely be the most recent version. The ones on Gigabyte's site would probably work...they'd just likely be old versions.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #3 ·
Actually, the chipset driver from Gigabyte website has been released just 2 days ago so it's very new.

But my question is, Does the "AMD Chipset Driver" from the Gigabyte website contain both the southbridge driver (SB700) + northbridge driver (780G)? Or does it only contain northbridge driver?
 

·
Registered
Joined
·
623 Posts
Catalyst turns out to include a fresh set of disappointments each month. Read the threads here. I would install the video driver from the CD or download from Gigabyte and don't mess with the monthly CCC update unless you have some problem. I gave up on ATI cards for HTPC use after fighting 1080i deinterlacing problems for months. But I do have one system left running an MSI mobo with HD 3200 IGP. And it does work. At least for Media Center HD OTA playback. Both 720p and 1080i programs are up-converted to 1080p. I'm running the video driver from the MSI CD on this one. 3 other systems now using N9400GT cards. Solved all of my problems anyway.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top