AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter · #1 ·
Background: My HTPC is a cablecard machine running TV Pack with an Intel DP35DP motherboard. The HTPC is connected to my receiver (AC3 and DTS capable) by Toslink and output to my 5.1 speakers. At setup of the machine, I made the following selections:


(1) Playback Devices from Sound Control Panel - digital output as 5.1


(2) MCE Setup - digital output as 5.1


Problem: I like to listen to lossless Audio, most of which is 2-channel. When playing in MCE (and also WMP, I think), my receiver always plays as 5.1. In order to listen in 2-channel, I always have to select "stereo" on my AVR.


I used to always think that this was a problem with my receiver UNTIL I put together a machine for my friend this past weekend. The new machine is an Intel G45 motherboard that is connected to my same receiver via Toslink. I installed VMC with TV Pack, but did NOT set up the sound for 5.1 because I wasn't sure of his setup. I then began testing the playback/recording of cable TV and movies and I noticed that everything that I would have expected to be in 5.1 (DVD, NFL game broadcast in QAM) was playing 5.1 on my receiver. To my surprise, when I played a 2-channel audio track in MCE (also in WMP), the playback on my receiver was in stereo, not 5.1.


Question:


(1) If you want the sound to be played as recorded, how should audio be set up in the Control Panel and within VMC?


(2) In the case of setting up both Control Panel and VMC for 5.1 and playing 2-channel audio, when I select "stereo" on my receiver is the sound now (a) the same as recorded, OR (b) has VMC messed with the sound in converting it to 5.1 to such an extent that selecting "stereo" on my receiver does not result in accurate 2 channel? My concern is that the 5.1 setup is converting the 2-channel to 5.1 in a manner similar to my understanding of Dolby ProLogic and that selecting stereo on my receiver is only using the L and R channels (I assume that this would not be good).


Thanks.
 

·
Registered
Joined
·
2,652 Posts
Since you are connected by toslink and using an external decoder, you set your sound card properties to external digital decoder/pass through, right?


If so, your sound card shouldn't be touching it. It would be your receiver that is upconverting the 2 channel audio when you turn its dolby on. When you turn the Dolby off on the receiver, it should be the untouched 2 channel audio.


In order to hear audio over toslink on your friend's computer, you would of had to setup optical out somewhere, which would have told your sound card to output audio by the digital out. Maybe on his setup you set the external decoder/pass thru as with yours you didn't.


To answer question 2, I think that if your receiver is showing a 5.1 signal input when you play a non-AC3 source (music), then your sound card is touching it and you must have an option turned on to upconvert the audio source to 5.1 (do you use X-Fi with Dolby Live driver, by chance?) and you do not have the pass-thru option enabled.


These are all guesses, though, as I haven't had a receiver hooked up to my PC in awhile and don't have recent hands on.
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #3 ·
Thanks for the help. The problem was AC3filter, which was configured to convert everything to 5.1. I changed output to "AS IS."
 
1 - 3 of 3 Posts
Top