AVS Forum banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter · #1 ·
I have a DirecTivo and an HD-5 both coming from an intergrated triple LNB dish. This is one of the new ones with built in mulitswitch.


My DirecTivo gets all transponders and sats with signals in the 90's on all three incoming cables. But my HD-5 currently is only receiving two transponders (31 and 20), and both in the low 40's.


Earlier today they started to fade, to my current position. I turned the unit off for awhile, but now it cant find the guide at all.


I have plenty of ventilation, and just to be sure, I placed a large box fan to rule out cooling.


Im watching the meter right now and transponder 16 is jumping from 0 to 40...


Any ideas?


Thanks,


Steve
 

·
Registered
Joined
·
2,771 Posts
This seems to be very common with these receivers, call mitsu and complain, they have been giving people $500 store credits, where you bought it.

If you are not the original owner you need to replace it. I will tell you that the Internals of the Hughes e86 are identical, and if you were able to find a new main board you could swap out the main board in a few minutes with a torx driver.
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #3 ·
Would anyone have the proper number to call??? I am the original owner. This receiver has been real nice until recently, but now it's very frustrating...


I would just like another ot the same. Does the E-86 have the UHF remote also?


Thanks,

Steve
 

·
Premium Member
Joined
·
7,093 Posts
Quote:
Originally posted by SteveHoltam
I would just like another ot the same. Does the E-86 have the UHF remote also?
The E86 does have an RF remote.
 

·
Registered
Joined
·
485 Posts
This really sucks! Same thing happened to me about 3 weeks ago as it weakens. I thought the satellite was out of alignment. One afternoon, I unplugged the unit to rearrange equipment and plugged it back in. It has not work since, it'll only pick up OTA HD now. It worked great for over 2 years and it cost me around $800. Now I get no D* signal, no programming guides, and it looses memory everytime I unplug it. I was hoping it would last at least 4-5 years.


Just curious, I'm the original owner also, but it's been two years, will they still issue this credit?
 

·
Registered
Joined
·
2,771 Posts
Call them it is worth a shot. I got this number off their website mitsubishi-tv.com


800. 888.8245
 

·
Registered
Joined
·
442 Posts
I had the same problem. Mits offered me a $400 credit. Not enough to cover the cost of a new replacement. I had the directv protection plan. Directv sent me a refurbed E86. Works great!
 

·
Registered
Joined
·
72 Posts
I just had the same problem. I called Mitsubishi, 949-830-8364, is the correct number. They suggested a soft reboot. On the remote: sat button followed by the action button followed by the power button. This at least brought back the signal but the signal is still low.


I have to fax them a proof of purchase and they will get back to me within 2 days with an action plan. Sounds like they are hearing alot of this.
 

·
Registered
Joined
·
345 Posts
Discussion Starter · #9 ·
Vdmai - Just let it sit for awhile and eventually the STB should re-aquire the guide, or at least mine always does. It seems worse in the evenings. My memory seems to be saved though, as my quick-tune channels are remembered.


Im going to call and see what happens...


Thanks All!


Steve
 

·
Registered
Joined
·
485 Posts
Not this time, Steve. I'm pretty familiar with the unit and I'm aware that it may take some time to re-aquire the guide. But it's been almost two weeks and NADA. So it's hopeless. The other thing I noticed now and that didn't happened before is that when it was working OK, all the memory or settings are still there whenever the unit was unplugged and plugged back in. Now everthing is wiped clean. Very disappointing!!
 

·
Registered
Joined
·
442 Posts
May want to try directv for a replacement. I got the impression in talking to them that they would have sold me the used hughes receiver for about $275 if I did not have the replacemnt plan. You may want to try to convince them that if the receiver is not replaced you will be forced to switch to cable.
 

·
Registered
Joined
·
1,503 Posts
I posted this elsewhere but here goes again.


I called Toshiba about my DST3000 with the same problems. Even though I was out of warranty, I escalated to a supervisor, explained the situation, told them that Mits and Hughes were at least offering some help and they replaced it with a refurb. The only thing it cost me was an LD to FAX the proof of purchase and shipping. I'd say that's pretty good in this case.


I now have a Celeron vintage CPU fan running off a 7.5V converter to keep the speed/noise down and the life expectancy up. Seems to be AOK.


It just goes to show, unless you ask, the answer is NO!!!!!!!
 

·
Registered
Joined
·
471 Posts
This is EXACTLY what is happening to my SRHD500 box, thought I was going nuts till I found this thread, it just WONT give me a signal reading on xponders, that I KNOW are there (verified with other boxes in house), OTA digital still works yet it wont even SEE xponders 1-21 even when the dish is up and verified working xponders with another box.


I am gonna try to call Tweeter (where I bought it 2 years ago) and also Mitsubishi and see what they say, anyone here recently done this and if so what if anything do they offer to do to help fix it, I want to keep this box and all vs trying a different brand, but it sounds like they don't just fix em, they give you a store credit (which wont even help cover a new one).


WIll know more tomorrow when I call around I guess...


Too bad too cuz I like this box!


Bill
 

·
Registered
Joined
·
471 Posts
Got a call today from Mitsubishi, basically anyone with the SR-HD400 or 500 units that has problems with them that are out of warranty are being directed to a company called TSR http://www.tsrservice.com/new.html


Brian from Mitsubishi gave me their number and explianed TSR has fast turnaround and for a flat rate of $99 they will fix and ship back to me my box with a 6 month warranty on their services.


Called TSR super simple instructions, box it up, send it to us with the word MITSUBISHI CUSTOMER on it, and send a check for $99 inside the box (they do accept personal checks), include a note as to what is going on with the box and your return address and they will repair it and ship it back out within 48 hours.


Not too bad I figure so I will ship this off tomorrow to TSR, even if Mitsu did offer me a credit I would still have to add money to it to buy another box, so I am glad they directed me to a company who will fix it and give me a warranty on it too for that flat rate of $99.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top