AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
426 Posts
Discussion Starter · #1 ·
Hello,


I have my Z2 for about a week now and I see a green circle on black background.


Is this a dust blob?


Should I try to clean it myself or send it back?


I've included a screenshot, it's not that good with my digital camera.


I know it's been asked many times, so thank you for your help.


Pitou!

 

blob2.zip 282.4208984375k . file
 

Attachments

·
Registered
Joined
·
224 Posts
Yes, it looks like what I had on my L300U. It was only visible under certain conditions, dark or low light scenes. I followed one of the threads on cleaning dust blobs with a can of compressed air & straw and it worked, although the first time it was reduced but less visible. I opened the case and cleaned it a second time which removed it completely. Do a search for dust blobs, there are posts with photos and instructions. Also clean the projectors filter, and clean the fan blades that is behind the filter.
 

·
Registered
Joined
·
426 Posts
Discussion Starter · #3 ·
Thank you very much for your answer.


I was hoping that it was visible in image attached. So I think it is!


I'll do the air blast tonight. I already have the tutorial for the Z2, it was to make sure that it was a blob, since it my first.


Is there a way to prevent that a little bit more? Like put the PJ in a bag! :)


Thanks again.


Pitou.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top