AVS Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1

Hoping I can get some help or at least thoughts on my issue. I have a Yamaha HTR-5790 AVR hooked up to my cable set top box for audio via coax/optical (it does not really matter for the purposes of this issue as both connections behave the same). My cable set top box has audio coding options of AC-3, HDMI, or PCM. When I set it to AC-3 I get Dolby 5.1 through the Yamaha and it is indicated as such on the receiver. However for this setting I get no audio out of the TV which is connected via HDMI. There are times however I would like the audio to come from the TV itself rather than the AVR. So I set the audio coding on the set top box to HDMI and I get audio from the TV but when I run it through the Yamaha AVR the audio comes across as 2 channel PCM indicated on the receiver. Let me emphasize the audio source is still the cable set top box via coax/optical NOT the TV via optical. My cable company insists I should still be getting Dolby from the set top box via the digital outputs. I tried this same setup (audio coding set to HDMI on the set top box) on a Sony AVR and that receiver shows Dolby 5.1 as expected. Any idea why the HTR-5790 shows PCM and seems to be receiving 2 channel vs 5.1 under this scenario when the Sony shows Dolby and does receive 5.1? By the way I tried multiple cable boxes as well and all behave the same. Bottom line I can get Dolby 5.1 out of both AVRs (Yamaha and Sony) when the audio coding on the set top box is set to AC-3 but I only get 5.1 through the Sony AVR when the output coding on the set top box is set to HDMI. Any ideas would be greatly appreciated as toy why the Yamaha might not be detecting the 5.1 signal when the cable set top box audio coding is set to HDMI.
 
1 - 1 of 1 Posts
Top