AVS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
I've been battling a frustrating issue with Live TV. When I watch Live TV (mostly HD), the video is jumpy. If I pause Live TV, then play again, video is smooth. If I watch pre-recorded shows, it's smooth.


My system specs are:


Biostar TN720 (Geforce 8100 video)

AMD X2 5000+ BE (clocked @ 3.2 GHz & stable)

2 GB DDR2 800 RAM

750 GB SATA HD


Since I've got an 8000 series GPU, I can't use XvMC. When watching Live TV with no backend jobs running (no recording, mythcommflag, mythtranscode, etc) CPU usage is around 55%. I added the following to my xorg.conf Device section:


Option "UseEvents" "on"

Option "RenderAccel" "on"


Here's my xorg.conf:
Code:
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS" "No"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "UseEvents" "on"
    Option "RenderAccel" "on"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Does anyone have a few suggestions? I don't appear to be CPU bound, so I'm not sure what's causing the jumpy video.
 

·
Registered
Joined
·
1,280 Posts
Since this mainly occurs with live TV, try increasing the HD Ringbuffer size. This is amount of the program stored before it starts reading. This will increase the delay when starting Live TV.

Anyone know

Go to:

Utilities/Setup-->

Setup-->

TV Settings-->

General-->

(4th page) HD Ringbuffer Size


This is on Mythbuntu 7.10, Your setup pages may be different. I have it set at 141.00 on one PC,


I can't seem to locate this setting on my MythTV 0.21 build. Anyone know where it is now located?
 

·
Registered
Joined
·
1,280 Posts
OK, I found the location of the HD Ringbuffer setting in MythTV 0.21. It is now located in the Backend setup pages.


First, you will have to stop the backend, I believe Mythbuntu will do this for you automatically when you run mythtv-setup.


In the General section, go to the third page. That is where you can change the setting.
 

·
Registered
Joined
·
5,829 Posts

Quote:
Originally Posted by jimsiff /forum/post/14203871


Does anyone have a few suggestions? I don't appear to be CPU bound, so I'm not sure what's causing the jumpy video.

UseEvents and RenderAccel should be "true" - I don't think "on" is valid. Check your /var/log/Xorg.0.log to see if 'Enabling RENDER acceleration' shows up with "on" set. UseEvents is what's critical here in any event.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #5
Thanks for the tips guys. I increased the HD ring buffer from 9400 KB (default) to 14100 KB.


I was unclear on whether to use on, yes, true or whatever for the xorg options. I got that syntax from a RetHat forum, and it appears to work. Here's an exerpt from Xorg.0.log:


(**) NVIDIA(0): Option "RenderAccel" "on"

(**) NVIDIA(0): Option "UseEvents" "on"

(**) NVIDIA(0): Enabling RENDER acceleration


I will check it out tonight when I get home. Hopefully this helps.
 

·
Registered
Joined
·
1,663 Posts
I've got the same issue. Recorded programs are fine on all my machines but live HD is terrible on most regardless of the playback profile...even one with nothing but the most basic setup in it. I just start recording it and then just watch the recording as it records. I've also noticed that at least on the mac release of myth, CPU use is INSANE. 105% utilization playing SD even with no deinterlacers or or filters in play on a 2.4Ghz dual core. Made me take my appletv and only boot Linux...I used to let it launch through frontrow in MacOS. There's definitely odd things up with .21. Had no problems with .20.

-Trouble
 

·
Registered
Joined
·
133 Posts
Discussion Starter #7
I think I may have fixed my stuttering Live TV issue. There is a bug in MythTV 0.21 where it will choose a deinterlacer based on the first signal resolution it sees, then not switch to a different one if the resolution changes.


Here's a thread describing the bug: http://svn.mythtv.org/trac/ticket/5025


Here's some output from my mythfrontend.log:

Code:
Code:
2008-07-02 21:18:37.459 The realtime priority setting is not enabled.
greedyhdeint: size changed from 0 x 0 -> 720 x 576
2008-07-02 21:18:37.568 OpenGLVideoSync()
2008-07-02 21:18:37.620 Video timing method: SGI OpenGL
2008-07-02 21:18:39.405 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
greedyhdeint: size changed from 720 x 576 -> 1920 x 1088
2008-07-02 21:18:40.389 AFD: Opened codec 0xa6464170, id(MPEG2VIDEO) type(Video)
Myth chose GreedyHighmotion 2x when the resolution changed to 720x576 (tuner test resolution). When the tuner switched to an active source, resolution changed to 1920x1088, but kept the Greedy deinterlacer.


I created a test profile that used the normal deinterlacer for all resolutions, and Live TV seems to work better now. I will monitor this over the next few days, and experiment with different deinterlacers to see which ones work the best and provide the best PQ for my Samsung 720p DLP.


Trouble, I hope this info can help you fix your Live TV issues.
 

·
Registered
Joined
·
142 Posts

Quote:
Since I've got an 8000 series GPU, I can't use XvMC

Can someone explain. I have an 8300 IGP on my Asus M3N78 mobo and mythtvfrontend.log says this:

2009-01-12 19:27:29.484 VideoOutputXv Error: XvMC output requested, but is not supported by display.

Xlib: extension "XVideo-MotionCompensation" missing on display ":0.0".

Xlib: extension "XVideo-MotionCompensation" missing on display ":0.0".

Xlib: extension "XVideo-MotionCompensation" missing on display ":0.0".


CPU is steady at 65% when watching HD. Using the CPU+ playback profile. Is there anyway to offload some processing to the vid card?
 

·
Registered
Joined
·
859 Posts
The X driver from Nvidia does NOT support XvMC with 8xxx & 9xxxx series GPUs. For some basic info on XvMC see here . The Nvidia driver does, however, support their vdpau method of acceleration, which very much indeed can be used by such GPUs. See here or, even closer to the source, one of the threads on nvnews .
 
1 - 9 of 9 Posts
Top