AVS Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just got my system Friday. It is the Onkyo HT-S770. Finally got it all set up Friday night and played around with it for a while. The next morning I wake up and my wife could not turn the receiver on. I thought she just could not figure it out so I go downstairs to turn it on for her. I turn it on and it automatically flips on then back off. I do this numerous times. Unplug the receiver for a while and plug it back in. No Luck. So I look in my manual and look in the trouble shooting area. I see it says contact dealer. Out of all of the 3 pages of trouble shooting this is the only line that says contact dealer. This can't be good. So I call Onkyo Saturday morning and of course they are closed til Monday. So no surround sound all weekend. I find out this morning (Monday) I have to take it to an Onkyo service shop in town. Take it to the service guy and he says he will call me in about a week with the details. This is bad real bad. I just got this system and now I have speakers all over my living room with nothing to connect to it. Anyone else have any similar experiences??
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yes it is a refurb but the refurb part was actually the subwoofer, not the receiver. I got it from J&R so I can't really return it and get a new one since they are not located locally. I guess technically I could pay for shipping to return it and have them send me a new one but that would probably take a few weeks and cost me money. I guess this is an instance where it would have been better to buy from someone locally so I could take it back and return it. :mad:
 

·
Registered
Joined
·
253 Posts
Dude, I ordered a refurb S570 from shoponkyo a couple of weeks ago... I got it and set it up only to find out that the left channel's amp was blown and got no sound from that channel. So, I call up Onkyo, and tell them my problem and they said that they would send me an email with an RA number for the receiver and a prepaid Fedex shipping label for a replacement in the mail. So a week goes by and I finally get an email with the RA number and the Label came in the mail. The label was made out to a local repair shop that Onkyo I guess uses to outsource the repairs. The label's return address was made out to my house. Then the next day, I got a shipping confirmation from shoponkyo with a Fedex tracking number. I tracked it and it weighed 66 lbs. WTF? I said, I didn't order two! All it said was it was a 66 lb package due to arrive today. Sure enough, the Fedex guy showed up today with a whole nother set of 570s, speakers and all, all the while I still have my other set of 570s here. I now have 2 sets of 570s and a receiver that is being sent back to me with a working left channel. And my credit card was never charged for the second set or shipping or anything. I am keeping my mouth shut... ;)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
just got my receiver back and it seems to work pretty good now. I did upgrade the speaker wire from what it came with and it definately does make a difference. As long as the receiver does not crap out on me again the system sounds very good for the price.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top