AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Sorry, i'm a complete noob to any speakers made past 1990. I just bought a pair of F-30's to go with my Pioneer 1020, and notice each speaker has two sets of plugins for the wires. When i plug in the top ones, i get great bass/power but it sounds like AM radio. When i plug in the bottom i get great sound and no bass.


It's probably something dumb but the instructions and google haven't helped which makes me feel really stupid lol. I've tried all settings while plugged into each set and still nothing. Anyone know what i'm doing wrong here? Thanks in advance.
 

·
Registered
Joined
·
446 Posts
Quote:
Originally Posted by Al Bundy.
Sorry, i'm a complete noob to any speakers made past 1990. I just bought a pair of F-30's to go with my Pioneer 1020, and notice each speaker has two sets of plugins for the wires. When i plug in the top ones, i get great bass/power but it sounds like AM radio. When i plug in the bottom i get great sound and no bass.


It's probably something dumb but the instructions and google haven't helped which makes me feel really stupid lol. I've tried all settings while plugged into each set and still nothing. Anyone know what i'm doing wrong here? Thanks in advance.
Are there any pieces of metal that came in the box? The 2 sets need to be connected (+ to + and - to -) to get power to both the tweeter and the woofer. Right now the connector sounds like it is missing, so you can only connect one or the other. If there is no metal pieces, you can run a short length of wire between them too.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Oh yeah 2 brass pieces came with each speaker screwed in with the connections but came out obviously and i wasn't sure if they were meant to stay when i plugged speakers in. I'll go try that, thanks very much.


Edit. Yes that fixed the problem as i'm sure you knew it would....thanks again sir i'm quite happy now.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top