AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All,


I'm trying to get my Kworld 115 tuner card working in my Windows 7 HTPC. I tried looking on the Kworld site for Windows 7 specific drivers, but that link just points me to the generic Win XP and Vista drivers. I tried them and I couldn't get my HTPC to recognize the card. According to the Microsoft site, this card should just work with Win 7 "with no additional software required". Under device manager, I think the card just shows up as "PCI device", not enabled or no drivers (I can't remember which). Anybody had any success with this combo?


Thanks in advance!
 

·
Registered
Joined
·
159 Posts
I have 2 Kworld cards one single tuner and one dual tuner both digital and the single tuner works but the dual tuner card wont even with the correct drivers. Im in Australia asia pacific region so may be different to you. Firsly the drivers for me are really hard to track down as the US and UK site dont have the same model cards so the drivers for my cards are old and out of date. I had to get the drivers from a Taiwan Kworld website which was alot of hard work to find. My single tuner card only has vista drivers but works better with windows 7 than xp or vista so the vista drivers should work.


I just think they are cheap tuners that are hit and miss to if they work and the drivers seem to be well out of date I would return it for a different model if I was you, Dont wast 50+ hours like I did on both my cards to only get one working.
 
1 - 3 of 3 Posts
Top