AVS Forum banner
Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter · #1 ·
I turned it on last night and "Game Over" popped up on the screen. It stopped working after that.


Don't have a heart attack, I was only kidding. I did take it down for cleaning / dust blob removal. I had two dust blobs, a green and a blue one. The blue one has been there for a long time, the green one has been there about 2 weeks. I can only see them when the screen is black, if they affect the picture otherwise I cannot tell it.


I got rid of the green blob, but the blue one stayed.


After having this projector for a while, here are my thoughts. At first it was very, very, cool. This lasted for about a week until I began to notice things or little flaws with my precious projector. Then I went thru a period where I had a little bit of regret, this lasted about 4 weeks, then you just accept that things are as they are and start enjoying the picture again.


BTW, ironically, I found that when the tweaking activity starts to go down the picture enjoyment factor starts to go up.
 

·
Registered
Joined
·
176 Posts
Quote:
Originally posted by yellowsubmarine
I

After having this projector for a while, here are my thoughts. At first it was very, very, cool. This lasted for about a week until I began to notice things or little flaws with my precious projector. Then I went thru a period where I had a little bit of regret, this lasted about 4 weeks, then you just accept that things are as they are and start enjoying the picture again.


BTW, ironically, I found that when the tweaking activity starts to go down the picture enjoyment factor starts to go up.



I could have sworn you are describing my feelings after the wedding!
 

·
Registered
Joined
·
587 Posts
Quote:
Originally posted by yellowsubmarine
...until I began to notice things or little flaws with my precious projector.
Could you please elaborate, what yo may find as "little flaws", others may not.


~ Jay
 

·
Registered
Joined
·
1,010 Posts
I've been tucking my 300u under a t-shirt when not in use to prevent dust. Not sure if this is helpful or harmful...
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #5 ·
Things like horizontal scan lines, defective pixels, the "veil" effect, black level, etc...


I was also suprised how dirty the filter was after 100 hours. And in one or two spots inside the case there was a fine powder like dust.


If you feel like you aren't enjoying your projector and you are tweaking alot, stop tweaking for a while and see how you feel... You might be suprised what a difference it makes!
 

·
Registered
Joined
·
443 Posts
I have a green dust blob myself. I realized it when I went from a 78" image(tablemount) to 92" image(ceiling mounted). Once the picture got bigger that's when I noticed it. After several blasts of air I was unable to get rid of the dust particle. After talking to my dealer, he said it was probably in the lens itself. In a couple of weeks I am going to send to an authorized Panasonic to clean the lens(it is under the manufactures one year warranty). I agree with yellowsubmarine, I no longer look for the little flaws that are present. My biggest critique is the pixel structure on certain scenes. So far everyone has been impressed with the projector(demoed it about a dozen times). ENJOY! ENJOY!
 

·
Registered
Joined
·
2,896 Posts
Just curious yellowsubmarine... how often do you feel you should clean the blobs?... and how often do you see the horizontal scan lines?
 

·
Registered
Joined
·
306 Posts
Quote:
Originally posted by yellowsubmarine


If you feel like you aren't enjoying your projector and you are tweaking alot, stop tweaking for a while and see how you feel... You might be suprised what a difference it makes!
I couldn't agree more! There are too many people with PJ's far too busy judging the picture quality instead of enjoying the content!

Your posting reminded me of exactly how I felt over the period I owned a Pana 75U. Then I changed to an HS10 and am currently at the 'tweaking' stage which hopefully will be over soon.

Whilst I enjoy this forum and the incredible detail and content, no offense guys but I'm looking forward to not being a regular reader and more of a movie enthusisast!


Forget the scan lines, the dust blobs, the screen door - relax and watch the movie content!

Addicted tweakers will find this very very hard to do!
 

·
Registered
Joined
·
1,483 Posts
So was moving from a 75U to a HS10 that much of an improvement? I am curious, I currently have a 75U. I recently saw a HS10 demo and thought it wasn't significantly better. Just wondering.


Scott
 

·
Registered
Joined
·
306 Posts
Hmm, Well the truth is that I had the LT712E - a UK/European/Australian version of the 75XU (?) - a 4:3 XGA PJ. I had a lot of lamp ballast problems plus colour purity problems on top of the fact that it would not accept the Australian HDTV (1080i @ 50hz) signal as they advertised it would so I sent it back (after 12mths use!) and got a full refund, (for which I am very impressed with Panasonic Australia's customer satisfaction attitude - I bet I would not get the same deal with Sony!)

I was then able to buy the HS10 for less than I originally paid for the 712E and yes there is a difference between the two - the HS10's extra res for a w'screen DVD makes a noticable difference in regards to sharpness and lack of screen door and it is also compatible with HDTV down under, this looks superb on the HS10, what little of it there is...


I am just hoping that I have not gone from bad to worse as far as reliability as there seems to be a lot of HS10 lamp problems...


The HS10's fan is also a good deal noisier than the 712E though but over-all I am glad I was fortunate to be able to change without losing any money.

If this had not been possible I probably wouldn't have 'upgraded' at this time - perhaps I would have waited another 12mths or so for the next generation - higher res and cheaper again I would think...
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #11 ·
I think the dust blobs should be cleaned whenever I take the projector down to clean the filter - about every 100 hours or 3 months, whichever comes first. Now if I suddenly got 3 or 4 dust blobs on the screen, I'd probably clean it sooner than I had planned.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top