AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
I got it removed finally and solved my problem.

I had the ghosting issue and found the solders were cracked on my coils on the z-sus board, I re-soldered them and the ghosting cleared.

Not sure if ghosting is the proper terminology to use, but in a light scene I was seeing pixel coloration, mostly on faces and white backgrounds. greenish/blue and sometimes purple, it was really driving me crazy to watch a show.
 

·
Registered
Joined
·
65 Posts
I got it removed finally and solved my problem.

I had the ghosting issue and found the solders were cracked on my coils on the z-sus board, I re-soldered them and the ghosting cleared.

Not sure if ghosting is the proper terminology to use, but in a light scene I was seeing pixel coloration, mostly on faces and white backgrounds. greenish/blue and sometimes purple, it was really driving me crazy to watch a show.
How do they unclip? Any tips on disassembly? I have the same problem with my LG plasma, but I haven't tried taking it apart yet.
 

·
Registered
Joined
·
53 Posts
I used a large flat screw driver to push them apart. It seems that it is a common problem with all LG plasma produced that year (PZ950, 750, 550, PV450 etc.). I did not re-solder that coils before they all became disconnected and lost my Z-Board. I replaced it and it is fine now, but I paid $75 for the new board. So if you see these picture artifacts I would recommend to re-solder these coils ASAP.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top