AVS Forum banner

1 - 20 of 68 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hello,

I recently got an nVIDIA 3080 for my computer, and have noticed that since I installed it, content in MPC-HC + madVR looks very blurry when people move and such. I had an AMD card in it before, and do not remember experiencing this type of issue. This is really starting to drive me crazy because I don't know what else I can do to fix it :(

Here's some madVR stats
I've tried enabling vsync in nVIDIA Control Panel, but that didn't seem to fix it. I've also tried matching display mode to 23fps as well, but doesn't help. I've noticed that in madVR stats, it says there's 1 frame repeat every 50 seconds or so after content plays for a while. I think that's really bad, but not sure how to fix.

Anyone have any ideas? It seems like a configuration change on nVIDIA side possibly due to that being the only thing that's changed.

Appreciate any assistance!

Thanks!
 

·
Registered
Joined
·
2,516 Posts
If you want to use the highest refresh rate for media playback, you need to put a 119Hz mode to switch to in madVR. That will get rid of the frame repeat every 50 seconds. Of course, your display would also have to support this (which it does, now that I know it's a CX).

Looks like you're using RGB full 10-bit on the Nvidia side, and 8-bit in madVR. You might want to match these at either 10-bit or 8-bit. Do some banding tests to see what looks better. What's the LAV video decoder set to? What's the Nvidia driver version?

EDIT: I just realized you put your TV model in the thread title. My bad :)

PC mode or normal HDMI mode? Considering it's an OLED, the motion "blur" doesn't surprise me, but it shouldn't be something new. Did you use TruMotion before by any chance, or BFI?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Hi @VBB,

Thanks for your reply! I'll be happy to give further details on my gear.

I'm not using Sony X900H. I'm using LG CX 48" via PC input. I tried using 60hz instead of 120hz, and it doesn't go away. Can you explain the 119Hz mode? What's so different between that and 120hz?
As for 8/10-bit, in Full Screen, it's showing "D3D11 exclusive 10-bit", but there's a line that says "NV12, 8 bit, 4:2:0". Any idea what that means?

I'm on version 0.74.1 of LAV video decoder, and 460.89 for nVIDIA.
 

·
Registered
Joined
·
2,516 Posts
Sorry, I edited my reply to you after you read it. All good, but you might want to read it again :)

With the CX, or any display capable of 120Hz, you ideally want to set madVR to switch to only three refresh rates: 100, 119, and 120. That covers all the common media frame rates (23.976, 24, 25, etc.). The reason you're getting a frame repeat at 120Hz is because 23.976 doesn't fit evenly into 120, but it does into 119 (which is really 119.88).

Sounds like your whole chain is set to 10-bit. The line that says "NV12, 8-bit, 4:2:0" shows the media encoding, so that's normal.

See my first reply for additional questions...
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
@VBB , ahh, gotcha. I can't use TruMotion or anything like that via PC input.

I set the auto matching display modes to: 2160p100, 2160p119, 2160p120. I'm still getting the blur though :( It did fix the frame repeating stat though!

Anything else I can tweak to possibly fix this?
 

·
Registered
Joined
·
2,516 Posts
Ok, if you want to work on the blur, you'll probably need to use at least some interpolation. That rules out PC mode. So, for the "non-purist" setup I would recommend the following:

Use normal HDMI mode. Set madVR to switch to 2160p23, 2160p24, etc., up to 2160p60. On the TV, set de-judder no higher than 2, if you want to avoid the soap opera effect. Best to try different settings yourself to see what you prefer.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #7
@VBB - I don't remember this effect being this bad when I used AMD 5700 XT. Are you sure it isn't something on nVIDIA's side?
 

·
Registered
Joined
·
2,516 Posts
There's nothing I can think of on the driver side that would cause blur. Are you sure you had the exact same settings before? Refresh rate, HDMI mode, etc.

Can you describe what you mean by blur? Maybe I'm confused. You said it happens mostly during motion, that's why I assumed it's the normal OLED stutter during pans and fast movements.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #9
@VBB - Yeah, everything is the same. When I say blur, it's exactly what you said: motion blur when camera pans and fast movements.
 

·
Registered
Joined
·
2,516 Posts
Did you perhaps use AMD's Fluid Motion Video feature before? It's been a long time since my last AMD card, so I didn't realize they have a motion interpolation feature built into the driver now. That would explain it. You would find this in the Radeon settings under Video -> Video Profiles.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #11
I don't recall ever turning that feature on, unless it's on by default. I no longer have an AMD card, so I can't test :(
 

·
Registered
Joined
·
2,516 Posts
I'm grasping at straws here! ;)
 

·
Registered
Joined
·
35 Posts
Discussion Starter #13
Yeah, I understand. I'm at a loss as well here. What did you mean by "normal OLED stutter during pans and fast movements.". Is that a thing?
 

·
Registered
Joined
·
2,516 Posts
The perceived stutter is a characteristic of the super-fast OLED panel response. It shows the flaws of slow frame rate content much more than other technologies. You can either take your time getting used to it, or you can counter it with a modest amount of interpolation.

If you've had your OLED for a while, and all you did was swap video cards, it does not explain why you would all of a sudden notice this blur/stutter. It should have always been there to some degree.
 
  • Like
Reactions: Goyle99

·
Registered
Joined
·
335 Posts
I have similar issues with slow panning shots with a 1080ti. Some of that is just inherent to the fast response rate of the TV relative to something like a plasma that will soften the image. So yes a tiny bit of noticable stuttering on panning shots is innate as your picture response time improves. Older TV's don't have this problem because everything happens slower and softens the stutter. TV's have some built in processing to soften the stutter but it doesn't seem to work all that great from waht i've seen.

I have also heard about the 2 and 3 series nvidia cards having this inherent unrelated stutter, which would account for the difference between the old and new card beyond the change in display. Very similar thread from another user yesterday. he too bought a 3 series card and found it was worse than his old one. Seems to be very common complaint. I told him to try another media player and suggested what you have but it looks like that won't fix it either.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #16
Yeah, it honestly makes me not even want to watch shows on my computer. I might just bring up Plex app on the TV and use that lol.
 

·
Registered
Joined
·
2,516 Posts
Well, I'll be damned if this issue here is the same as the micro-stutter one from the other thread. The word "blur" could have thrown me off completely, though.

So, please try this:

On the madVR side, set "how many video frames shall be presented in advance" to 1 or 3 (madVR settings->rendering->windowed mode and/or exclusive mode).

On the Nvidia side, turn on VSYNC.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #18
Well, I'll be damned if this issue here is the same as the micro-stutter one from the other thread. The word "blur" could have thrown me off completely, though.

So, please try this:

On the madVR side (assuming you use madVR), set "how many video frames shall be presented in advance" to 1 or 3 (madVR settings->rendering->windowed mode and/or exclusive mode).

On the Nvidia side, turn on VSYNC.
Already tried those 2 things... didn't help my issue :(
 

·
Registered
Joined
·
2,516 Posts
OK good :) j/k
 

·
Registered
Joined
·
2,516 Posts
Have you tried using the Plex app? Do things look different/better? Make sure you use the same settings on the TV.
 
1 - 20 of 68 Posts
Top