AVS Forum banner
Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Well, after 3+ years of faithful service, my LT150 started making a really loud noise from the fan that sits by the bulb last week. I immediately searched AVS for possible fixes, and found these two posts:

Post #1 (from the Archives)

Link #2


So I went to the site mentioned (marsh electronics) and asked if they had any of the Sanyo Denki fan #109P0412H6D15 or if they could get their hands on them. They wrote back and said no they could not, and their minimum order is now 100 pieces....so I was wondering if anyone else knew of a source for these fans!


The one that I need has 3 wires and one of the posts mentions that it is a "lock sensor"...Would any 40x40x20mm fan with 3 wires work, or is the 3rd wire on most fans something different?


Any other suggestions? The real kicker is I'm down in Mexico, and the PJ was bought in the US. I will be home for a few days this week in the Washington, DC area, and I need to have the projector working before I get back. My options are:


1) Fix PJ myself

2) Call NEC and see if they have the specific part

3) Call NEC and see if they can do the service and get me a replacement in the same day (since its out of the 2 year warranty, i figure this would be a pretty expensive option)

4) Buy an Infocus X2 or similar projector and get the LT150 fixed at a later date and just eBay it.


The PJ is no longer used for home theater, just for presentation projection so I definitely don't have upgraditis for something clearer or higher rez. Its got about 700 hours on the bulb.


/matt
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top