AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Help Please,



Having a problem with the volume not sounding full strength. When I adjust the balance control either left or right I receive the full body sound and volume. However, when its set normal between both channels the sound seems lower and half strength. Any thoughts?


I recently had it in for repair locally (not authorized dealer) and had the tubes replaced and the unit cleaned.


My audio system consists of a Bedini Class A 150 watt amp, Lux Turntable with grace aram & dynavector cartridge. Magnepan speakers.


Love the Preamp, please advise as to what might be the cause. Suggestions as to who does authorized Luxman repairs with a solid reputation.

Thanks!
 

·
Blues In Thirds
Joined
·
2,522 Posts

Quote:
Originally Posted by Suprq /forum/post/19536823


Help Please,



Having a problem with the volume not sounding full strength. When I adjust the balance control either left or right I receive the full body sound and volume. However, when its set normal between both channels the sound seems lower and half strength. Any thoughts?


I recently had it in for repair locally (not authorized dealer) and had the tubes replaced and the unit cleaned.


My audio system consists of a Bedini Class A 150 watt amp, Lux Turntable with grace aram & dynavector cartridge. Magnepan speakers.


Love the Preamp, please advise as to what might be the cause. Suggestions as to who does authorized Luxman repairs with a solid reputation.

Thanks!

Did you ever get this resolved?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top