AVS Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter · #1 ·
Is there a way to take the S/PDIF OUT from the MyHD and send it to the S/PDIF IN on the M-Audio 410 (which would route it to its S/PDIF out) AND also have the M-Audio pass-thru S/PDIF for DVD playback? Right now I have them sent as two separate inputs on my Denon 3803 and I have to hit the remote to change it. If there is a way I'd appreciate the details on how to set it up. Thanks for any help.


Kerry
 

·
Registered
Joined
·
1,716 Posts
Kerry,


I've been playing with my 410 and just recently started routing my cable TV's SPDIF to the SPDIF in. Here's what I did in the M-Audio control panel by the tab sections:


Monitor Mixer: Raise the volume for SPDIF IN.


PatchBay/Router: Select SPDIF in. I get a high-pitched noise when I select Monitor/Mixer so don't set it here. To play another source (internal DVD), you will need to change this back to WavOut 1/2.


Hardware Settings: This is key - you need to set Master Clock to SPDIF in. While Internal would have been better, it will not work - the input signal will be detected as "Invalid."


S/PDIF: If you have set it up correctly, this screen will say "Valid Signal Detected". I leave the default consumer settings alone.


That's it!
 

·
Registered
Joined
·
1,230 Posts
Rich, are you saying that you can hear the audio with this set up? I see "valid signal detected" but I don't seem to get any audio out of it.


Thanks,
 

·
Registered
Joined
·
1,716 Posts
Yes, it does.


Some sources (such as certain DVD players) may not work properly (they set a copy protection bit that stops the pass-through). Try a different source to ensure your setup.


I am not at my HTPC but you may also need to set up Multimedia in the Control Panel to the proper input (M-Audio SPDIF in). This may be your problem.


It took me a while but I eventually got audio passing through.
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #6 ·
I guess what I'm asking for isn't possible. I don't want to change anything, if possible, when I switch from TheaterTek for DVD playback, and then go to MyHD for HDTV. I know I can set the MyHD for wave out, but there are issues with that and I lose any surround data.


Kerry
 

·
Registered
Joined
·
1,716 Posts
Kerry,


I will try this out this weekend and let you know.
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #8 ·
Thanks Rich! I've tried a variety of things, but I always end up losing one input or the other. Hopefully you'll have better luck. I'm sure there are many others that are having this same issue.


Kerry
 

·
Registered
Joined
·
13,423 Posts
â€Is there a way to take the S/PDIF OUT from the MyHD and send it to the S/PDIF IN on the M-Audio 410 (which would route it to its S/PDIF out) AND also have the M-Audio pass-thru S/PDIF for DVD playback?â€


Kerry,


That is not possible. The Delta cards can not auto-switch between external and internal S/PDIF without user intervention.

â€Right now I have them sent as two separate inputs on my Denon 3803 and I have to hit the remote to change it. If there is a way I'd appreciate the details on how to set it up. Thanks for any help.â€


You could add an AA 1177 auto-switch and would not require you to use pass-thru on the Delta 410.
 

·
Registered
Joined
·
1,716 Posts
Kerry,


Just tried passing the MyHD SPDIF out through the M-Audio card and it worked fine for me (given the settings I described earlier).


And, I also use the AA1177 auto-switch so that I do not have to switch my receiver.
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #11 ·
Thanks for the help everyone. I was hoping to avoid buying additional hardware, but this looks like it works out well.


Kerry
 

·
Registered
Joined
·
1,716 Posts
One more thing I discovered over the weekend.


Once M-Audio is set for SPDIF in and you play an internal source, the M-Audio control panel AUTOMATICALLY switches to the internal Wave source. Then, when you go back to the other source using the SPDIF in, you get silence.


You need to go back to the control panel and reselect SPDIF in. So, in a way, you get auto-switching from external to internal, but have to manually reset to external sources.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top