AVS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I think my vizio LED aray may have gone bad. Any thoughts. Insurance is sending a tech and the tech saw these photos said it was a bad power supply. I don't want to second guess a professional but sure looks like LED failure to me. Any ways he ordered the power supply without even comming out. Should I be worried?
 

Attachments

·
Registered
Joined
·
1,869 Posts
Yep, sadly that looks like a dead zone.
Could be a LED, or it could be the LED driver, which I think is a separate board from the power supply. On edge lit TVs the LED drivers are usually on the power supply board, on the Vizio, since it's FALD, it has a separate board with 32 drivers on it for each zone.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3 (Edited)
Hey, thank you! I figured. I'm sure he won't be able to fix it as the led strips are not sold anymore that I can find. Maybee they will replace the TV or at least pay out so I can get a diff 4k
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
So tech says it's delamination and a total loss. Insurance should pay out. Damn sucks. Does every one agree. Should I try and out a new strip in?
 

·
Registered
Joined
·
1,869 Posts
So tech says it's delamination and a total loss. Insurance should pay out. Damn sucks. Does every one agree. Should I try and out a new strip in?
If the 2015 panels are anything like the 2017 ones, it won't be easy to find a replacement LED strip for your TV. Unless you can find another M60-C3 that's being broken down for parts.
https://imgur.com/a/VgFwt
 
1 - 5 of 5 Posts
Top