AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Does any one have an Apple Mac Mini connected to a Denon AVR-790? I cannot get optical digital audio to work.


My configuration:


Mac Mini

Video: DVI=>HDMI 4 (DVR)=>Panasonic projector

Audio: Headphone/Optical Digital Output=>Denon 790 (Optical 1)


PLEASE HELP...
 

·
Premium Member
Joined
·
3,025 Posts
Do you have any other devices successfully connected with both HDMI and optical?


Start by reading your manual, though granted, manuals from certain AVR manufacturers tend to suck, and read through this massive thread on your Denon AVR model:

http://www.avsforum.com/avs-vb/showthread.php?t=1152799


First figure out if you can assign optical 1 to HDMI 4, then how to tell it not to look for audio over HDMI, then how to define for that input what to do when it receives digital audio over optical, the setting you want is usually called something like "Auto Surround Mode." This is handled differently from brand to brand.


Do that first, then we can return to the Mac side of the equation if that's even necessary. You'll have to be more specific about 1) the software player and 2) the file you're trying to play back for us to help, but rule out basic Denon setup and configuration issues first.
 

·
Registered
Joined
·
41 Posts
This may seem to0 obvious but - I assume you have the audio preferences In System Prefs and DVD Player set to digital audio out.
 

·
Registered
Joined
·
70 Posts

Quote:
Originally Posted by jcar901 /forum/post/18222037


This may seem to0 obvious but - I assume you have the audio preferences In System Prefs and DVD Player set to digital audio out.

I'm running on a 590. Posts above hit the key issues. Make sure the right optical input is selected for the input device name you have assigned to the mimi. Make sure that no other units are assigned to the same device name. Make sure the input type is either Auto or (better) optical or digital (can't recall which). Then make sure mini prefs and software prefs are set to optical output.


Good luck.
 

·
Registered
Joined
·
26 Posts

Quote:
Originally Posted by bkspero /forum/post/18247155


I'm running on a 590. Posts above hit the key issues. Make sure the right optical input is selected for the input device name you have assigned to the mimi. Make sure that no other units are assigned to the same device name. Make sure the input type is either Auto or (better) optical or digital (can't recall which). Then make sure mini prefs and software prefs are set to optical output.


Good luck.

I'm also running a 590 (1610 to be precise), and have no problem with digital audio out. As mentioned, make sure you go into the input setup, and change the audio to the appropriate input.


On the mini, if you're using DVD Player, you may need to select digital audio out each time you start it. This was a weird bug that I found annoying before I started using Plex.
 
1 - 5 of 5 Posts
Top