AVS Forum banner

541 - 549 of 549 Posts

·
Registered
Joined
·
378 Posts
I didnt have this problem until a few months back. I used to not turn on HDR in windows at all, madvr would autoswitch my screen to HDR when proper content was played. Now this has changed; I need to switch the HDR on in windows. No problems after that though..
I found this was caused by incorrect / old displays listed in madVR Settings. Delete all the displays from the list and reconfigure them. madVR auto-switching is preferred as it sends the correct MaxCLL metadata to the display based on the movie. Windows HDR uses a fixed MaxCLL which may result in hard clipping above the display's peak brightness, depending on the display's dynamic tone mapping algorithm. With the correct MaxCLL, the display can perform dynamic tone mapping properly and make brighter highlights visible. On G-SYNC HDR monitors which have static tone mapping from 0 - 1000 nits, it makes no difference as the monitors hard clip above 1000 nits anyway.
 

·
Registered
Joined
·
510 Posts
I found this was caused by incorrect / old displays listed in madVR Settings. Delete all the displays from the list and reconfigure them. madVR auto-switching is preferred as it sends the correct MaxCLL metadata to the display based on the movie. Windows HDR uses a fixed MaxCLL which may result in hard clipping above the display's peak brightness, depending on the display's dynamic tone mapping algorithm. With the correct MaxCLL, the display can perform dynamic tone mapping properly and make brighter highlights visible. On G-SYNC HDR monitors which have static tone mapping from 0 - 1000 nits, it makes no difference as the monitors hard clip above 1000 nits anyway.


how do u delete them?
 

·
Registered
Joined
·
4 Posts
My MadVR MPC-HC no longer passes HDR through correctly either, after updating my codecs. HDR is enabled, but the colors for Ultra HD movies look washed out unless I enable HDR in the Windows display settings first. Already tried deleting the profile for this display as suggested above.

I've tried setting madVR > Properties > native display bitdepth to both "auto" and "10 bit or higher," which makes no difference.

For madVR > hdr, I've tried both "let madVR decide" and "passthrough HDR to display" with "send HDR metadata to the display," which makes no difference either.

Are AMD cards less problematic with this? I don't know if it's the graphics card, but I'm out of ideas.
 

·
Registered
Joined
·
2,364 Posts
Aaron, the latest Nvidia drivers fix this issue. Try the one they released yesterday.
 

·
Registered
Joined
·
4 Posts
Aaron, the latest Nvidia drivers fix this issue. Try the one they released yesterday.
I didn't think it would, but that took care of it. Now that I think about it, I believe I updated my Nvidia driver shortly before updating my codecs. One thing: why do the colors now change when I'm in windowed mode or when I hover over the seekbar or right click? If there's no fix, that's okay.
 

·
Registered
Joined
·
2,364 Posts
There is no fix for that yet, and who knows if there will be one. The good thing is that you can work around this by using full screen exclusive mode in madVR, but then you lose the MPC-HC GUI. Either way, this is not a big deal for those of us who watch full screen (windowed or exclusive).
 

·
Registered
Joined
·
378 Posts
I didn't think it would, but that took care of it. Now that I think about it, I believe I updated my Nvidia driver shortly before updating my codecs. One thing: why do the colors now change when I'm in windowed mode or when I hover over the seekbar or right click? If there's no fix, that's okay.
madVR uses NVAPI to override the HDMI metadata sent to the display. This method should be used only in fullscreen mode. Windows thinks it's still in SDR mode and renders the desktop in sRGB Gamma 2.2 without mapping it into the BT.2020 PQ signal. This causes incorrect colours in application windows.

Going forward, enabling HDR in Windows is the correct way to watch any HDR content. The desktop and SDR applications will be correctly mapped within the BT.2020 PQ signal. You can view HDR videos & wide gamut images in Edge / Chrome etc. where only the content area is HDR and the surround text is SDR.

For the desktop to look correct in HDR on a TV, you must set Dynamic Tone Mapping to Off or HGIG. You should also force the HDMI Mastering Peak to 1000 nits if your TV has such an option, e.g. via the HDMI Signalling Override menu on the LG CX.
 
541 - 549 of 549 Posts
Top