AVS Forum banner

2721 - 2740 of 3367 Posts

·
Registered
Joined
·
1,999 Posts
Is there a way, such as a keyboard shortcut, to toggle between devices? I have an LG E9, NX7, and RS500 running on the same PC. The only that I know to switch is to drag and drop the device identification into another.

You can create separate profiles and activate them with hotkeys.
 

·
Registered
Joined
·
1,999 Posts
I doubt that I'm doing this correctly. Is this how I should start? I can't seem to find the shortcut to activate each device.
You are on the right track.

You need to create those profile groups and profiles, and then you can set hotkeys in them.

In the profile group level you can set a hotkey to toggle through the profiles within the group. But in each group you can set a hotkey to activate that particular profile which is what you will want to use.
 

·
Registered
Joined
·
6 Posts
madVR on a laptop with NVIDIA Optimus

So, I'm pretty new to this, so go easy on me. I'm not really sure where to go to help, so I kinda thought I'd ask here.

I have a laptop with a 1660Ti and an i7, with NVIDIA Optimus to switch between Integrated and Dedicated GPU. I've been using MPC-HC for a while and I recently installed the K-Lite Codec pack and got madVR working. Problem is, madVR does not seem to be using my dedicated GPU whenever I play videos. So, there are a lot of dropped frames and playback is laggy, when it does play. So, I wanted to ask if there was a way to fix this and force macVR, perhaps, to use my dGPU? I found a thread on reddit outlining a similar problem but all it said was to buy a new monitor, which does not help since I do not intend to buy one anytime soon. Sorry if it's been asked before, and sorry if it's, like, a redundant question, but just help me out if you can. I use my laptop's display itself for everything.

What I've tried:
Tried forcing default GPU as my NVIDIA GPU for both mpc-hc64.exe and madHcCtrl.exe

Other than that, I don't know what to try. Anyway, thanks in advance! :)
 

Attachments

·
Registered
Joined
·
1,999 Posts
So, I'm pretty new to this, so go easy on me. I'm not really sure where to go to help, so I kinda thought I'd ask here.

I have a laptop with a 1660Ti and an i7, with NVIDIA Optimus to switch between Integrated and Dedicated GPU. I've been using MPC-HC for a while and I recently installed the K-Lite Codec pack and got madVR working. Problem is, madVR does not seem to be using my dedicated GPU whenever I play videos. So, there are a lot of dropped frames and playback is laggy, when it does play. So, I wanted to ask if there was a way to fix this and force macVR, perhaps, to use my dGPU? I found a thread on reddit outlining a similar problem but all it said was to buy a new monitor, which does not help since I do not intend to buy one anytime soon. Sorry if it's been asked before, and sorry if it's, like, a redundant question, but just help me out if you can. I use my laptop's display itself for everything.

What I've tried:
Tried forcing default GPU as my NVIDIA GPU for both mpc-hc64.exe and madHcCtrl.exe

Other than that, I don't know what to try. Anyway, thanks in advance! :)

Yes in the nvidia control panel you can tell it to use your dGPU for MPC-HC.

I just googled this screenshot but there is where you can specify the program, and whether it should use your integrated graphics or dedicated GPU.

https://answers.unrealengine.com/storage/temp/2485-screen2.png

If you are having trouble with that there is another trick that should work. Rename your mpc-hc64.exe to something else. That should automatically make it use your dGPU if I recall correctly.

Maybe even try doing both if you really can’t seem to get it working. Rename the .exe and assign it the dGPU in the nvidia control panel.
 

·
Registered
Joined
·
276 Posts
So, I'm pretty new to this, so go easy on me. I'm not really sure where to go to help, so I kinda thought I'd ask here.

I have a laptop with a 1660Ti and an i7, with NVIDIA Optimus to switch between Integrated and Dedicated GPU. I've been using MPC-HC for a while and I recently installed the K-Lite Codec pack and got madVR working. Problem is, madVR does not seem to be using my dedicated GPU whenever I play videos. So, there are a lot of dropped frames and playback is laggy, when it does play. So, I wanted to ask if there was a way to fix this and force macVR, perhaps, to use my dGPU? I found a thread on reddit outlining a similar problem but all it said was to buy a new monitor, which does not help since I do not intend to buy one anytime soon. Sorry if it's been asked before, and sorry if it's, like, a redundant question, but just help me out if you can. I use my laptop's display itself for everything.

What I've tried:
Tried forcing default GPU as my NVIDIA GPU for both mpc-hc64.exe and madHcCtrl.exe

Other than that, I don't know what to try. Anyway, thanks in advance! :)
You're GPU is working just fine. Drop chroma to medium or high settings. You're graphics card is not powerful enough for very high settings.
 

·
Registered
Joined
·
6 Posts
Yes in the nvidia control panel you can tell it to use your dGPU for MPC-HC.

If you are having trouble with that there is another trick that should work. Rename your mpc-hc64.exe to something else. That should automatically make it use your dGPU if I recall correctly.

Maybe even try doing both if you really can’t seem to get it working. Rename the .exe and assign it the dGPU in the nvidia control panel.
Renaming it and then changing the settings from the Control Panel seems to work. Thanks a lot!

You're GPU is working just fine. Drop chroma to medium or high settings. You're graphics card is not powerful enough for very high settings.
Now that I got it to work, everything's still laggy (less than before) and the picture itself seems kinda blurred. I tried dropping the settings down to medium, but I still am getting the same results. Tried Jinc with Anti-Ringing filter which I read was a good fit for both performance and quality. Any recommended settings for my card or some way to reset all settings to defaults so I can try tweaking it bit by bit myself? Thanks for the quick reply, guys! Much appreciated.
 

·
Registered
Joined
·
21 Posts
Hello all,

I've seen on a youtube video a guy displaying the video information when playing a video using MADVR on MPC-HC, showing resolution, rendering stats, refresh rate etc etc.
Unsure if the information was shown by MPC-HC or MadVR but does anyone know how I can get these info on my screen?
 

·
Registered
Joined
·
4,209 Posts
Hello all,

I've seen on a youtube video a guy displaying the video information when playing a video using MADVR on MPC-HC, showing resolution, rendering stats, refresh rate etc etc.
Unsure if the information was shown by MPC-HC or MadVR but does anyone know how I can get these info on my screen?
It's madvr keyboard shortcut.

Ctrl+J
 

·
Registered
Joined
·
4,209 Posts
What scenarios does scale chroma separately work?

4K source on a 1080p display works, but 4K source on a 1440p does not. Is this because in a 4K video the chroma is 1080p and on a 1440p display it would still require upscaling?
 

·
Registered
Joined
·
164 Posts
What scenarios does scale chroma separately work?

4K source on a 1080p display works, but 4K source on a 1440p does not. Is this because in a 4K video the chroma is 1080p and on a 1440p display it would still require upscaling?
You're right. I think by downscaling, SSIM 2D is the king. So in order to use SSIM 2D, with a GTX1060 you have to enable scale chroma separately without having dropped frames especially at [email protected] If you got a more powerful GPU eg. 2080ti then it can be unchecked.
 

·
Registered
Joined
·
4,209 Posts
You're right. I think by downscaling, SSIM 2D is the king. So in order to use SSIM 2D, with a GTX1060 you have to enable scale chroma separately without having dropped frames especially at [email protected] If you got a more powerful GPU eg. 2080ti then it can be unchecked.
It can also be debated if the result from upscaling chroma from 1080p (original size for 4K) and downscaling it is a good thing. For playback on a 1080p display.
 

·
Registered
Joined
·
164 Posts
It can also be debated if the result from upscaling chroma from 1080p (original size for 4K) and downscaling it is a good thing. For playback on a 1080p display.
I have tried pixel-peeper the two images but not noticed any difference on my 4K monitor. I think, as Madshi named that option, it's more about "saves performances" of the GPU than the picture quality.
 

·
Registered
Joined
·
4,209 Posts
I have tried pixel-peeper the two images but not noticed any difference on my 4K monitor. I think, as Madshi named that option, it's more about "saves performances" of the GPU than the picture quality.
But in your case the feature does not work since you have a 4K display and the chroma is still getting upscaled. I think this is only for 4K downscaling to 1080p displays. Check the OSD and you'll see chroma upscale active.
 

·
Registered
Joined
·
164 Posts
But in your case the feature does not work since you have a 4K display and the chroma is still getting upscaled. I think this is only for 4K downscaling to 1080p displays. Check the OSD and you'll see chroma upscale active.
I have only checked the two static images on the 4k monitor to find out any differences. Normally I'm downscaling 4k HDR movies to my 1080p projector.
 

·
Premium Member
Joined
·
3,897 Posts
In jriver, I can’t seem to get then lav filters to show up.
Note the "auto-configured" text next to the filters. They were downloaded, installed, and configured by JRiver. You can't display or modify them. This is by design with JRiver.

You can replace them with standalone versions if you wish.
 
  • Like
Reactions: Aceman2101
2721 - 2740 of 3367 Posts
Top