AVS Forum banner

2741 - 2760 of 3390 Posts

·
Registered
Joined
·
8 Posts
Does anyone know how to fix this monitor flicker issue? I don't see any settings about a borderless fullscreen mode or anything.
 

·
Registered
JVC RS4500 | ST130 G4 135" | MRX 720 | MC303 MC152 | B&W 802D3, HTM1D3, 805D3, 702S2 | 4x15 IB Subs
Joined
·
8,822 Posts
Does anyone know how to fix this monitor flicker issue? I don't see any settings about a borderless fullscreen mode or anything.
I dont see what that has to do with madVR. But it looks like your video card is resetting and/or resolutions are trying to reset repeatedly and keeps failing.
 

·
Registered
Joined
·
358 Posts
Not sure if this is specifically a madVR issue, but can anyone help me get frame packed 3D output working? I've installed the latest lav filters with the 3D download option, and I've used 3D fix manager to enable stereo 3D with my Nvidia driver, but madVR is just outputting side by side off of my FP mkvs. All I can find is some 4+ year old threads about enabling this, and following all the steps results in side-by-side output.
 

·
Registered
Joined
·
6 Posts
Hey, I'm getting pretty bad quality when using MadVR. Settings in the screenshot below. I usually get better quality when I'm using the MPC Video renderer. Despite having a 1660Ti and using pretty high settings, the image quality looks pretty bad. Anything I'm doing wrong here? Also, I'm having way more dropped frames when playing 1080p videos instead of lower quality ones. I don't know, shouldn't it be the other way around due to the upscaling?

The image I've attached is of a 720p movie. Edit: I've attached a couple more images and cranked the settings all the way up to very high, which doesn't make any difference in image quality.
 

Attachments

·
Registered
Joined
·
4,249 Posts
Hey, I'm getting pretty bad quality when using MadVR. Settings in the screenshot below. I usually get better quality when I'm using the MPC Video renderer. Despite having a 1660Ti and using pretty high settings, the image quality looks pretty bad. Anything I'm doing wrong here? Also, I'm having way more dropped frames when playing 1080p videos instead of lower quality ones. I don't know, shouldn't it be the other way around due to the upscaling?

The image I've attached is of a 720p movie. Edit: I've attached a couple more images and cranked the settings all the way up to very high, which doesn't make any difference in image quality.
If the source is bad madvr can only do so much.

Post a screenshot of the movie while playing.

Also post a screenshot of:
mediainfo of the 720p file in question
madvr
processing>artifact removal
processing>image enhancements
scaling algorithms>image upscaling
scaling altorithms>image downscaling
scaling algorithms>upscaling refinement
rendering>dithering
rendering>trande quality for performance
 

·
Registered
Joined
·
6 Posts
Post a screenshot of the movie while playing.

Also post a screenshot of:
mediainfo of the 720p file in question
madvr
processing>artifact removal
processing>image enhancements
scaling algorithms>image upscaling
scaling altorithms>image downscaling
scaling algorithms>upscaling refinement
rendering>dithering
rendering>trande quality for performance
Please note that I have tried lower and higher settings, without no improvement in image quality at all and also MPC renderer produces better results (in my opinion). Right now it's on pretty much max settings and it doesn't have many dropped frames unless I'm playing 1080p videos. Quality and performance doesn't change for any settings. Looks all the same.

I'm posting a screenshot of 1080p video too, the dropped frames stay the same at all levels of quality. With madVR it looks really bad, worse than the original. Hobbit.txt is the mediainfo for the screenshot of the Hobbit I've provided.

And I just tried it out. 4K doesn't play at all. On any settings.
 

Attachments

·
Registered
JVC RS4500 | ST130 G4 135" | MRX 720 | MC303 MC152 | B&W 802D3, HTM1D3, 805D3, 702S2 | 4x15 IB Subs
Joined
·
8,822 Posts
Please note that I have tried lower and higher settings, without no improvement in image quality at all and also MPC renderer produces better results (in my opinion). Right now it's on pretty much max settings and it doesn't have many dropped frames unless I'm playing 1080p videos. Quality and performance doesn't change for any settings. Looks all the same.

I'm posting a screenshot of 1080p video too, the dropped frames stay the same at all levels of quality. With madVR it looks really bad, worse than the original. Hobbit.txt is the mediainfo for the screenshot of the Hobbit I've provided.

And I just tried it out. 4K doesn't play at all. On any settings.
Something is really wrong. It looks like there's a *massive* anti noise filter going. Try turning off that anti-bloat filter. Also, I'd suggest dithering error diffusion 2 not 1. Hopefully the anti bloating filter fixes it. It definitely should *not* look this way.
 

·
Registered
Joined
·
6 Posts
Something is really wrong. It looks like there's a *massive* anti noise filter going. Try turning off that anti-bloat filter. Also, I'd suggest dithering error diffusion 2 not 1. Hopefully the anti bloating filter fixes it. It definitely should *not* look this way.
Well, turning it off made it slightly better, but nowhere near the original quality. It actually should be better, right? Is there some kind of configuration file I could use so as to default everything to normal or something like that? Best settings for my GPU would be better, but that's probably taking it way too far. Any other settings I could try turning off? I hope I've given you enough info, I'd be glad to do what I can to get this fixed. It's only very slightly better. I wouldn't have said it made a difference if I didn't look closely. Big thanks for the help anyways! Hoping to get this fixed soon!
 

·
Registered
Joined
·
4,249 Posts
Well, turning it off made it slightly better, but nowhere near the original quality. It actually should be better, right? Is there some kind of configuration file I could use so as to default everything to normal or something like that? Best settings for my GPU would be better, but that's probably taking it way too far. Any other settings I could try turning off? I hope I've given you enough info, I'd be glad to do what I can to get this fixed. It's only very slightly better. I wouldn't have said it made a difference if I didn't look closely. Big thanks for the help anyways! Hoping to get this fixed soon!
I'm going to assume that you're new to madvr. There's no such thing as best settings for GPU, it's up to the source and personal preference.

So you have to read the guide and see what everything does. Cranking everything up does not mean the best quality.
https://forum.kodi.tv/showthread.php?tid=259188

I don't know how when disabling the settings mark suggested looked just a bit better. There should be a significant difference.

And how can a downgraded 800kb/s 720p video looks better than the original Blu ray? Or what's the original file the 720p file is being compared to?

First you should disable everything on artifact removal page, and only enable the feature after you've tested them individually with varying settings. The guide has examples of the effect of the feature in artifact removal page, but you can also try on your own files.

Disable anti bloating filter.

Try NGU Sharp instead of AA.

Try the dithering setting mark suggested.



This is my personal preference, but I only use banding removal from artifact page, unless the file is very poor quality.

I also use these settings for scaling algorithms>upscaling refinement
sharpen edges 2
enhance detail 1.1
luma sharpen 1.15

If there's some artifacting then disable luma sharpen setting and leave the other two.

And these for when the source has the same resolution as the display, or when the source is slightly higher resolution, but not something like 4K>1080p. Works for 1080p on 1080p:
In processing>image enhancements
sharpen edges 1.1
enhance detail 1.1
luma sharpen 1.15

The enhancement sets above should not be used at the same time, for upscaling use the first one, for video with same resolution as the display use the second.

There's nothing to be fixed, it's on your end that adjustments need to be made.


As for 4K, what happens exactly?
What madvr version are you using, is it a beta?
What LAV version?
Screenshot of LAV Video?
 

·
Registered
JVC RS4500 | ST130 G4 135" | MRX 720 | MC303 MC152 | B&W 802D3, HTM1D3, 805D3, 702S2 | 4x15 IB Subs
Joined
·
8,822 Posts
Well, turning it off made it slightly better, but nowhere near the original quality. It actually should be better, right? Is there some kind of configuration file I could use so as to default everything to normal or something like that? Best settings for my GPU would be better, but that's probably taking it way too far. Any other settings I could try turning off? I hope I've given you enough info, I'd be glad to do what I can to get this fixed. It's only very slightly better. I wouldn't have said it made a difference if I didn't look closely. Big thanks for the help anyways! Hoping to get this fixed soon!
Please turn *everything* off on the artifact removal page. You have every option checked. Let me know how it looks then. I totally missed that first setting photo when I looked at this earlier.
 

·
Registered
Joined
·
5 Posts
Hello everyone!
I use the "always shift the image" function in the "zoom" menu in MadVR to move it down (it’s better to watch 2.35 with a projector on 16:9 screen).
When a film in full HD 1080p, the image moves down - all is ok. When I watch a film in the ultra HD 3840p, the image does not move down.
Please help deal with this problem. Perhaps there is another way to automatically shift the image down.
My projector - JVC dla X700

Any ideas?
 

Attachments

·
Registered
Joined
·
6 Posts
I'm going to assume that you're new to madvr. There's no such thing as best settings for GPU, it's up to the source and personal preference.

I don't know how when disabling the settings mark suggested looked just a bit better. There should be a significant difference.

And how can a downgraded 800kb/s 720p video looks better than the original Blu ray? Or what's the original file the 720p file is being compared to?

First you should disable everything on artifact removal page, and only enable the feature after you've tested them individually with varying settings. The guide has examples of the effect of the feature in artifact removal page, but you can also try on your own files.

Disable anti bloating filter.

Try NGU Sharp instead of AA.

Try the dithering setting mark suggested.

As for 4K, what happens exactly?
What madvr version are you using, is it a beta?
What LAV version?
Screenshot of LAV Video?
Okay, I am very new to madVR. I did mention that in the last page. And I'm being honest it didn't make a lot of difference. But turning off everything in artifact removal did work. Disabled anti-bloating filter too. Tried NGU Sharp instead of AA. And the original I was referring to was how it looked using the default MPC renderer for the same file.

4K is playable now after changing the settings. Rendering time is still 100ms but I'll try tweaking some settings myself.

Please turn *everything* off on the artifact removal page. You have every option checked. Let me know how it looks then. I totally missed that first setting photo when I looked at this earlier.
I've uploaded a screenshot on how it looks now. It looks a lot better now. Although I would like your opinion on how it actually looks. I mean, would this be the best quality I could get with madVR or could I push for better by tweaking settings? Anyway, performance is loads better. Uses only about 30% or less of my GPU. Makes me think it is underutilized. Anyway, thanks a lot, guys!

I have uploaded screenshots when using default MPC renderer, NGU AA and NGU Sharp. NGU AA seems like the best to me.
 

Attachments

·
Registered
Joined
·
358 Posts
I’m having a problem with setting up custom display modes. I’m trying to follow the MadVR tutorial on them. After following the instructions and running a video for 30 minutes, I create a custom resolution, choose “try” on one of the optimal timings, and then restart. When I start playing the same video, MadVR reports 1 dropped frame ever 54 minutes (much better than the 4 minutes I’m getting), but then after a few seconds it drops back to ~4 minutes. However, when I check the timings, they HAVE changed to the new ones I’m setting. It’s almost like something in the software is actively throwing the sync.

Any ideas? Could this be an nvidia driver problem? I’m running the most recent driver that doesn’t cause HDR issues.
 

·
Registered
Joined
·
2,872 Posts
it throws half the frames away. there are a lot of ways to do that i haven't test what which DXVA implementation does. could be blending just discarding or frame matching followed by discard.

if you let madVR do it you are of really bad madVR is far from optimal if it has to drop frames. is one of the rare cases where other render are better but it's actually not needed so no really unimportant feature.
 

·
Registered
Joined
·
7,613 Posts
Okay, I am very new to madVR. I did mention that in the last page. And I'm being honest it didn't make a lot of difference. But turning off everything in artifact removal did work. Disabled anti-bloating filter too. Tried NGU Sharp instead of AA. And the original I was referring to was how it looked using the default MPC renderer for the same file.

4K is playable now after changing the settings. Rendering time is still 100ms but I'll try tweaking some settings myself.



I've uploaded a screenshot on how it looks now. It looks a lot better now. Although I would like your opinion on how it actually looks. I mean, would this be the best quality I could get with madVR or could I push for better by tweaking settings? Anyway, performance is loads better. Uses only about 30% or less of my GPU. Makes me think it is underutilized. Anyway, thanks a lot, guys!

I have uploaded screenshots when using default MPC renderer, NGU AA and NGU Sharp. NGU AA seems like the best to me.
You like the middle one? Looks like the worst to me, I like the 3rd one.

EDIT# Ah my bad they are out of order.
 

·
Registered
JVC RS4500 | ST130 G4 135" | MRX 720 | MC303 MC152 | B&W 802D3, HTM1D3, 805D3, 702S2 | 4x15 IB Subs
Joined
·
8,822 Posts
Can you explain what it actually does please if the source is 60Hz and you play at 30Hz?
Why even have a 30hz option? I don't see the benefit. My madVR display modes are: 2160p23, 2160p25, 2160p60. 30hz stuff will play back at 60hz just fine with no extra processing required. I suppose you could swap 2160p60 with 2160p59.
 
2741 - 2760 of 3390 Posts
Top