AVS Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Got a 300 E-Link at the end of November last year. Really liked it. However, around Christmas time, things started to go wrong. The projector reset (?) itself, causing the picture to be out of focus and it did not fill the screen (zoom). The installer came over and fixed the problem. Then the Crestron remote and the receiver box would not communicate with each other well. I had to manually turn on the projector by pushing the on/off button on the receiver. This continued to happen, bringing my installer over for numerous service calls. Finally, in March, without the problem being resolved, the installer put in a new 300 E-Link. That one worked well untill around June. I had the same communication problems, whereby the projector would not turn on when I pressed 'system on' on the remote. This happened a few times. But then around July 4th, the projector again reset itself. The installer came back to fix it and showed me how to get the zoom and focus back via the Sim remote. Luckily I knew this, because this happened again a few times. The installer a few weeks ago sent the projector the the Sim offices in Florida. There they replaced some board (not sure what), and we got it back last week. However, this week the thing was out of focus again. The installer is frustrated; I am obvioulsy frustrated, and tired of crossing my fingers everytime I turn the thing on. The installer did say that he called the offices in Italy and they mentioned that they were having some problems with the E-Link. The offices here said that there were no such problems. They mentioned they could reimburse, or send another projector (but that wasn't guaranteed of working). My installer is now proposing that they put in a RUNCO (I think it is the VX 1000d - would this be around the same cost as the 300ELink?). He said that we would be happy with it. I think that Sim should send us over a 500 for all the trouble we've been through. Anyway, what do you guys think of swapping the Sim for a Runco?? Thanks for any info/advice.
 

·
Registered
Joined
·
50 Posts
I considered both the Runco VX-1000d & the Sim2 300E. Do a search on the forum and you should find my review/comparison. I preferred the PQ of the Runco. You won’t be disappointed with the Runco. Make sure you get the new DHD controller with your 1000d(released last fall), and the newer models also come with the DC3.


FYI. I ended up buying the Marantz VP-12S4.


Your problems sound like they could be electrical in nature. Do you have a dedicated line to the projector? Is it going through an AC line conditioner? You should see if your installer can test the AC outlet your using.


Hope this helps. Good Luck.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Thanks for the advice. I did see your review and others too. It did seem that most people prefer the 300 E link to the Runco though. That has me a bit worried, since I would be swapping the 2. I would love to hear from others about the comparison bet the 2.


Thanks.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top