AVS Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
288 Posts
Discussion Starter · #1 · (Edited)
I am having random flashing/blinking when I use certain sources with my Marantz SR7012, my display is a Sony 75 XE9405 (US version is Sony XBR-X940E ). I am using Premium Certified Cables (have also tried amazon basic hdmi cables), 3m (10') to the display and 2m (6.75'). I am also on my second receiver which is doing the same thing.



My sources are:



HTPC (Nvidia GTX 1050Ti) - No Issues
PS4 - Blinking @ 1080p HDR

Tivo V6 - Blinking @ 2160p\1080p



When I use my PS4 for HDR gaming at 1080p I get random blinking ie a black screen for a split second, it is fine for non HDR gaming. The same happens if I set my Tivo box to output at 2160p.



If I connect either the Tivo or PS4 directly to my display I do not see any of these issues and the only time I see this problem is when I introduce the Marantz Receiver into the equation. I am using bypass in the receiver so no scaling is occurring and I have enabled the 4K option for HDMI on the receiver.



I can use my HTPC to play 4k HDR movies with no issues at all so all I can presume is that this issue is a Handshake issue or a compatibility issues between my Sony display, Marantz and (PS4/Tivo). I also have a friend with the exact same display and receiver setup who is experiencing the same issues.



I have contacted Marantz and followed all the advice they have given and nothing has solved the issue. I have also googled about and see that Denon and Marantz have issues with the PS4 and Xbox.



Is anyone out there running a PS4 in HDR or a PS4 Pro with a current gen Marantz or Denon and if so are you getting issues or have you come across this and solved it?



If the Marantz is a no go which is looking more and more likely I am thinking of going for a Yamaha RXA 2070 instead, however I just wanted to make sure this would solve my problems.



Any help would be much appreciated.
 

·
Registered
Joined
·
4,273 Posts
I have sr7011, ps4 pro, and sony z9d. I've seen the blinking issues talked about in the sony TV thread with various AVRs and sources. Nobody really knows what is causing it though.

Luckily for me, I've been problem free. The only thing I can suggest trying is to make sure all your hdmi settings on the marantz are enabled, especially the communication one.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #3 ·
I have sr7011, ps4 pro, and sony z9d. I've seen the blinking issues talked about in the sony TV thread with various AVRs and sources. Nobody really knows what is causing it though.

Luckily for me, I've been problem free. The only thing I can suggest trying is to make sure all your hdmi settings on the marantz are enabled, especially the communication one.



Thank you for the info on Sony having issues with various AVRs. Do you know if Yamaha are effected by any chance or am I likely to experience the same thing?



Do you by any chance know where the communication option is, I have just had a look and cant seem to find it?
 

·
Registered
Joined
·
4,273 Posts
Thank you for the info on Sony having issues with various AVRs. Do you know if Yamaha are effected by any chance or am I likely to experience the same thing?



Do you by any chance know where the communication option is, I have just had a look and cant seem to find it?
The HDMI setting, it's called "HDMI Control" in the video settings.

Sorry, I don't know if any of the people affected by this have Yamaha receivers. In that thread (the Sony Z9D thread), we all assumed it was a Sony thing because it seemed to have started after the most recent firmware for the TV. Some said with Apple TV, others complained with PS4 Pro, and we all have various different AVRs. It could be related or not with your issue with the Marantz, so just keep that in mind while troubleshooting. I don't want to steer you the wrong way.
 
  • Like
Reactions: Razor Time

·
Registered
Joined
·
288 Posts
Discussion Starter · #5 ·
The HDMI setting, it's called "HDMI Control" in the video settings.

Sorry, I don't know if any of the people affected by this have Yamaha receivers. In that thread (the Sony Z9D thread), we all assumed it was a Sony thing because it seemed to have started after the most recent firmware for the TV. Some said with Apple TV, others complained with PS4 Pro, and we all have various different AVRs. It could be related or not with your issue with the Marantz, so just keep that in mind while troubleshooting. I don't want to steer you the wrong way.



Thanks again. I have just checked and HDMI control is ON.



So it was a recent update which has caused this issue, its probably why Marantz seems a bit lost as to what it can be. I have only had my receiver for about a month so its all very new. I am at a loss on what to do, the retailer has said I can return the Marantz but the window of return is small ie asap. I love the sound and features of the receiver inc Audessey so going for the Yamaha really would be a second choice. If I knew things would return to normal I would hold on and wait it out.
 

·
Registered
Joined
·
4,273 Posts
Another thing to try, when turning on everything, do it in this order:

TV -> AVR -> PS4 Pro

Also, forgot to mention that you should also double check that your "HDMI Control" settings are turned on for both the TV and PS4 (also referred to as either HDMI-CEC, or EDID etc.).
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #7 ·
Another thing to try, when turning on everything, do it in this order:

TV -> AVR -> PS4 Pro

Also, forgot to mention that you should also double check that your "HDMI Control" settings are turned on for both the TV and PS4 (also referred to as either HDMI-CEC, or EDID etc.).



I will try the switching order, I use a macro on my remote at the moment so not sure what order it fires everything up as. It could well be AVR before the TV.



I have HDMI control ON, on my sony for ARC, PS4 I have toggled HDCP and another HDMI feature on/off with no luck.,
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #8 ·
Unfortunately the switching order made no difference.
 

·
Registered
Joined
·
30 Posts
Marantz SR7012 PS4 & Tivo HDMI problems, Thinking of going for Yamaha

I use a tx-rz820. Ps4 Pro is connected straight to lg oled. With an optical cable back to avr from TV. I gave up basically using hdmi. Had same problem using nr1604 avr Marantz with Panasonic plasma. Sometimes it worked fine but it would just stop working. It's the handshake that fails. You could take out all hdmi cables and power plugs. Put everything back in and check which power up sequence works best if you really want to use hdmi control.


Verzonden vanaf mijn iPhone met Tapatalk
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #10 ·
I use a tx-rz820. Ps4 Pro is connected straight to lg oled. With an optical cable back to avr from TV. I gave up basically using hdmi. Had same problem using nr1604 avr Marantz with Panasonic plasma. Sometimes it worked fine but it would just stop working. It's the handshake that fails. You could take out all hdmi cables and power plugs. Put everything back in and check which power up sequence works best if you really want to use hdmi control.


Verzonden vanaf mijn iPhone met Tapatalk



Thank you for the info that another Marantz and an Onkyo have had this same issue. Curiosity got the better of me today and I have ordered a Yamaha RXA2070 to see if it also effected, fingers crossed its not so I can put this behind me and enjoy some gaming.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #11 ·
Well I have just had 2.5 hours on the PS4 with no blinking, I disabled ARC on the receiver. A bit early to say but usually the problem would happen within the first 10-15 minutes.


@pbz06 can I ask if you have ARC enabled or disabled on your receiver?
 

·
Registered
Joined
·
4,273 Posts
Well I have just had 2.5 hours on the PS4 with no blinking, I disabled ARC on the receiver. A bit early to say but usually the problem would happen within the first 10-15 minutes.


@pbz06 can I ask if you have ARC enabled or disabled on your receiver?
Well that's good to hear. Hopefully it is fixed.

Yes I do have ARC enabled and use it for my apps from TV.
 
  • Like
Reactions: Razor Time

·
Registered
Joined
·
288 Posts
Discussion Starter · #13 ·
Well that's good to hear. Hopefully it is fixed.

Yes I do have ARC enabled and use it for my apps from TV.

Haha, I was hoping you were going to say you had it disabled and that was the missing link as to you not having issues. Oh well I still have the Yamaha turning up tomorrow so I will see how that gets on with my setup.
 

·
Registered
Joined
·
4,273 Posts
Haha, I was hoping you were going to say you had it disabled and that was the missing link as to you not having issues. Oh well I still have the Yamaha turning up tomorrow so I will see how that gets on with my setup.
You can try re enabling arc for troubleshooting purposes. If it comes back, then turn it back off.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #15 ·
You can try re enabling arc for troubleshooting purposes. If it comes back, then turn it back off.

Yeah I will try that. Makes sense, thanks.



If it does solve the issue I will be very happy, although I will still try out the Yamaha and see how it compares in terms of sound quality. So many conflicting reviews on which is better, however at the moment I just want a blink free setup.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #16 ·
You can try re enabling arc for troubleshooting purposes. If it comes back, then turn it back off.



Just tried this again. 40 mins with ARC off and no blinking. Turned on ARC and the blinking came back within a few minutes. Its definitely looking like ARC is the issue.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #17 ·
Just updating this thread in case anyone else is experiencing the same thing. I have tried the Yamaha RXA 2070 and it too has the same blinking problem. It also doesn't sound as good as the Marantz 7012 so is going back.
 

·
Registered
Joined
·
4,273 Posts
Just updating this thread in case anyone else is experiencing the same thing. I have tried the Yamaha RXA 2070 and it too has the same blinking problem. It also doesn't sound as good as the Marantz 7012 so is going back.
So I guess the Sony TV might be the culprit???
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #20 ·
So I guess the Sony TV might be the culprit???
It's looking that way at this present time. I have reached out to another owner of my display and he also has the same problem but it doesn't with his projector.



Did you try new cables?



Verzonden vanaf mijn iPhone met Tapatalk

Yes. I have tried many cables and am now running premium certified cables. The marantz receiver has a built in cable tester which marantz support got me to run and it passed.
 
1 - 20 of 22 Posts
Top