AVS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
199 Posts
Discussion Starter · #1 ·
Matricom G-Box MX2 Dual Core and denon 2100 reveiver issues
have a Matricom G-Box MX2 Dual Core and denon 2100 reveiver the gbox is connected to the denon hdmi and i'm having issues and when play a movie or tv show its been flashing and going blank for few seconds its very frustrating.
can someone please help me on this
Thank you
 

·
Registered
Joined
·
47 Posts
Matricom G-Box MX2 Dual Core and denon 2100 reveiver issues
have a Matricom G-Box MX2 Dual Core and denon 2100 reveiver the gbox is connected to the denon hdmi and i'm having issues and when play a movie or tv show its been flashing and going blank for few seconds its very frustrating.
can someone please help me on this
Thank you
When it goes "blank" it's just a black screen you see I presume? Does the audio also drop out with picture? Also, what label HDMI connection is it connected to? I ask these questions because I had very similar issues with my cable box connected to an X4100 and was advised by jdsmoothie to try another HDMI connection (this was the "cable/sat" connection" I believe) because all my other video connected sources did not exhibit this issue... haven't had that issue since. It sucks though, because I basically can never use that port.
 

·
Registered
Joined
·
199 Posts
Discussion Starter · #3 · (Edited)
Picture and audio goes out and yes black screen and its hooked up to media canter i could try diffent hdmi connection but i just got this denon receiver i could send it back yet but whats not to say it wont do it again? and its a pain to send back. do you think i should send it back?
 
1 - 4 of 4 Posts
Top