AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
284 Posts
Discussion Starter · #1 ·
I wonder if anyone knows what's happening here:


Using MCE2005, some of my DVD's have started playing in 4:3, rather than 16:9. Its clearly the wrong aspect ratio, with tall-thin-people and black bars at the sides. I should stress, this is happening with anamorphic DVD's.


Play the same DVD in Zoom Player and it runs at 16:9 just fine.


I can "fix" the MCE problem by chosing a Zoom mode to stretch the image horizontally. But this isn't really a fix, because then all of the other DVD's I play are too stretched: cropped at the sides and the images are too fat.


So what's going on? How does MCE decide whether to output 4:3 or 16:9? And why is it getting it wrong with some DVD's, but not others? Its all very odd.


Chip
 

·
Registered
Joined
·
7,958 Posts
Very odd.


Never happened with my MCE install. What MPEG2 codec are you running? (I'm using the nVidia ones)


My install is configured as follows :


Windows resolution 16:9 1024x576 (with 50Hz refresh rate interlaced) using Powerstrip. (1024x576 is square pixel widescreen "PAL")

Video card is ATI Radeon 9600 Pro

PC connected to RGB SCART input on 16:9 SD TV via VGA to SCART cable

DVB-T capture card to receive UK SD OTA digital TV

MCE 2005 installed with all rollups and updates


When replaying 16:9 anamorphic DVDs, watching 16:9 anamorphic Live TV or Recorded TV, MCE realises the source material and the display resolution are the same, so doesn't offer any Zoom options.


When replaying 4:3 material or watching full-width 4:3 Live TV, MCE defaults to pillarbox display (with black bars left and right), but also offers the option of stretching this to 16:9, or cropping and zooming the central 16:9 portion to 16:9.


I think the MPEG2 codec is what tells MCE the aspect ratio of material (as 4:3 and 16:9 DVD have the same resolution - they are non-square pixel based) - it could be that Zoom player is using a different MPEG2 codec?


Might be worth checking which your preferred MPEG2 decoder is using the MS DecCheck utility that can be downloaded, or just re-installing the MPEG2 decoder?
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #3 ·
Thanks. I guess its probably the decoder. I have pretty much decided to use dscaler all the time now, after some initial experimentation with the nvidia decoder and others.


I have the dscaler decoder set to be the default, using the MS DecCheck utility.


I will try changing to the nvidia decoder to test to see whether that fixes it - and therefore if I can isolate Dscaler as being the cause.


Cheers


Chip
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top