AVS Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Just bought 2012 on Blu-ray, and I ran it on my HTPC. Problem is, when I finally get to the main menu, the menu doesn't show! The background images and sound play, but I can't access any menu. Even pressing random keys doesn't seem to work.


I thought it may be the disc, but I popped it into a PS3 (not mine) and it played fine. Any idea as to WTF is going on? I just seem to be having really crappy luck with HD on my HTPC (District 9 refuses to even play, just gives me "Disc with unsupported format in drive" error).


My setup:

Windows XP

2GB RAM

ATI radeon HD 4670 AGP

PowerDVD 9 Ultra

Sharp 26" LCD w/HDMI
 

·
Registered
Joined
·
537 Posts
what player are you using?
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
Sorry, forgot to include that. I'm using PowerDVD 9 Ultra, upgraded from PowerDVD BD Edition that was bundled with my hardware. I'm using an LG CH08 Super-Multi Drive.
 

·
Registered
Joined
·
17 Posts
I just finally got around to watching the copy I picked up yesterday and sure enough it won't play on PowerDvD 9 Ultra. The disc loads fine but the menu will not appear, so you can't play the movie.


Hopefully they'll patch it soon.
 

·
Registered
Joined
·
1 Posts
I have the same issue using Dell Media Direct on my laptop. First time attempting to play, the blu ray would not load at all. Then I updated to latest patch and disk loads, plays previews, and finally shows main menu background images for 2012, but no actual menu text to select play. Also tried hitting just about every key on my keyboard and clicking randomly around the screen with my mouse, but nothing works. I even used the remote that came with my laptop and hit the enter key there.. but did not work. All I can do is stop and reload to watch previews. I have the Digital Copy disk but it's not in HD and that's specifically why I purchased this BluRay. I'm upset.
Any ideas please?
 

·
Registered
Joined
·
2,439 Posts
This is exactly the reason I gave up on PowerDVD and started ripping EVERYTHING and playing with the free players. After 3 years of putting up with their crap I said enough is enough, I had it happened a couple of times when I had guests over.


I paid for PowerDVD 7 & 9 Ultra and it’s not installed on any of the 5 HTPC's in my house.



Mike
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #10 ·

Quote:
Originally Posted by bbowman71 /forum/post/18242878


I just finally got around to watching the copy I picked up yesterday and sure enough it won't play on PowerDvD 9 Ultra. The disc loads fine but the menu will not appear, so you can't play the movie.


Hopefully they'll patch it soon.

I downloaded the latest update directly from Cyberlink's website, and that seems to have fixed the menu problem in 2012. As for the Dell Media Direct issue, I honestly don't know how to fix that one.
 

·
Registered
Joined
·
2 Posts
i got 2012 on Blu-ray to after i retune it for the 2nd time it still do not work not on my lap top i have a HP HDX Premium Series Lap top that use HP Media Smart bilt in the hard drive But were you saying if i go on the Cyberlink's Website that that should fix the movie
John ????
 

·
Registered
Joined
·
2,652 Posts
Download the latest update from Cyberlink website and 2012 menu should work. The menu didn't work for me but after I updated it did.
 

·
Registered
Joined
·
1,076 Posts
The latest update for Power DVD 8 does not fix it.----oops scratch that a new update released on 04-21-10 fixed it.
 
1 - 16 of 16 Posts
Top