AVS Forum banner
1 - 20 of 118 Posts

·
Banned
Joined
·
1,803 Posts
Man am I out of touch. I have a MFW-15 and have had not issues, to my knowledge, that there were amp issues. What, exactly, can I read about what's going on?
 

·
Registered
Joined
·
3,696 Posts
Funny you should mention this. I just ordered an MFW 15. Talking to Kyle over at AV123, he said they're testing each and every unit to make sure they're working properly before they ship.


Don't know what amp they were using before, buy Kyle mentioned they're now using the BASH amp.
 

·
Premium Member
Joined
·
26,233 Posts
I would suggest just bumping the existing poll/thread, instead of starting an entirely new thread on the same issue. That way it makes it easier for those interested like atdamico would have a background and you could then seek feedback from all those ppl who have already given this type of information.


Here's the on-going poll

http://www.avsforum.com/avs-vb/showt...highlight=poll


Ron
 

·
Registered
Joined
·
103 Posts
From the comments I've read here and at AV123 forum, the issue with the Amps failing is allegedly due to Chinese manufacturing and the possibility of Black Market parts being used over there. Most of the Amps that failed did so in the first month or two. AV123 was supposed to be switching to a new manufacturer. Not aware that they already have replacement amps on hand.


I have a B-Stock MFW and I have not reached the 2 month window yet so we shall see. Notwithstanding the amp issue, it's a heck of a unit and the B-Stock price was a steal.
 

·
Registered
Joined
·
521 Posts
With two MFWs going for a year now, I stepped away from AV123 and this subforum for awhile. Now coming to check out what's new, I hear about MFW failures, I guess I got lucky because I received one of the first batches from last Jan. I hope AV123 gets a handle on the failures because this is a great subwoofer for the price and it's a shame to see it have such ongoing issues.
 

·
Registered
Joined
·
3,696 Posts

Quote:
Originally Posted by phipp01 /forum/post/15562511


I read on their forum that they now have another company making the amps and that things should be better.

Did you ever hook up with Mark at AV123? He's got what I consider a great "offer" for you if you take him up on it.
 

·
Registered
Joined
·
1,164 Posts

Quote:
Originally Posted by graphicguy /forum/post/15562960


Funny you should mention this. I just ordered an MFW 15. Talking to Kyle over at AV123, he said they're testing each and every unit to make sure they're working properly before they ship.


Don't know what amp they were using before, buy Kyle mentioned they're now using the BASH amp.

You sure about this?
 

·
Banned
Joined
·
2,969 Posts

Quote:
Originally Posted by MUCHO /forum/post/15565450


You sure about this?

IIRC I read something about that on their forum too. I tried to find MLS's post regarding the new amps and I couldnt figure out which thread it was in. Or for that matter if it was in the update, loudspeaker, or subwoofer forum over there.






turkey bacon
 

·
Banned
Joined
·
2,969 Posts

Quote:
Originally Posted by graphicguy /forum/post/15565242


Did you ever hook up with Mark at AV123? He's got what I consider a great "offer" for you if you take him up on it.

As a matter of fact I sent him an email last Sunday, he replied, I replied to his reply on Monday, havent heard back from him but he is a VERY busy guy.
 

·
Registered
Joined
·
103 Posts

Quote:
Originally Posted by phipp01 /forum/post/15566202


IIRC I read something about that on their forum too. I tried to find MLS's post regarding the new amps and I couldnt figure out which thread it was in. Or for that matter if it was in the update, loudspeaker, or subwoofer forum over there.






turkey bacon

Here's the quote from MLS: "Lets try to find a place where we can both learn about each other... The MFW-15 has had some amplifier issues - and we have figured these out - and we have informed out Agent in China to visit the sub contractor and in a quiet voice "present our findings"... This has been done - and everyone is on the same page...


Our Chinese Agent (ZengMing) has opened our own facility to manufacture electronics - we opened it 6 weeks ago - and product is flowing..."


It's a little vague as to what is flowing and where it's flowing to.
 

·
Banned
Joined
·
2,969 Posts

Quote:
Originally Posted by ppomerantz /forum/post/15567344


Here's the quote from MLS: "Lets try to find a place where we can both learn about each other... The MFW-15 has had some amplifier issues - and we have figured these out - and we have informed out Agent in China to visit the sub contractor and in a quiet voice "present our findings"... This has been done - and everyone is on the same page...


Our Chinese Agent (ZengMing) has opened our own facility to manufacture electronics - we opened it 6 weeks ago - and product is flowing..."


It's a little vague as to what is flowing and where it's flowing to.

OK I remember that one but I think there was another one that mentioned BASH. I'm probably wrong, it might have even been an employee or a poster who said it.
 

·
Registered
Joined
·
3,696 Posts

Quote:
Originally Posted by MUCHO /forum/post/15565450


You sure about this?

MUCHO...am I sure? I'm just repeating what Kyle over at AV123 told me. I don't know why he would tell me that if it wasn't so. But, without knowing what amp they were using before, and what they're using now, I guess I'd have to say I'm not sure. Kyle also said there was quite a bit of concern from a company standpoint to get units out that are tested individually before shipment. Whether this is done at the factory, or at their HQ in CO, I'm uncertain.


I know if I were in AV123's shoes, and a supplier did this to me, I think I'd be looking for a new supplier, too. Matter of fact, Mark stated as much...that they were looking at that option, at much higher cost to AV123. So far, I haven't seen any price increase, though.


The MFW 15 is just one of their flagship products. And, best I can tell, it's also highly rated. I don't know that I'd dally too long in making sure one of my flagship products worked as specified. I do know that Mark put a lot of effort into the design. It certainly has to be a "*****" if you put all that effort into it, only to see a supplier screw it up.


All that said, I've had multiple speaker systems from AV123 in my system over the years. They've been sterling....sound quality, build quality and operationally. And, AV123 has always bent over backwards to take care of me...many times above and beyond what can be reasonably expected.
 

·
Registered
Joined
·
103 Posts

Quote:
Originally Posted by graphicguy /forum/post/15562960


Funny you should mention this. I just ordered an MFW 15. Talking to Kyle over at AV123, he said they're testing each and every unit to make sure they're working properly before they ship.


Don't know what amp they were using before, buy Kyle mentioned they're now using the BASH amp.

When you get your unit take a picture of the amp, post it on the thread and we'll settle this once and for all. When's it shipping?
 

·
Registered
Joined
·
3,696 Posts

Quote:
Originally Posted by ppomerantz /forum/post/15570066


When you get your unit take a picture of the amp, post it on the thread and we'll settle this once and for all. When's it shipping?

I will definitely do that. Right now, I'm awaiting word from Kyle about the "Diamond" finishes MLS said they had floating around. Very nice!
 

·
Registered
Joined
·
3,696 Posts
Got one being delivered later this week....."Diamond Cherry". When it gets here, I'll definitely post pics of both the finish and the amp.


They've got my Diamond Cherry and Moho Diamond (as of last Friday). I've only seen pics of the Diamond Black. But, that's supposed to be 30+ days out.


Here's a thread with the pics of the Diamond Black.....very sharp....

http://av123forum.com/showthread.php?t=39844
 

·
Registered
Joined
·
403 Posts
I received my new A stock from AV123 last week. The amp appears to be the same amp that is in the photos from the amp fix thread on their website.


My amp had the hum caused by wire routing. I was able to fix but this leads me to believe that the new amps have not hit the street yet and the subs are still being assembled in a way to not prevent the hum.


There were no indications on the sub or amp to indicate manu or assembly date. It is possible I got a sub that had been sitting in a warehouse for while.
 

·
Registered
Joined
·
7 Posts
thanks av123 for not responding to my email. i am now going to be a happy owner of a elemental design sub. hands down great customers service.
 
1 - 20 of 118 Posts
Top