AVS Forum banner

4801 - 4820 of 5281 Posts

·
** Man of Leisure **
Joined
·
23,206 Posts
With a response curve that will need some pulling down of these peaks and a MiniDSP 2x4HD and a NAD 758v3 with Dirac should I:

a.) Do autoEQ with REW into the MiniDSP and let Dirac do the rest

b.) Just let miniDSP handle the worst peaks with a negative HSQ and a little LSQ and then let Dirac do the rest

c.) let Dirac in the NAD do everything and the MiniDSP just for consolidation of the 3 subwoofers (distance/gain) following Jerry's guide

I am not sure what the best approach would be as far as headroom and dynamics are concerned.

Also with my Crown XLS 2502 Amp would it be better to put the input attenuaters to full and lower the sub signal with the MiniDSP (MV)? The amp is a bit too powerful for 4 JBL I was told.

I will be running 12 JBLs, each 4 JBL will get its own 2502 bridged. :)

TIA
Nima
Typically, I will measure the combined sub response with Dirac turned off. If it looks like the response might benefit from applying PEQ, I use REW to calculate the PEQ, and apply if before running Dirac. Example:



After PEQ has been applied, Dirac has an easier job placing the finishing touches on the combined sub response.



And finally, don't forget to experiment with the sub distance tweak to optimize the alignment between subs and mains.

I don't have an opinion WRT the signal level into your amp.
 

·
Registered
Joined
·
1,516 Posts
Thanks Jerry this looks nice. I guess I got a bit more work with my FQ. Did you also apply boosts? Did you use AutoEQ in REW?

TIA
 

·
** Man of Leisure **
Joined
·
23,206 Posts
Thanks Jerry this looks nice. I guess I got a bit more work with my FQ. Did you also apply boosts? Did you use AutoEQ in REW?

TIA
The example shown is using REW’s EQ tool. I rarely pay much attention to the amount of boost or attenuation being applied, since the correction is quite modest.
 

·
Registered
Joined
·
664 Posts
NP. I should have clarified a bit on the router settings as I didn't quite explain that part properly. I'll blame that on pouring over the WI-DG manual + on my first cup of coffee at the time. LoL. :)

The TTL (Time-To-Live) is a function of how long a device waits for a connection to receive a response. Your router will have that setting somewhere as well (though you may or may not be able to modify it). That's not too likely to be the problem here, but you could increase it on both the router and the WI-DG and see if that helps. Normally, that could be the culprit if you had a congested WiFi network or got intermittent connection drops for some other reason.

There's another function (which I did a poor job of describing earlier) that is user-configurable on some routers, which has to do with pinging the host the router is connected to (i.e. the WI-DG) that's more like an "Are you still there?" message. I don't think it's likely the problem here. It's one of those things more common in large networks where resource allocation is more likely to be a concern. Something to consider if the more likely solutions don't work....

The time of the IPv4 leases that your router assigns is the most likely culprit. To test that, either increase the length of time DHCP leases live until they expire or hard-code the WI-DG's MAC address and assign it a specific IPv4 address that it and only it will ever be assigned. The downside to increasing the DHCP lease time is every device that connects to the WiFI router temporarily will clog up your pool of IP addresses until they reset via the timer. If you have a lot of guests using your network on a daily basis, you might run out of IP addresses if you set the DHCP lease to a really long interval. It's unusual to see leases >24 hours max. There are some esoteric security reasons to use shorter DHCP leases, but on a home network this virtually always a non-issue.

If there's a way for you to hard-code a specific IPv4 address to the WI-DG's MAC address, I would suggest that route. If you're using DHCP, it's often called "DHCP Reservation" which is just a fancy way of saying "reserve an IP address for this host only." I looked up the manual for the Linksys WRT1900ACS here, and the instructions for this process are on page 27.

If all of your host devices connected to the WiFi router already use static IP addresses, then there's something else amiss and I'd be inclined to focus on the WI-DG instead as the likely culprit. If that's the case, the TTL values are more likely to come into play as well, but still unlikely to be the problem given the behavior you've described.
Thanks for the advice, but no luck so far. I tried the DHCP reservation initially, but the WI-DG wouldn't connect - timed out after 3 attempts. I next tried the same thing, but by choosing the WI-DG from the network map. It said it connected, but when I looked at it a few hours later I don't think it ever did. The level indicators weren't changing with the music/movie, and muting different outputs had no effect. I managed to connect using the "auto" IP address and watched a movie and called it a night. I also increased the lease time from 24 to 48 hours but I don't think it made any difference.

The next day I did the DHCP reservation again, butt his time changed the IP address. I reset the miniDSP, WI-DG, and DSP software. Upon restarting I entered the new IP address and everything worked. I used everything the rest of Saturday night without any issues. Even Sunday afternoon everything was still fine - listened to music while watching the NFL games. A few hours later it was "locked up" again. The level indicators were frozen and muting outputs had no effect. I reduced the volume and switched to a different configuration with a big bass boost and I could tell that there was no change. I closed the software and logged out/in on my laptop. After restarting the software and entering the IP address, it wouldn't connect. Got the one time "connection timed out" error - it didn't try 3 times. Anything else I can try?
 

·
Wireless member
Joined
·
27,111 Posts
Basic WiFi stuff. Do you know what channels your WiFi is using? Have you scanned your living space for WiFi signals? If you answer no to the second, you could have interference from other ppl’s WiFi. I use Fing on my iPhone. I think it might be available for Android as well. (It’s free.) it will show every WiFi signal with channel and signal strength.

If your WiFi is on a crowded channel, change the channel. Run through setting up The MiniDSP wifi bridge again. It will follow.
 

·
Registered
Joined
·
1,600 Posts
Thanks for the advice, but no luck so far. I tried the DHCP reservation initially, but the WI-DG wouldn't connect - timed out after 3 attempts. I next tried the same thing, but by choosing the WI-DG from the network map. It said it connected, but when I looked at it a few hours later I don't think it ever did. The level indicators weren't changing with the music/movie, and muting different outputs had no effect. I managed to connect using the "auto" IP address and watched a movie and called it a night. I also increased the lease time from 24 to 48 hours but I don't think it made any difference.
Well, re-iterating the fact I don't have a WI-DG for reference - but I have read the manual for it - the first process when you tried the DHCP reservation method on the router.... FYI, you must reboot the device you're connecting to after making such a change on the router. Sometimes you need to reboot the router as well (or force a refresh of its DHCP table). Unfortunately, exact steps in this process are highly dependent on the devices involved.

The next day I did the DHCP reservation again, butt his time changed the IP address. I reset the miniDSP, WI-DG, and DSP software. Upon restarting I entered the new IP address and everything worked. I used everything the rest of Saturday night without any issues. Even Sunday afternoon everything was still fine - listened to music while watching the NFL games. A few hours later it was "locked up" again. The level indicators were frozen and muting outputs had no effect. I reduced the volume and switched to a different configuration with a big bass boost and I could tell that there was no change. I closed the software and logged out/in on my laptop. After restarting the software and entering the IP address, it wouldn't connect. Got the one time "connection timed out" error - it didn't try 3 times. Anything else I can try?
I'm realizing that I am so used to dealing with these types of issues that I hadn't realized that I was not being explicit enough for you with some steps.

So... if I understand what you've tried so far, it sounds as if the first time around making the DHCP reservation changes, you also hard-coded the new IP address onto the WI-DG. It sounds counter-intuitive, but you don't want to do that. Let me try another way of explaining the steps.

First off, let's go over your options again and I'll attempt to be more detailed/thorough on my end:

You could:

1. Extend the lease time period on the WiFi router (which you've already done; to 48 hours) only
2. Or, you could not change the DHCP lease time period on the WiFI router and just give the WI-DG a static IP address
3. Or, you could do both (recommended)

Now, so far it seems you've already extended the lease time to 48 hours, so that's good. However, your description of the events after that sound as if the WI-DG now has a hard-coded IPv4 address (static IP) in its memory. This would mean it will always think that's supposed to be its IP address. That would work for the first 48 hours after the change was made to the router's DHCP lease time (if you're still using DHCP... which I would imagine you are). After that, the IP address reservation expires, and the router picks a new address for your device. What would happen then is because the device has its understanding of its IPv4 address hard-coded, you then have a mis-match between the WI-DG and WiFi router. It sounds like this is what happened.

If I'm right, you're almost to a solution.

Note 1: A "DHCP Reservation" is an assigned static IP address within the DHCP range. However, the device connecting to the network doesn't know it's a static IP (and it doesn't need to know). You need to leave the connecting device (WI-DG in this case) in DHCP mode. I suspect that is the only mode the WI-DG understands - based on my read of its manual - but I'm stating that here to be clear.

Note 2: I am presuming the WI-DG is always operating in DHCP mode when it connects to a WiFi network in Station Mode. I don't see any reference in the WI-DG manual indicating it's possible for you to select DHCP or static IP assignment mode.

Note 3: After studying the WI-DG manual more carefully, it appears you also need to make an adjustment to the MiniDSP via a Plugin (MiniDSP -> WI-DG). I've added a step for that below.


Let's start the process over and try this:

1. On your WiFi router: Enter the administrative interface. Here's what you want to accomplish:
a. Create a fixed IP address associated with your WI-DG device. This process may be called "DHCP Reservation" or "Fixed IP Address" or "Static IP address" or something like that.
b. Presuming you do have a WRT1900ACS, it is called "DHCP Reservation" and is found on page 27 of the manual (8820-01897 Rev. A00); found here.
c. If you already setup the DHCP Reservation, don't change anything, but note the IP address you assigned.

2. On your WI-DG: Verify the WI-DG is set to Station Mode and assigned to the appropriate WiFI network. If there's any sort of option in its admin interface not mentioned in its instruction manual that allows you to set its IP assignment mode to DHCP or Static modes, ensure it is set to DHCP.

3. On your Mini-DSP: Unplug your MiniDSP. Leave it that way for the moment.

4. On your WI-DG: Unplug your WI-DG. Leave it that way for the moment.

5. On your WiFi router: Perform a hard restart of your WiFi router (unplug it for 30 seconds or perform a "cold restart" from the admin interface). You're usually better off doing the manual unplug-wait-plug it in again method.

6. Wait for the WiFi router to complete booting.

7. On your WI-DG: Restore power and wait for it to boot-up and connect to your WiFi network. There are some guidelines in the WI-DG manual that tell you how to interpret its indicator lights for this purpose (pg. 9)

8. On your WiFi router: Login to the administrative screen and get to the DHCP pages. You want to view your current DHCP IPv4 address associations. Verify you see the WI-DG's assigned DHCP reservation associated with the WI-DG's device MAC ID, and that it is an Active DHCP lease.

9. On your WI-DG: Locate and verify your WI-DG's assigned IPv4 address on the System Information screen. Verify what it thinks is its IPv4 address matches what you see right now on the WiFi router's DHCP list association for the WI-DG.

10. On your MiniDSP: Connect to the MiniDSP with a computer. Start the MiniDSP plugin on the MiniDSP. In the plugin's interface, locate the field named "IP Address" (see page 15 of the WI-DG manual). Check the "Auto" checkbox. Wait for it to identify the IPv4 address of the WI-DG. Verify it matches what you see in the WI-DG's administrative interface and the WiFi router's administrative interface. If they all match, click on the Connect button in the plugin user interface. [and if they do NOT all match, then something is misbehaving]

You *should* now be Good-To-Go.

Please report back on whether or not this fixes it once and for all or not. IF NOT, you could a) try connecting between MiniDSP and WI-DG using the USB Method (see bottom of page 15 in WI-DG manual v1.7); OR b) you may have either uncovered a bug or have a defective MiniDSP or WI-DG; OR c) there's some strange business going on with your WiFi router and how it manages wireless DHCP; or d) when the router's lease expires and it renews the lease, it may be creating a hiccup between the WiFi router and the WI-DG where the latter is dropping the connection and failing to re-establish it automatically.

If you continue to have trouble, based on current info I'd be inclined to suspect it's either a defective WI-DG or the WI-DG is WAD (Working As Designed) and the product has what I would consider a design flaw. It *might* be possible to correct such a problem by increasing the TTL (Time To Live) value in the WI-DG (set it to maximum, which I believe is 255).


Basic WiFi stuff. Do you know what channels your WiFi is using? Have you scanned your living space for WiFi signals? If you answer no to the second, you could have interference from other ppl’s WiFi. I use Fing on my iPhone. I think it might be available for Android as well. (It’s free.) it will show every WiFi signal with channel and signal strength.

If your WiFi is on a crowded channel, change the channel. Run through setting up The MiniDSP wifi bridge again. It will follow.
That's not the problem in this case. The device isn't going to pair with a network willy-nilly. One must tell the WI-DG which network to join. Changing the network it connects to requires logging into the WI-DG's administrative interface, which requires a login/password and connection via either a wired network cable or connecting to a short-range network the WI-DG broadcasts.
 

·
Registered
Joined
·
664 Posts
@HT Geek Thanks again for such a detailed write up. I've done basic home WIFI setup, but I'll admit my knowledge on these things is pretty low. Normally things are pretty plug and play so I haven't ever had to learn much beyond the basics. I don't get much time during the week, but I'll try everything you recommended as soon as possible - hopefully Wednesday. The router is a Linksys WRT1900ACs.
 

·
Wireless member
Joined
·
27,111 Posts
That's not the problem in this case. The device isn't going to pair with a network willy-nilly. One must tell the WI-DG which network to join. Changing the network it connects to requires logging into the WI-DG's administrative interface, which requires a login/password and connection via either a wired network cable or connecting to a short-range network the WI-DG broadcasts.
I suggest some additional reading on your part. Every packet impinging on both access points and clients must be examined by same to determine if it is from an in-network device. This consumes time and processing power. Especially for devices with flea-powered CPU's, being on a crowded channel can cause the symptoms described. I frequently see it interrupting robust WiFi networks.

If everybody Plugs and Plays their routers/access points, everybody with Linksys will be on the same channel. Ditto for all of the other brands as well as they all have default channels.
 

·
Registered
Joined
·
664 Posts
@HT Geek

7. On your WI-DG: Restore power and wait for it to boot-up and connect to your WiFi network. There are some guidelines in the WI-DG manual that tell you how to interpret its indicator lights for this purpose (pg. 9)

8. On your WiFi router: Login to the administrative screen and get to the DHCP pages. You want to view your current DHCP IPv4 address associations. Verify you see the WI-DG's assigned DHCP reservation associated with the WI-DG's device MAC ID, and that it is an Active DHCP lease.

9. On your WI-DG: Locate and verify your WI-DG's assigned IPv4 address on the System Information screen. Verify what it thinks is its IPv4 address matches what you see right now on the WiFi router's DHCP list association for the WI-DG.
For step #7 do mean just the WI-DG or both it and the miniDSP? For step #8 how can I tell it's an active DHCP lease? I know you said you don't have a WI-DG, but can you clarify step 9? Do your mean on the laptop's network properties page? The only way to look at the WI-DG otherwise is it's software which doesn't seem to show any general properties - just the IP address that can be entered manually or automatically.

The USB method works great - that's what I used over the holiday break. I'd rather not use that since I don't want a long wire running across the room and I've already paid for the WI-DG. The WI-DG used to connect more reliably. During the past few months (and a few Windows 10 updates) it's been more problematic. I updated the miniDSP's firmware but it didn't seem to help. The firmware update was supposed to address some Wi-DG issues.
 

·
Registered
Joined
·
664 Posts
@pepar Not lately. I used to have an app on my old phone, but I'll get one and scan again. I know at one time I made a change based on how much traffic each channel was seeing.
 

·
Wireless member
Joined
·
27,111 Posts
That right there places you above 90% of home WiFi users. I was in error about the app name. Fing is for network devices in general. iOS iPhones/iPads will use the free Apple app, Airport Utility.

It can’t hurt to check and you might just find the reason for your problems. It doesn’t seem like anything else has worked for you.

Jeff
 

·
Registered
Joined
·
1,600 Posts
I suggest some additional reading on your part. Every packet impinging on both access points and clients must be examined by same to determine if it is from an in-network device. This consumes time and processing power. Especially for devices with flea-powered CPU's, being on a crowded channel can cause the symptoms described. I frequently see it interrupting robust WiFi networks.

If everybody Plugs and Plays their routers/access points, everybody with Linksys will be on the same channel. Ditto for all of the other brands as well as they all have default channels.
Why do you presume that I need to perform additional reading? Of what? I understand what you’re saying.

You're suggesting the design and function of the WI-DG may inhibit its performance in noisy 802.11 RF environments, and the O.P.'s equipment may be in a noisy RF environment.

My starting position is the RF environment is likely not congested. Therefore, I see no reason to look in that direction as a first or second tier of troubleshooting. If I had physical access to the O.P.'s site then I'd have a lot more info (and I wouldn't be bothering to spend my free time writing these forum posts). If I were there in person, perhaps I'd consider running a site survey or a proper 24/7 environmental survey. Either way, to do that requires appropriate knowledge, equipment, and time. It's more efficient to address the low-hanging fruit possibilities first; unless one has unlimited resources.

Most modern WiFi client devices are robust enough to automatically make repeated attempts to connect and re-establish dropped connections, dropped packets, etc. However, that is of course depends on the device (hardware), drivers (software), and configuration (software and/or user). Those would be questions to pose to the WI-DG manufacturer, as it's beyond the O.P.'s control and I'll bet no one on this forum will know the details. Even the manufacturer might not if they outsource their physical production.

IMHO, I believe in this case, your scenario is less likely to be the culprit vs. other possibilities. That doesn't mean I didn't think of it. I'm presuming the O.P. is not in a congested environment since we're talking about a home theater. Probably not in a condo. Probably not in an apartment. Definitely not an office environment. Probably not in an industrial environment. Likely not a high RF noise environment, though it could be. I'm not disagreeing about whether or not your suggestion could cause the O.P.'s issue, but it seems unlikely UNLESS there is a hardware limitation (as you mentioned) AND the RF noise in the O.P.'s environment exceeds the threshold of (probably the WI-DG). My presumptions about the environment could be wrong. If they are, that might tip the scales in the other direction. I do agree the problem is likely some quirk of the WI-DG to begin with, but in what way? That is the question.

What advice is practical, and what is truly helpful? We're all exchanging ideas on an internet forum. There's only so much one can do to help another person remotely. What's the person's perceived technical ability that one is helping? What tools and resources do they have available? How much effort are they willing to put forth?

If you feel strongly about the possibility the O.P.'s problem is caused indirectly by a hyperactive wireless environment, perhaps you'd care to educate them on how to conduct a site survey and analyze the data, and then provide them with suggestions for mitigation strategies.
 

·
Registered
Joined
·
1,600 Posts
@pepar Not lately. I used to have an app on my old phone, but I'll get one and scan again. I know at one time I made a change based on how much traffic each channel was seeing.
That right there places you above 90% of home WiFi users. I was in error about the app name. Fing is for network devices in general. iOS iPhones/iPads will use the free Apple app, Airport Utility.

It can’t hurt to check and you might just find the reason for your problems. It doesn’t seem like anything else has worked for you.
@Spidacat, to @pepar's point, is there any possibility of you taking your WiFi network out of the equation temporarily for the purpose of troubleshooting?

Would it be feasible for you to connect your WI-DG via the Ethernet port (CAT-5/6) and make a direct connection to see if you continue to have disconnects? Even then, I don't know if that is functionally possible with the WI-DG or if it's still going to try and connect to your WiFi, so ideally you'd want to turn off the WiFi on your router at the same time to (theoretically) prevent that scenario.

I know that's a lot to ask and I presume not a realistic possibility for you or perhaps you've already tried that. If you could go this route, it would determine definitively whether or not the WiFi network is a factor at all.
 

·
Registered
Joined
·
1,600 Posts
For step #7 do mean just the WI-DG or both it and the miniDSP?
You're right. I missed a step. The power should be turned back on for the MiniDSP as either step 6.5 or 7.5. I don't know how to advise you of which one (perhaps before the WI-DG?), due to my ignorance over how the MiniDSP and WI-DG work with one another (I have direct access to neither).


For step #8 how can I tell it's an active DHCP lease?
Should be on that page or a similar page in the Linksys admin GUI, yes. Again, we are running into the limits on my (lack of) experience working with that particular router. In a nutshell, there should be a page display somewhere in the admin GUI that shows you current (active) DHCP leases. What you are looking for here is to confirm the router has connected with the WI-DG device.

BTW, this info is normally very limited on consumer-grade routers. Most keep a DHCP lease "reserved" until the lease timer is up (48 hours after you changed it) even when the client device isn't connecting to the router. Let's say you put your laptop to sleep or turn it off. When you turn it back on again, it will wake-up and still be able to use the same IP address it had when it went to sleep, provided the router did not release (expire) the DHCP IP address the laptop last used. My point is just because a lease shows as active in the router's GUI does not mean there's an active connection at that moment. What I've been guiding you through however, are steps to ensure the IPv4 address of the WI-DG doesn't change.

Many, many factors depend on nuances of the equipment involved. These instructions are about as generic as I can make them while still being relevant. The reason for all the power shuffling is to ensure DHCP reservations have been wiped from the router and that the WI-DG and MiniDSP "forget" their network associations. It's not uncommon for a warm boot/soft boot of a router to not completely erase its cache memory and you end up with the old DHCP table. Same for other devices that may fail to release and renew their IP. We want to prevent that in your case, and force the router to re-establish the WI-DG's local IPv4 address and force other connected equipment to re-validate the WI-DG IPv4 address.


I know you said you don't have a WI-DG, but can you clarify step 9? Do your mean on the laptop's network properties page?
Based on my read of the WI-DG manual, there appears to be a GUI (Graphical User Interface) you have access to. These days, that's usually via a web page/browser when connected to the device. According to the WI-DG manual, there is a status page where you should see it's currently assigned IPv4 address (what the WI-DG thinks it is). You want to correlate that to what the router thinks the WI-DG's IPv4 address is. Make sure they are the same.


The USB method works great - that's what I used over the holiday break. I'd rather not use that since I don't want a long wire running across the room and I've already paid for the WI-DG. The WI-DG used to connect more reliably. During the past few months (and a few Windows 10 updates) it's been more problematic. I updated the miniDSP's firmware but it didn't seem to help. The firmware update was supposed to address some Wi-DG issues.
GTK. The beauty of the USB approach is no IP connections involved at all. Is it worth considering finding a creative way to route (and conceal) a USB cable and be done with it?

If the DHCP address reservation changes don't help consistently, and if you can't reasonably use a hard-wired USB or CAT-5/6 cable, then I would agree with @Papar; that it's time to look at your WiFi environment, OR potentially try your luck with the manufacturer. The latter could take a long time and you might be sans adapter for several weeks. The former can be time consuming (depending on scope), but at least it is under your control. No guarantee of results no matter what. :(
 

·
Wireless member
Joined
·
27,111 Posts
@HT Geek:
1. I used to post wordy and didactic posts, too.
2. I did not allege a “noisy” environment. (i speculated his channel might be crowded.) Or anything about the WI-DG’s design.
3. My starting “position” is that I don’t know what the problem is and I am interested in exploring anything that fits the scenario.
4. If you were there in person, and would do a site survey, why poo-poo that as my suggestion?
5. I feel strongly that I made a valid suggestion and do not care to joust with anyone about it.
 

·
** Man of Leisure **
Joined
·
23,206 Posts
TBH, it would be nice to see this thread return to a civil discussion of MiniDSP topics that pertain to a wider audience, rather than network troubleshooting for a single user.
 

·
Wireless member
Joined
·
27,111 Posts
Unsubscribed
 

·
Registered
Joined
·
664 Posts
@Spidacat, to @pepar's point, is there any possibility of you taking your WiFi network out of the equation temporarily for the purpose of troubleshooting?

Would it be feasible for you to connect your WI-DG via the Ethernet port (CAT-5/6) and make a direct connection to see if you continue to have disconnects? Even then, I don't know if that is functionally possible with the WI-DG or if it's still going to try and connect to your WiFi, so ideally you'd want to turn off the WiFi on your router at the same time to (theoretically) prevent that scenario.

I know that's a lot to ask and I presume not a realistic possibility for you or perhaps you've already tried that. If you could go this route, it would determine definitively whether or not the WiFi network is a factor at all.
It is possible, but considering the location of the router I would probably need a 100 foot cable. I guess I could temporarily disconnect the router from my desktop (not wireless) and move it downstairs near my living room HT just to see what happens. I'll keep this in my back pocket in case your other recommendations don't work out.
 

·
Registered
Joined
·
664 Posts
Sorry Jerry I wasn't trying to hog the post, but I thought this was the most appropriate place. If you think it should be moved, please let me or an admin know.

HT Geek, thanks for the clarifications. I was trying to avoid dealing with the manufacturer. I wrote them about another issue and it took a long time for a response that wasn't very helpful.
 
4801 - 4820 of 5281 Posts
Top