AVS Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
It's a feature used to annoy you into buying the pay per view channels and

anything else they can sell you.

Some say it is a bug in the box,it sure bugs me!

I think they do it on purpose.
 

·
Registered
Joined
·
780 Posts
It's a known "feature". You can call Mitsubishi who will tell you that they've never heard of this problem and no-one has reported it before which has been their standard answer for each problem I've reported.


Tony
 

·
Registered
Joined
·
5,658 Posts
I have reported this problem to Mitsubishi and they have acknowledged that it is a problem and they are working on a solution. I suggest you (and everyone else) call them and complain. The more complaints they hear the more motivated they might become to fix it. They did not give me a time frame when it will be fixed.


I have also complained to DirecTv about this issue and they said they'd elevate the matter to their technical dept.


The problem with these particular channels is that they aren't always being broadcast. Most of the DirecTv channels are always On, always available. Some channels, like 190, 195, RSNa, NBA, NHL, (and soon to be baseball) are only ON when they are needed. When they are not needed they are turned off. When they are turned back on the Mits receiver thinks it's a new channel and promptly adds it to the fav channel list. My old Sony would at least remember the channel after the first time but this appears to be a bug in the Hughes design.


Again, please call Mit's (or Toshiba, or Highes) and complain.....


------------------

Geof
 

·
Registered
Joined
·
1,100 Posts
I've been using my hd500 for a few weeks now and worked out most of the problems with 1 exception. After going through the favorite channel lists (A,B,C,D) and turning off ALL 600, 700 and 800 channel numbers I find that some of these same channels are showing back up in my favorite lists again. As time goes on more and more of these excluded channels are showing up. Has anyone else experienced this problem or do I have a defective STB?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top