AVS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·

Purchased this projector in 2009,  Barely used this in my home-theater,  This week wanted to watch a movie after 6months from the its last use.  Turned projector ON with remote,  it made some clicking noise for few seconds (never heard before) light never turned on,  then went back to standby mode.  (when turned on with remote, 2 green lights are on, then red light blinked and turned off,  I see only 1 red light now indicating projector powered on).  This was very expensive at the time,  Not sure either LAMP went out or Projector itself gone bad,  don't know how to troubleshoot,  appreciate if I can get any troubleshooting hints. 
 

·
Registered
Joined
·
586 Posts

Quote:
Originally Posted by pkbhavani  /t/1500306/mitsibosjo-hc6500-projec...tartup-and-goes-to-standby-mode#post_23964691


Purchased this projector in 2009,  Barely used this in my home-theater,  This week wanted to watch a movie after 6months from the its last use.  Turned projector ON with remote,  it made some clicking noise for few seconds (never heard before) light never turned on,  then went back to standby mode.  (when turned on with remote, 2 green lights are on, then red light blinked and turned off,  I see only 1 red light now indicating projector powered on).  This was very expensive at the time,  Not sure either LAMP went out or Projector itself gone bad,  don't know how to troubleshoot,  appreciate if I can get any troubleshooting hints. 

Troubleshooting begins on page 40 of the manual.

http://www.projector-manual.com/manuals/mitsubishi/Mitsubishi_HC6500.pdf
 

·
Registered
Joined
·
650 Posts
Un plug it wait a minute or two and try it again. See if you get ANY light from the lens at all . If not remove and check the lamp. Look at it head on and see if its cracked or looks like a spiders ass - Bohanna
 
1 - 3 of 3 Posts
Top