AVS Forum banner
1 - 3 of 3 Posts

2 Posts
Discussion Starter · #1 ·
I've been experiencing dropped frames/lag/choppy playback and it just started out of no where and I don't know how to fix it.
I've looked through countless forums and tried a number of different configurations with MadVR and LAV filters and Reclock.

For an overview.
I'm trying to play 4K mkv files HEVC x265. I have my computer hooked up to my 4K tv via hdmi. I am using a 40ft fiber optic cable and it supports hdmi 2.0. I also have my main monitor hooked up to the same computer via DVI-D. (Don't know if this makes a difference).
I'm playing the movies on MPC-HC with MadVR and LAV filters.
I'm playing the movie over my home network, I store them on my main computer and I access them from my computer in my room.

My hardware is as follows:
AMD Ryzen 7 1700
16gb of DDR4 memory at 3000MHz
Nvidia GTX 1060 SSC
TV is a Vizio E70-E3 running at 23hz
The movies are stored on a regular 4TB hard drive.

So here's the thing I don't think its my hardware because I've already watched a few movies and they worked flawlessly. But feel free to correct me.
All of a sudden they start getting all choppy.

I thought maybe it was the network connection. Nope. Only maxes out around 13%

Maybe my GPU can't handle the settings I put on it? I don't think so, its only maxing out at 60%

Maybe the CPU is struggling? Nope, it maxes out at 5%

So task manager is telling me everything is fine.
I start messing around with MadVR and LAV filters. I mess around for hours.
I finally got a configuration where i think is fine. Again feel free to correct me.

I think its fine only because my clock deviation is low.
All the queues are filling up.
Rendering stats hover around 10 or so.
I also think this is good because during this trouble shooting I've had movies with higher clock deviation, queues weren't filling up, and the rendering stats were hovering around 20 and those were playing fine!

I got this configuration and the movies that play fine are still playing fine with no frames drops or anything. But there's still movies that only get a few minutes in and start lagging.

So I don't think its my system and I don't think MPC or MadVR so I'm thinking its the movie it self? Well no, there's some movies i watched last week and they worked fine and now they don't want to work.

I thought maybe because some movies had higher bit rates and higher file sizes than the ones that are working now. Well no, one of the first movies I watched was 80gb with a 71mb/s bit rate, which is one of the biggest files that I have and it use to work perfectly fine.

I thought maybe a background process was dropping the frames somehow? Maybe but those processes are running for all the movies, even the ones that are working so why would a background process make some movies lag and others not.

Referring to the OSD attatchment:
This is what it looks like for ALL movies.
This is on a movie that currently works flawlessly with the settings that I have currently. (Disregard the repeated frames it does that when i press play from time to time)
This is exactly the same for a movie that lags a minute or 2 in.
When it lags, the frames dropped spike up obviously and the queue go down to 0-1.

Referring to the Task Manager attachment:
This is what it looks like when I'm playing a movie.
Disregard google chrome I usually have it closed.

Refer to my MadVR settings and my LAV filter settings.
I'd like to keep them like this because this is actually the best results I've gotten regarding all the numbers but idk its still lagging on some movies and not others so if i need to change something I will.

Please Please Please someone help. I don't know what to do anymore!


1,455 Posts
To be honest, just about every setting you have changed is for the worst. Default everything and start over. Too lengthy to suggest what to change. There is a guide in my signature that has a link to a .bin file you can d/l and replace in madVR with yours. It has all profiles setup to save you the hassle. The settings will be very close to what your 1060 is capable of. Delete my 'Devices' after adding it and keep yours. There are also pictures linked to that guide showing all the settings if you'd like to do it manually yourself.

Your LAV Filters adjustments are also way off. At least change your Cuvid setting to D3D11 auto native and use ordered dithering.

If you still have problems, it won't be because of software settings. Most likely would be your network even though you think it is perfect. To confirm (if need be), copy a problem playback file local to your desktop and play it from Windows Explorer. Then post back your results.
1 - 3 of 3 Posts