AVS Forum banner
Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter · #1 ·
Hi all,

I hope someone can help me out.

I have been using me HTPC (windows XP, Theatertek, Radeon 7200) extensively for DVD viewing. As in my country DVD prices have escalated, I have been ripping rented ones for my own use.

Formerly I had a 80G Seagate barracuda as master (only) hardisc, of which a 30G partition was dedicated for DVD ripping storage. And recently, I decided to install another 80G Barracuda unit for DVD ripping use only, in slave configuration.

I tried a few ripping on my new HD, but the ripping speed was very low, about 1.2X average, while I get up to 6.0X speed on the master HD.

Checking the PC settings, I found out the slave HD has not DMA enabled.

So, I have a master HD with Ultra DMA mode 5 and a slave HD with PIO mode enabled, where in the former I can get up to 6.0X ripping speed and a poor 1.2X on the Slave HD.


I checked HD physical integrity with Seagate software , and checked OK. Rechecked IDE cable connection and looks ok to me.

Moreover, I have tried forcing DMA to no avail. I toggled between “PIO only†and “DMA if available†in the Current Transfer Mode drop-down box. Nothing, nada. Still PIO mode.


Lastly, following some recommendations, I opened the following registry key:

HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Control\\Clas s\\{4D36E96A-E325-11CE-BFC1-08002BE10318}

Where I opened the 0001 subkey (the slave HD is on primary IDE channel), and deleted the SlaveIdDataCheckSum value. Then I rebooted the PC. Unfortunately, the transfer mode didn’t change to DMA.


I have read some people have solved this issue by uninstalling the IDE channel where the device is connected and reboot the PC, letting Windows re detect the IDE channel.

Thing is, I’m too chicken to do that, as my OS is located in the primary IDE channel, and I’m afraid I might make my HTPC useless.

Any help is much appreciated.

PS: I’m very green about this HTPC stuff.

Regards,

Jose
 

·
Registered
Joined
·
4,412 Posts
Quote:
I have read some people have solved this issue by uninstalling the IDE channel where the device is connected and reboot the PC, letting Windows re detect the IDE channel.
Come on, give a whirl, what can go woornng!!!!


But seriously, I had the same problem, tried to toggling the DMA state and it didn't really work either.


So first make sure that everything is connected correctly, and when you boot, go into the BIOS setup and check to make sure the settings for the drives are set to auto, then save and exit, as it boots watch to see how the hard drives are listed in the boot-up screen should be listed as Ultra DMA mode 4 or 5, if this is alright and checking the IDE channel does not show that the drives are in DMA mode then...DO IT!


Un-install the IDE channel, reboot and let windows find it and re-install it, don't worry I've done this few times, and it always comes back;)


Oh yeah, the last time I did this was on my HTPC primary IDE channel, and it worked like a charm!
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #3 ·
Al,

How do I get into BIOS setup?

I told you I'm green....super green regarding HTPC!!!

I'm still preoccupied about unistalling primary IDE channel where my Windows XP is located? How is this possible?

I guess I will have to prepare a back up image before I go for it!!

Is this the only way to solve it?...sigh....

chicken.....chicken..... That's what I am!!!!

thanks you.

regards,

Jose
 

·
Registered
Joined
·
1,206 Posts
As soon as you bootup and see your bios name hit the "del" button.

Also when you go to select your dma to on I have read it is better to shut down the computer for a minute or two after doing so.



peace
 

·
Registered
Joined
·
342 Posts
Quote:
Originally posted by josesol
I have read some people have solved this issue by uninstalling the IDE channel where the device is connected and reboot the PC, letting Windows re detect the IDE channel.

Thing is, I’m too chicken to do that, as my OS is located in the primary IDE channel, and I’m afraid I might make my HTPC useless.

Any help is much appreciated.

PS: I’m very green about this HTPC stuff.

Regards,

Jose
Just do it, Start Settings-->Control Panel-->System-->Hardware Tab-->Device Manager--> IDE ATA/ATAPI controllers and select primary/secondary and delete them both


Reboot and plug and play kicks in and installs the right driver. Its a known bug in winxp and trust me, you wont lose ANY data just by removing the UDMA driver from winxp :)
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #6 ·
Hi guys,

Ok, I checked BIOS and found out Primary IDE channel - slave shows "none": so I guess somehow the HD is not recognized. Something to do with the 80-pin cable maybe? Any idea what might produce this condition?

I configured the jumper in the second HD as slave (no jumper), and First HD as master.

help much appreciated.

regards,

Jose
 

·
Registered
Joined
·
4,412 Posts
The 80 pin cable won't be the problem if you have it installed correctly! Make sure that the blue or red end is in the motherboard, the slave should be in the middle (grey) connector and the master should be on the end (black) connector.
 

·
Registered
Joined
·
4,412 Posts
Now for the jumper settings, use this picture as your guide. Power is also connected right?
 

·
Registered
Joined
·
4,412 Posts
If all of the above is correct (cable, power, jumpers) and you have the BIOS set to "auto" for Primary IDE channel, slave position and it still is not recognized...


Then try a different cable, or, move the slave drive to the secondary IDE channel set the jumpers for the drive's position and try it there (remember the BIOS settings).


POST ;) your results!
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #10 ·
Hi Al,

I selected "auto" in BIOS and all went beautifully.

Got ULTRA DMA 5 in slave HD!!!

thanks you very much!!!

Jose
 

·
Registered
Joined
·
4,412 Posts
Quote:
Originally posted by josesol
Hi Al,

I selected "auto" in BIOS and all went beautifully.

Got ULTRA DMA 5 in slave HD!!!

thanks you very much!!!

Jose
That's great Jose!


Glad to have helped out!
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top