AVS Forum banner
Status
Not open for further replies.
1 - 20 of 20 Posts

· Registered
Joined
·
384 Posts
Discussion Starter · #1 ·
I have two Home Theater Master (URC) MX-500 remote controls. I love them. I just bought a third unit (with the "Gemstone" buttons).


Home Theater Master has changed the joystick on this "upgrade." The center "select" button works intermittently. It is so hard to find the sweet spot that the joystick is virtually unusable.


At first I thought I just had a defective unit, so I contacted the dealer. The dealer (BlueDo.com, formerly RRDeals.com) directed me to Home Theater Master who supposedly has an active recall/exchange program for this problem. Home Theater Master sent me a new unit.


The new unit is as bad as the original. They have apparently not corrected the joystick problem.


The MX-500 is a beautifully designed device. It is a shame that URC has made a design/manufacturing decision that cripples a great product.
 

· Registered
Joined
·
183 Posts
I also noticed this on my new MX-500 with gemstones. There is a "learning curve" to the button and it takes a bit to get used to but once you do, its great.


What I finally realized is not to "*****-foot" the button at all trying to find the sweet spot and hit it. Just hit the thing, and I think its a time sensitive function. The faster you hit the button and release the better it works. Give it a try.
 

· Registered
Joined
·
384 Posts
Discussion Starter · #3 ·
Hi Shane,


Thanks for the response. I'm glad you found a technique that works for you. Unfortunately, I can't make it work. I just tried what you suggested. After 23 key presses, the MX-500 finally sent the code. On my other two units, one key press is all it takes.
 

· Registered
Joined
·
654 Posts
balpers: I've owned 2 Mx-500's. (Nothing wrong with the 1st one. I just ended up being able to trade up to a brand new one for virtually nothing. Legal too!)


Anyway, my 1st MX-500 was (from what I can figure at remotecentral) the second thumbpad version. It always worked pretty good but once in a while I would execute an up or down (or whatever) instead of the enter I was wanting.


Now with the GemStone2 version I now have, I have never had 1 problem. Zero! This is after over a month's worth of use.


IMO, I'd try again at HTM. Let them know what's going on. They should be able to make it right.


Good luck!
 

· Registered
Joined
·
384 Posts
Discussion Starter · #6 ·
This is an update after another round with URC.


I spoke to them again. They said that the select button on the second remote they sent me is the latest one and it is as good as it gets.


Apparently, this is my problem. I must have weak perceptual/motor skills that prevent me from pushing a button properly.


As I mentioned above, it took 23 attempts to get the remote to send the code to my UltimateTV box. My two other MX-500 remotes accomplished the same task with one attempt. My perceptual/motor skills must be highly selective. They only fail with the Gemstone unit.


It is clear that URC is satisfied with their new design (they know how to push buttons). So, I guess this is the end of the line. I just emailed BlueDo to request an RMA for a refund. Too bad. I really wanted that Gemstone unit.


Burt
 

· Registered
Joined
·
654 Posts
Hmmm!


Well, from my viewpoint, it would seem like they would at least try exchanging the unit one more time. Even if the thumb pad is the latest and greatest, it could still be defective on your individual remote.


Hopefully Randy will do right by you. I have bought 2 different remotes from him and have been very pleased. I plan to buy an MX-700 from him once they're out.


Sorry about your bad luck!
 

· Registered
Joined
·
384 Posts
Discussion Starter · #8 ·
Yeah, Randy has been great. Within 15 minutes of my email he sent me an RMA. This is my third remote from him. If I go for another one, he will get my business again.


The more I think about this, the more it gnaws at me.




On engineering arrogance:


The solution to bad engineering is: Blame the user. The attitude at URC seems to be "That button takes a little getting used to." [direct quote]


It shouldn't be necessary to train users on how to push a button. Many of us have been doing it for years. I have even been successful in alerting people to my presence by pushing a doorbell.




Good luck on your MX-700. It looks like it should be a great unit. I just hope they don't use the same joystick.


Cheers,


Burt
 

· Registered
Joined
·
183 Posts
Quote:
Originally posted by balpers
The attitude at URC seems to be "That button takes a little getting used to." [direct quote]

I know I have stated this before, but I couldn't agree with this statement more.
 

· Registered
Joined
·
1,528 Posts
Anyone have any information about the release date for the MX-700? URC's website just continues to display "Coming soon". Their last press release on the MX-700 from December 2001 stated the first quarter of 2002. Maybe they jumped the gun a little there.


Ken
 

· Registered
Joined
·
654 Posts
Rumors at remotecentral.com seem to point to very soon.


There are a couple of beta testers that have been posting their thoughts for a while. Also, another rumor is that HTM has received a first shipment at their warehouse.


I'm waiting until BlueDo gets them in stock before I place my order...
 

· Registered
Joined
·
384 Posts
Discussion Starter · #13 ·
I think all the new Gemstone units have the bump. I don't even notice it with the remote in my hand.


Burt
 

· Registered
Joined
·
384 Posts
Discussion Starter · #16 ·
Now that the MX-700 has been released, can anyone confirm if URC is using the same joystick as the Gemstone MX-500s, or have they switched to one that works.


Burt
 

· Registered
Joined
·
654 Posts
I've pre-ordered an MX-700 from bluedo.com. I'll let you know once I get it... (Based on what I've gathered from the MX-700 beta testers, I believe it is the same.)
 

· Registered
Joined
·
501 Posts
Got my MX-700 and having problems getting the PC to recognize it. I've tried 2 pc's and 4 serial ports (all known to work with other devices). Any suggestions before I return it due to poor QA?
 

· Registered
Joined
·
654 Posts
David: Hmmmm. I can't say I'm happy to see this.


I have downloaded the MX Editor and tinkered a bit with it but it may be a week or two before I get mine (hopefully no more than that!) The only thing I can think of is to close as many programs as you can to free up as many resources as possible. Could also be a bad cable???


Have you contacted HTM to see if they have any ideas? You also might try the HTM forum at remotecentral to see if any of the beta testers have any ideas.


Let us know what you find out!
 

· Registered
Joined
·
501 Posts
I got it from the dealer after Universal Remote's business hours and couldn't contact them. It is possible the cable is bad but doubtful its applications running causing the trouble. I've tried this from two pc's from known good COM ports.


I have no way of testing the cable. It uses a earphone jack on one end and a DB9 connection on the other. Not a standard cable.
 
1 - 20 of 20 Posts
Status
Not open for further replies.
Top