AVS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a WD73738(or 838), it's about 6.5 years old, I'm on my 3rd lamp (replaced 12 mos ago)... a couple of weeks ago it would shut off (after a loud "pop"), then the green light would flash and some orange. So I waited a few mins, turned it on again and it worked fine... but after a few days it happened again, so I waited a bit and turned it back on, only that time it just stayed on for a few hours before shutting off. After a few more days of the tv being off more than it was on, I did some research, and could not find a solution to the light show it was displaying, so I tried getting some canned air and blew out the vents in the back/sides... well, that seemed to work b/c for 2 weeks, everything was back to normal. 2 days ago the same problem started again.



As far as the error lights, this is what happens: first a rapid green blinking light (30 seconds), then a "click", the blue light flashes (once), then the rapid green flashing light (10 seconds), this repeats 3-4 times, then the rapid green flashing light (30 seconds), which is followed by 2 sets of blinking orange lights (8x each), then the rapid green flashing light (10 seconds), then another 2 sets of blinking orange lights (34x each), then the rapid green flashing light (10 seconds), then another 2 sets of blinking orange lights (24x each). Then after stopping for a few seconds, the whole cycle repeats. The tv will still come on and the picture is good*, it just wont stay on.



* picture is dimming a little and takes a bit to fully "warm up".


Most recent "error code": 2 sets of 12 orange, repeated 3 times with rapid green flashing light between.



Any assistance would be appreciated.
 

·
Registered
Joined
·
157 Posts
Seems like there are no Mits folks around anymore to help. I have had a couple posts also waiting for any assistance. We are a few years too late it appears....
 
1 - 4 of 4 Posts
Top