AVS Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I have a Harman Kardon AVR 300 reciever. It'll decode DTS and DD 5.1 when the source is a DVD, but when I play a DIVX movie with AC3 sound it reads it as plain old stereo. I've tried switching out the sound card. I first had a Hercules Fortissimo II (with optical out), now I'm using a Phillips Accoustic Edge (with coax out).


I've gotten pass-through to work fine for DTS or DD 5.1 playing DVD's with either WinDVD or PowerDVD. But when using either of these players to play DIVX AC3 movies, I get nothing at all when the s/pdif pass though option is enabled, and stereo when it's diabled.


I'm running Win98 SE, on a PIII 933Mhz system using the Phillips Acoustic Edge sound card. I've installed the AC3 codec for Win98, along with the latest DIVX codecs.


Is there something I'm not doing? Anyone else had these problems?
 

·
Registered
Joined
·
159 Posts
Did you try with Zoom Player ? I have it play AC3 DivX without to much hassle, and at least you can figure out which filters are involved...

I don't really remember, but I think I never managed to get AC3 DivX to output real DD with either PDVD or WinDVD.
 

·
Registered
Joined
·
276 Posts
I always use PowerDivXNextGen for AC3 DivX movies. You still have to go into audio filter properties to enable SPDIF. Haven't figured out how to get it to stick. Prolly a simple registry fix.


Arnax,

Did you make a mediagraph to get your AC3 DivX to work in ZP? Please describe what you've done.


Slobbie
 

·
Registered
Joined
·
276 Posts
Here's how to get the SPDIF to stick in PDNG (From the AC3/SPDIF FAQ on the PowerDivx forum):


__Why don’t the SPDIF settings stick in the InterVideo filter after I reboot? This is a known issue and currently you can change the following registry entry to make them stick. HKEY_LOCAL_MACHINE\\SOFTWARE\\InterVideo\\WinDVD\\Audio Set the DWORD value to 6 to enable SPDIF. (This key may have to be entered manually if it doesn't exist)
 

·
Registered
Joined
·
144 Posts
Did you register the Intervideo audio codec (iviaudio.ax) filter on your system yet? You get them all in a zip file called "audiofilters.zip" or you can install WinDVD (even the trial will work). Then you need a player that lets you get at your filters so you can select S/PDIF on the filter property page.


Good luck.


-rick


P.S. Check the download section of Doom9.net's site.
 

·
Registered
Joined
·
276 Posts
Well, I have WinDVD and it works fine for DVD's. I don't know if PDNG uses the same WinDVD audio filter that came with the player or what, but I do know that it won't stick in PDNG. I'm not at home right now so can't try it out.


I don't want that audio filter set you mentioned. I have all the major players and the last thing I need is more filters floating around my system:)


I only spent like 5 minutes trying to get ZP to play DivX AC3. I know the info is out there, just haven't pursued it yet.


slobbie
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #8 ·
I tried using the Zoom Player with no luck. I installed the audio filters from doom9, and they didn't show up in any of Zoom's related options menus. Arnax, can you give me a little more info on how you got AC3 to work with Zoom Player?


I also tried installing PowerDivX NextGen, but when I went to run it, it gave me an error, said there was a missing DLL. Not sure what the deal is there.


I have the audio filters installed, and I believe I have the Intervideo audio codec, because I use WinDVD.


Are there any other players out there that are good at playing AC3 DivX movies?


Erick
 

·
Registered
Joined
·
408 Posts
Erick - in zoom, just go to the options dialog, external, windvd audio output and set to SPDIF. Connect your card to your receiver via toslink or spdif, and then load your divx with ac3. This should work without any doubt.


BTW I believe if you install one of the AC3 divx decoder filters, it will render the ac3 FL and FR channels only as standard audio via dsound/waveout.


If that doesn't work, you need to check your sound drivers.


I'm using WinXP and a el cheapo SBLive (not the 5.1!) with spdif out.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #10 ·
I set the WinDVD (and for PowerDVD as well) audio to SPDIF in Zoom's options menu, and tried playing a DIVX AC3 file and it still didn't work. I also set the output in the Philips Acoustic Edge control panal to SPDIF - DTS/DD pass though. It looks as though the sound is not making it to my receiver to be decoded. The only way I can get sound to go though is to disable the pass though, then I can only get stereo.


I'm going to be reinstalling windows soon, perhaps that will fix it. But I'm not holding my breath. Thanks to everyone for your help.


Erick
 

·
Registered
Joined
·
159 Posts
To make AC3 DivX work with Zoom Player, you need to register :


- Morgan Stream Switcher filter (mmswitch.ax)

- an audio filter capable of passing through SPDIF a DD audio stream (like iviaudio.ax)


Then in Zoom Player, go to DVD options, unregister all filters, and then register a set that includes the audio filter you want to use.

Also set the output to SPDIF from ZP for the chosen filter (I don't remember the option name, I'm not on the HTPC), or do it manually in the registry if you prefer.


At this point I quit and relaunch ZP to avoid inconsistencies.


Then play your AC3 DivX, and check from the filters properties what are the filters in use. You should have something like :


Default DirectSound Device

Video Renderer

Morgan Stream Switcher

Intervideo audi decoder

DivX Decoder

AC3 from AVI XForm (greyed)

AVI splitter (greyed)

Source File (greyed)


Make sure the audio filter is set to use the SPDIF output.


Depending on the card, you might not be able to output on the SPDIF using the default DirectSound device. With the Fortissimo I own, I can but then there's a lot of video stuttering. Go guess why...


So in order to force Zplayer to use the Default WaveOut Device in the graph, you need to create a .filters file (name it as you like, only the extension matters) with this one and only line :

LoadFilter({E30629D1-27E5-11CE-875D-00608CB78066},Default WaveOut Device)

And then in ZP options select "using filter file" in the Manual filters options and select your file. Close and relaunch ZP.


To summarize, I didn't have to build a graph, only make sure what I need is registered and preload the Waveout device to force its use in the graph...


Let me know if it's working now :)
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top