AVS Forum banner
1 - 20 of 52 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter · #1 ·
Anyone running 0.22 trunk?


I've got it installed, and so far, it seems stable. I'm interested in it, cause I want to pick up a pair of HD-PVRs and get rid of my ComCrap DVR forever!


One problem I'm having is that I have an NVIDIA 9500GT. I'm trying to get VDPAU configured. (I've previously used 0.21-fixes from the Avenard repo and had VDPAU working fine.) I created the new profile, specified 'vdpau', as explained here:
http://avenard.org/media/MythTV_%26_...%26_VDPAU.html

(See the first question in the Quick F.A.Q. section.)


But, I still don't get VDPAU. Anyone had a similar problem w/ 0.22?


-Mark
 

·
Premium Member
Joined
·
560 Posts
Just switched to trunk this past weekend. And have two HDPVRs working (yeah!).


I'm using LinHES R6 so it was still pre-compiled for me. I'm assuming you checked out the source and built it yourself. So perhaps a configuration option?


I did not set any "resolution rules" when I added VDPAU as described in FAQ 1. I guess it's something you can try.


What is mythfrontend spewing out at run-time?


One more thing: Try no deinterlacing first.
 

·
Registered
Joined
·
157 Posts
Discussion Starter · #3 ·
Hi,


Heh, sorry, I should have mentioned, I'm on Ubuntu 9.04 and I'm using the Mythbuntu Weekly Builds to install 0.22 trunk, so, I did not build from source.

From what I read, VDPAU should be enabled in these builds.


I can provide mythfrontend output logs when I get home this evening.


Thanks!


-Mark
 

·
Registered
Joined
·
501 Posts
I've been using 0.22 svn for about the past six months. It's mostly stable. I still get the occasional "video frame buffering failed too many times" error, which doesn't happen with 0.21-fixes, but they are more rare with the latest code.


VDPAU works fine for me, but I build from source, I don't download prebuilt binaries.


-- Kevin
 

·
Registered
Joined
·
157 Posts
Discussion Starter · #6 ·
Kevin,


Which NVIDIA card do you have?


What have you defined for your profile, to enable VDPAU?


-Mark
 

·
Registered
Joined
·
501 Posts
I'm using onboard NVIDIA 8200 video, on two different motherboards.


I'm at work now, so I don't have access to the profile settings I used. Basically, any profile setting works, as long as you specify VDPAU. I played around with the different de-interlacers. The most advanced one (don't remember what it's called) won't work on my IGP, it's too slow. I get choppy video. The other, less demanding de-interlacers work fine, though.


When I get home, I can give you my exact profile setup, if you like.


-- Kevin
 

·
Registered
Joined
·
501 Posts
Also, if you have an AMD CPU and are using onboard video, make sure you disable the ondemand CPU governor, or at least set the minimum frequency to 1.8 GHz, otherwise you'll get choppy video even with VDPAU enabled.
 

·
Registered
Joined
·
157 Posts
Discussion Starter · #11 ·
Here's what I get when mythfrontend starts up:

2009-08-06 19:39:18.496 mythfrontend version: trunk [Unknown] www.mythtv.org

2009-08-06 19:39:18.613 AudioPulseUtil: Suspend Success

2009-08-06 19:39:18.648 Using runtime prefix = /usr

2009-08-06 19:39:19.914 Empty LocalHostName.

2009-08-06 19:39:19.914 Using localhost value of jupiter

2009-08-06 19:39:20.072 New DB connection, total: 1

2009-08-06 19:39:20.120 Connected to database 'mythconverg' at host: localhost

2009-08-06 19:39:20.120 Closing DB connection named 'DBManager0'

2009-08-06 19:39:20.155 ScreenSaverX11Private: Gnome screen saver support enabled

2009-08-06 19:39:20.156 DPMS is active.

2009-08-06 19:39:20.162 Primary screen: 0.

2009-08-06 19:39:20.165 Connected to database 'mythconverg' at host: localhost

2009-08-06 19:39:20.166 Using screen 0, 1920x1080 at 0,0

2009-08-06 19:39:20.251 MythUI Image Cache size set to 20971520 bytes

2009-08-06 19:39:20.255 Enabled verbose msgs: important general

2009-08-06 19:39:20.568 The theme (defaultmenu) is missing a themeinfo.xml file

2009-08-06 19:39:21.618 The theme (defaultmenu) is missing a themeinfo.xml file

2009-08-06 19:39:21.704 Desktop video mode: 1920x1080 60 Hz

2009-08-06 19:39:21.848 Primary screen: 0.

2009-08-06 19:39:21.849 Using screen 0, 1920x1080 at 0,0

2009-08-06 19:39:21.850 Using theme base resolution of 1280x720

2009-08-06 19:39:21.862 LIRC, Error: Failed to connect to Unix socket '/dev/lircd'

eno: No such file or directory (2)

2009-08-06 19:39:21.862 JoystickMenuThread Error: Joystick disabled - Failed to read /home/mjb/.mythtv/joystickmenurc

2009-08-06 19:39:22.280 Using the OpenGL painter

2009-08-06 19:39:22.525 Loading base theme from /usr/share/mythtv/themes/MythCenter-wide/base.xml

2009-08-06 19:39:22.881 Loading base theme from /usr/share/mythtv/themes/default-wide/base.xml

2009-08-06 19:39:22.952 Loading base theme from /usr/share/mythtv/themes/default/base.xml

2009-08-06 19:39:22.998 Current Schema Version: 1238

2009-08-06 19:39:23.003 Connecting to backend server: 192.168.1.110:6543 (try 1 of 5)

2009-08-06 19:39:23.014 Using protocol version 45

2009-08-06 19:39:23.192 Registering Internal as a media playback plugin.

2009-08-06 19:39:23.294 Cannot load language en_us for module mytharchive

2009-08-06 19:39:23.352 Cannot load language en_us for module mythbrowser

2009-08-06 19:39:23.354 Registering WebBrowser as a media playback plugin.

2009-08-06 19:39:23.354 Cannot load language en_us for module mythbrowser

2009-08-06 19:39:23.526 Cannot load language en_us for module mythflix

2009-08-06 19:39:23.648 MMUnix::GetDeviceFile(/sys/block/sdb/bdi), Error - udevinfo failed to start!

2009-08-06 19:39:23.648 MMUnix::AddDevice() Error: failed to stat /dev/bdi,

eno: No such file or directory (2)

2009-08-06 19:39:23.657 MMUnix::GetDeviceFile(/sys/block/sdb/power), Error - udevinfo failed to start!

2009-08-06 19:39:23.657 MMUnix::AddDevice() Error: failed to stat /dev/power,

eno: No such file or directory (2)

2009-08-06 19:39:23.664 MMUnix::GetDeviceFile(/sys/block/sdb), Error - udevinfo failed to start!

2009-08-06 19:39:23.671 MMUnix::GetDeviceFile(/sys/block/sr0/bdi), Error - udevinfo failed to start!

2009-08-06 19:39:23.672 MMUnix::AddDevice() Error: failed to stat /dev/bdi,

eno: No such file or directory (2)

2009-08-06 19:39:23.679 MMUnix::GetDeviceFile(/sys/block/sr0/power), Error - udevinfo failed to start!

2009-08-06 19:39:23.679 MMUnix::AddDevice() Error: failed to stat /dev/power,

eno: No such file or directory (2)

2009-08-06 19:39:23.684 MMUnix::GetDeviceFile(/sys/block/sr0), Error - udevinfo failed to start!

2009-08-06 19:39:23.685 MonitorRegisterExtensions(0x100, gif,jpg,png)

2009-08-06 19:39:23.685 Cannot load language en_us for module mythgallery

2009-08-06 19:39:23.717 Cannot load language en_us for module mythgame

2009-08-06 19:39:23.781 Cannot load language en_us for module mythmovies

2009-08-06 19:39:24.043 MonitorRegisterExtensions(0x40, mp3,mp2,ogg,flac,wma,wav,ac3oma,omg,atp,ra,dts,aac,m4a)

2009-08-06 19:39:24.048 Cannot load language en_us for module mythmusic

2009-08-06 19:39:24.110 Cannot load language en_us for module mythnews

2009-08-06 19:39:24.233 Cannot load language en_us for module mythvideo

2009-08-06 19:39:24.355 Cannot load language en_us for module mythweather

2009-08-06 19:39:25.779 Loading window theme from /usr/share/mythtv/themes/MythCenter-wide/menu-ui.xml

2009-08-06 19:39:25.819 Loading menu theme from /usr/share/mythtv/themes/defaultmenu//mainmenu.xml

2009-08-06 19:39:25.820 Found mainmenu.xml for theme 'MythCenter-wide'

2009-08-06 19:39:25.823 Using NV NPOT texture extension

2009-08-06 19:39:36.618 Loading menu theme from /usr/share/mythtv/themes/defaultmenu//library.xml

2009-08-06 19:39:38.326 New DB connection, total: 2

2009-08-06 19:39:38.328 Connected to database 'mythconverg' at host: localhost

2009-08-06 19:39:38.444 Loading window theme from /usr/share/mythtv/themes/default-wide/recordings-ui.xml


2009-08-06 19:39:46.485 Loading window theme from /usr/share/mythtv/themes/default-wide/recordings-ui.xml



And when I actually play a program, I get:

2009-08-06 19:43:43.785 TV: Attempting to change from None to Watching WatchingRecording

2009-08-06 19:43:43.851 Using protocol version 45

2009-08-06 19:43:43.853 TV: StartPlayer(0, Watching WatchingRecording, main) -- begin

2009-08-06 19:43:44.875 mpegts_read_header: TS packet size = 188

2009-08-06 19:43:45.166 AFD: Opened codec 0xb230cc0, id(MPEG2VIDEO) type(Video)

2009-08-06 19:43:45.167 AFD: codec AC3 has 6 channels

2009-08-06 19:43:45.189 AFD: Opened codec 0xb379260, id(AC3) type(Audio)

2009-08-06 19:43:45.205 Opening audio device 'default'. ch 6(6) sr 48000

2009-08-06 19:43:45.206 Opening ALSA audio device 'default'.

2009-08-06 19:43:45.374 ALSA, Warning: mmap not available, attempting to fall back to slow writes.

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.838 Mixer unable to find control PCM

2009-08-06 19:43:45.839 Mixer unable to find control PCM

2009-08-06 19:43:45.839 Mixer unable to find control PCM

2009-08-06 19:43:45.839 Mixer unable to find control PCM

2009-08-06 19:43:47.349 NVP(0): Forcing decode extra audio option on (Video method requires it).

2009-08-06 19:43:47.359 OSD Theme Dimensions W: 640 H: 480

2009-08-06 19:43:47.527 Unknown font: descriptfont in textarea: description

2009-08-06 19:43:47.775 WriteAudio: buffer underrun

2009-08-06 19:43:48.886 TV: StartPlayer(0, Watching WatchingRecording, main) -- end ok

2009-08-06 19:43:48.889 TV: Changing from None to Watching WatchingRecording

2009-08-06 19:43:48.889 OpenGLVideoSync()

2009-08-06 19:43:48.894 Realtime priority would require SUID as root.

2009-08-06 19:43:49.183 ScreenSaverX11Private: DPMS Deactivated 1

2009-08-06 19:43:49.400 Video timing method: SGI OpenGL


The line that reports "(MPEG2VIDEO)", I believe indicates that VDPAU is not in use.

When I ran 0.21 w/ VDPAU patches, I'd get something like "(MPEG2VIDEO_VDPAU)".


-Mark
 

·
Premium Member
Joined
·
560 Posts

Quote:
Originally Posted by mythmaster /forum/post/16955428


somewhat OT:


is 1080i working on the HDPVR's yet?

Yes. And according to this page "native passthrough" output should work fine now too with the latest firmware, as changing "on the fly" is stable. Of course one needs to update the firmware on windoze.


I did a few 1080i recordings and they were fine. But I put my DirecTV boxes in 720p since all my screens are 720p.


Watching LiveTV has not been very reliable on my system. We don't do that much in our house so it's not really a problem for us. But I have seen changing channels three or four times will core dump mythfrontend. I haven't taken the time to check into it any further.


I noticed LinHES has made a new svn snapshot and I'll install it tonight.
 

·
Premium Member
Joined
·
560 Posts

Quote:
Originally Posted by mbobak /forum/post/16956967


The line that reports "(MPEG2VIDEO)", I believe indicates that VDPAU is not in use.

When I ran 0.21 w/ VDPAU patches, I'd get something like "(MPEG2VIDEO_VDPAU)".

Yes I think you are right. I'll check my log tonight to verify.


You probably have done this but make sure you disable the compositing extension of Xorg. "nvidia-xconfig --no-composite" or edit your xorg.conf file. Also enable "OpenGL VSync" in the MythTV playback setup. I think your log says you have it set but I thought I would just mention it just in case.


I was hoping the log would give more of a hint...it looks like Myth is just deciding to use something other than VDPAU.
 

·
Premium Member
Joined
·
560 Posts
It's really hard to say. Personally I did not want to wait any longer. I've been wanting the HDPVR ever since it was announced so I could record HD from the satellite box over the component instead of 480i over s-video. And with football coming up I decided to see how stable trunk was (so far so good!)


If you keep an eye on the roadmap , when it gets near the open tickets will be moved to 0.23 from 0.22. When that happens a release should follow soon. It really hasn't changed much the last few weeks...a few more bugs, a few more fixes but staying around 75%.
 

·
Registered
Joined
·
157 Posts
Discussion Starter · #17 ·
The other thing you can do is look here:
http://svn.mythtv.org/trac/query?sta...milestone=0.22


....for how many tickets have a priority of "Major" or higher. Right now, that number is 22. It may not sound like much, but, these statuses don't change very often, and that number is actually higher now than I've ever seen it in the past several months. I've seen it as low as 16.


I suspect it's going to be a while.....


-Mark


PS Meanwhile, it's only been a few days for me, but 0.22 trunk is (so far) surprisingly stable.
 

·
Registered
Joined
·
247 Posts

Quote:
Originally Posted by mbobak /forum/post/16962200


I suspect it's going to be a while.....

The reason I ask is I am hoping to setup a HTPC this fall/winter and am kind of hoping it will be released by then. Of course time will tell when!


I will keep half an eye on the roadmap and Magor + Critical bugs.


Thanks!
 

·
Registered
Joined
·
226 Posts
does anyone happen to have instructions on how to upgrade from 0.21 to 0.22-trunk?
 
1 - 20 of 52 Posts
Top